billweber
Contributor
Contributor

Windows 7 Aero and Office 2013 Incompatibility

Jump to solution

I originally asked this question in the Windows Community Forum, but it occurs to me that it might be related to VMware Tools and how they deal with Windows 7 Aero, so I'm copying the thread here.

So, I would like to run a Windows image on my MacBook Pro for backwards compatability.  Here is the image I've created.

MBP OSX 11.8.2 with VMware Fusion 5.0.1

Windows 7 6.1.7601 SP1 64-bit

Office 2013 15.0.4420.1017 64-bit (Final)

VMware Tools 9.2.1.818201

With Aero enabled, starting any Office 2013 application creates a  blank screen where you can see some artifacts when you mouse over them  and can close the app by clicking on the upper right hand corner  (presumably the "X" one would normally expect).


Disabling Aero produces normal Office functionality and of course makes all applications as ugly as the new Office.

Given the direction MS has taken on reducing functionality, I  understand if the answer to my question is MS wants you to disable Aero;  presumably so I'll get accustom to less functionality and be more  willing to downgrade to Windows 8.  But the blank screen  seems like a bug.

Do I have this wrong?  Is there a way to keep Aero enabled and still use Win7/Office15?

What I am posting is a screen print of my MBP screen so you can see exactly what I see.

Office 2013 is the only program that has this problem. 
I've noted it across two virtual machines running on the same laptop, both using Windows 7.

Here is Word off Aero.
http://ironbravo.com/public/20121027/Off%20Aero%201.png

Here is my desktop with Aero turned on.
http://ironbravo.com/public/20121027/On%20Aero%20Desktop%201.png

Here is Word on Aero.  Note the artifact search window when I mouse over it.
The application is otherwise black.
http://ironbravo.com/public/20121027/Word%20on%20Aero%201.png

I also tried to use an Aero feature of switching to a application with  the preview showing.  It shows black as well.  Here is that image.
http://ironbravo.com/public/20121027/Word%20on%20Aero%202.png

Excel on Aero has the same problem.
http://ironbravo.com/public/20121027/Excel%20on%20Aero%201.png

So does PowerPoint
http://ironbravo.com/public/20121027/PowerPoint%20on%20Aero%201.png

On both Excel and PowerPoint, I moused over the search box dialog when I took the screen shot.

What is potentially interesting is when the application starts I see the  splash screen and when it closes by selecting the hidden X in the upper  right corner, I see an animation of the screen minimizing.  It's very  notable because you see the theme colors of  the application, like Blue for Word, Green for Excel or Red for  PowerPoint.

So, I'm not sure how helpful screen shots of a black screen can be, but there they are.

To your question about compatibility mode, I verified that Windows 7 App  Compatibility is not turned on for this application, and I don't recall  turning it on for any other applications in the image.  The  verification I did was by viewing the application settings  from the Word 2013 Icon Properties dialog under the Compatibility tab.

My laptop has a 2880x1800 screen, so I reduced the size of the images here.
When running in full screen, rather than a window, the results are the same.
All of the files are located here if you want the original images.

http://ironbravo.com/public/20121027/

Thanks for your thoughts.

http://answers.microsoft.com/en-us/office/forum/office_2013_release-office_install/office-2013-windo...

My reasoning is that this functionality seems to only be a problem for the virtualized image.

So I'm curious if others have seen problems with Aero in this configuration.

0 Kudos
1 Solution

Accepted Solutions
avanish321
Expert
Expert

Instead of disabling 3d acceleration in vm settings have you tried disabling hardware acceleration in individual office apps? enable acceleration on vm.

Cheers! Avanish

View solution in original post

0 Kudos
4 Replies
avanish321
Expert
Expert

This is because office 2013 needs direct x 10 which is not yet available in fusion 5. I believe this will be supported soon.

workarond is to disable hardware acceleration.

For more details refer the KB Article

update : This is applicable for both fusion as well as workstation users.

Try any one of the workaround. I would suggest you to disable hardware acceleration in office apps rather than entire vm.

Cheers! Avanish
billweber
Contributor
Contributor

I've implemented turning off 3D Acceleration in the Fusion settings for the virtual machine with some success.

It has gotten me to a comfortable middleground where I have a Win7 non-Aero appearance.

So, thank you for that.

Two remaining questions.

- I still have occasional black boxes that appear when my mouse changes from one shape to another.  For example, when mousing over a link, I occasionally get a small black box that then changes to the proper image.  Is this an artifact of sub-optimal performance?

- If the hardware (VMware SVGA) only supports DirectX 9, why does Microsoft fail to a black screen?  That still seems like a bug.  Is there something I'm missing?

Thanks for the help.

0 Kudos
avanish321
Expert
Expert

Instead of disabling 3d acceleration in vm settings have you tried disabling hardware acceleration in individual office apps? enable acceleration on vm.

Cheers! Avanish

View solution in original post

0 Kudos
billweber
Contributor
Contributor

That is an improvement.

Still have the black box artifacts I mentioned, but Win7 is back to normal.

Thanks for the help.

0 Kudos