hollyerp
Contributor
Contributor

Win 8.1, Fusion 8, Display Settings

Hi,

I have just upgraded to Fusion 8 Pro from 7 Pro.

I already have a Win 8.1 VM and when I start it up, the display settings default to 3840 x 2400 which makes it completely unusable.

No matter how many times I reset it to 1920 x 1080 it always reverts to the highest display setting available.

The worst thing about this is that when I switch desktops on my Mac, and then switch back to the desktop displaying the VM, the display settings have, again, reverted to the highest available. If it was just a case of resetting the display settings each time I started up the VM, then I could live with that, but having to reset the display settings each time I switch desktops is just not realistic.

Am I the only one seeing this? Does anyone have any sort of fix I can try?

Thanks

Paul

4 Replies
hollyerp
Contributor
Contributor

Fixed it by unchecking 'Use full resolution for Retina display' by selecting Settings > Display in VMWare (not Windows), so hopefully this will help somebody else.


This setting seems to override whatever display settings you select within Windows so I don't see why it is checked by default. I'm sure most users would expect whatever settings they set in Windows to be the settings selected next time they come back to the VM. Overriding Windows settings should be by user selection, not by default, surely.

In the process, I found a few other posts ref display settings, going back to 2010 - none of which had had any reply or solution provided by anyone from VMWare. Which, doesn't make me feel very confident after switching from free VirtualBox to paid VMWare.

(As a side note, Fusion 8 apparently supports Win 10, but I'm still getting the driver incompatibility issues...)

Thanks

Paul

avanish321
Expert
Expert

I found following new setting of Fusion 8 ( new feature ) quite useful.

Go to Virtual Machine > Settings > Display

Under Virtual Machine Resolution, choose "Stretch Virtual machine in Window" and Stretch virtual machine in screen from drop down menu.

The advantage of this, you do not have to uncheck Retina display resolution.

Hope this helps.

Cheers! Avanish
0 Kudos
hollyerp
Contributor
Contributor

Hi avanish321

Thanks for the tip, but doesn't work well enough for my use.

I should have mentioned I'm using a non-retina HD second monitor, and choosing the settings you suggest, results in the windows display being narrower than the available screen area on the monitor.

The problem I was having was the same on the HD monitor and the retina display on my MBP, unchecking the retina display checkbox fixed the problem on both displays.

It appears, that changing the settings as you suggested, results in the VM thinking the HD monitor is the retina display, because it the height stretches correctly, but the width seems to relate to the width of the retina display (squashed with black bars either side).

Thanks for the suggestion - when I get the time, I'll experiment with a few of the settings and see if there is any other way.

Regards

Paul

0 Kudos
zhus
VMware Employee
VMware Employee

Paul,

If the resolution of your Win8.1 worked before you upgrade to Fusion 8, you can try following steps:

1. Power on VM, make sure VM tools is running.

2. Open Settings -> Display.

3. If you have checked "Use full resolution for Retina display" checkbox, there is "Automatically adjust user interface size in the virtual machine" checkbox under it.

4. Uncheck "Automatically adjust user interface size in the virtual machine". A tools message will be shown in Win8.1 guest to ask you to log off then log in Win8.1 to apply the change.

5. Check the checkbox first, then log off and log in again.

It will use the high resolution, but show a proper UI size.

-Shan

0 Kudos