bhavik2
Contributor
Contributor

Vmware Fusion 12 causes high cpu after MAC upgrade to Big Sur

The System cpu spikes to 80% out of which vmware-vmx takes 50%. The moment I shut down the fusion the cpu is normal. I have disabled side channel mitigations on the Ubuntu vm which I am running on fusion. Before the upgrade the CPU was not this bad

 

kindly provide solutions to fix the high due to Fusion 

0 Kudos
18 Replies
wila
Immortal
Immortal

Hi,

For us to be able to find out what is going, we need to see some log files.

The vmware log files to look at are saved in your virtual machine bundle.

You can find them via VMware Fusion Virtual Machine Library screen.

In the Library, select the virtual machine, then right click (or in apple terms: control+click, don't hold down the control key after clicking) and select "Show in Finder". That should open Finder with the current VM bundle selected.

With the VM bundle select right click again, this time select "Show Package Contents".

This will open the virtual machine bundle and show you all the files it is made up of.

Locate the vmware.log files, select them via command+click one by one and right click again, select "Compress n items". That by itself will create an archive.zip file which you can add to the reply down here.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
bhavik2
Contributor
Contributor

Attaching the files

0 Kudos
bhavik2
Contributor
Contributor

Kindly let me know if any update. I have shut down Fusion currently

 

Regards,

Bhavik 

0 Kudos
wila
Immortal
Immortal

Hi Bhavik,

We're all volunteers (other Fusion users) here, so sometimes a reply can take a while.

Just looked at your log.

Can you please try to disable 3D and see if that helps?

Eg. With the VM shut down go to menu -> Virtual Machine -> Settings -> Display -> uncheck 'Accelerate 3D graphics"

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
bhavik2
Contributor
Contributor

Apologies.

Disabling the 3d graphics did not help. MAC is still slow when the Fusion is enabled

Regards,

Bhavik

0 Kudos
bhavik2
Contributor
Contributor

Kindly let me know if there is any alternative

Regards,

Bhavik

0 Kudos
wila
Immortal
Immortal

Hi,

Another thing you can try is to reduce the vCPU count, so go from the  currently assigned 2 vCPU's to 1 vCPU.

Honestly it should not make much of a difference with your intel i7 CPU, but it might.

There's other questions too, like is your VM busy doing something, or is the CPU in the guest idle?

How much RAM has your mac?

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
bhavik2
Contributor
Contributor

Would reducing cpu processor help? It many make things worse right?

My guest OS RAM is 4gb. 

So when the Guest OS is like in idle state all is good. The moment I start working on Guest OS the CPU spike to 80% with vmware-vmx consuming 50% of it. Even access to Fusion becomes freezed and also my Internet connectivity is lost from the guest OS 

Regards,

Bhavik

0 Kudos
wila
Immortal
Immortal

Hi,

I already saw your VM uses 4GB RAM, I still don't know how much RAM your mac has..

Reducing CPU in the VM might make the VM a bit slower, but it will make your host more performant.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
bhavik2
Contributor
Contributor

My MAC has 16gb RAM

This used to work before MAC upgrade. Could there be some process on MAC which Fusion Pro is not liking

 

Regards,

Bhavik

0 Kudos
bhavik2
Contributor
Contributor

While reducing the CPU core Fusion itself gives warning that the VM with 1 core may not be able to boot up

From the vmware logs were you able to get what is causing the MAC cpu to spike?

 

Regards,

Bhavik

0 Kudos
dlhotka
Champion
Champion

MacOS requires 2 cores.  If your host only has 2 cores, it's not enough capacity to virtualize MacOS effectively. 

0 Kudos
wila
Immortal
Immortal

Dlhotka, his guest OS is Ubuntu 21.04, at least the guest OS in his logs is..

That's what puzzled me as I have only seen that message so far with macOS guests.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
bluefirestorm
Champion
Champion

IIRC, there used to be a high CPU usage in an earlier version of Fusion (maybe 8.x) where there is high CPU usage when the

VMware Fusion -> Preferences -> Applications menu: Show in menu bar:

is set to either "Always" or "Only when Fusion is running".

Try setting it to "Never" if it not yet so and see if it resolves the high CPU usage issue.

 

0 Kudos
dlhotka
Champion
Champion

Oh yeah, I missed that - have only seen that with Mac guests.

 

Maybe the guest OS type is set incorrectly?

0 Kudos
wila
Immortal
Immortal

Hi,


@dlhotka wrote:

Maybe the guest OS type is set incorrectly?


Nope, that's one of the things I had checked.
According to the log it is set correctly. Would need to setup a Ubuntu 21.04 to see if the behavior is reproducable, sadly though as a volunteer that's a step beyond my curiosity/commitment.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
bhavik2
Contributor
Contributor

I have configured as Never and currently monitoring it . MAC still becomes slow but it is relatively better

0 Kudos
gigs94
Contributor
Contributor

I might have just discovered something regarding high cpu.   Though I'm on monterey running a monterey vm (unsupposed by vmware fusion atm).  I was getting high cpu for SYSTEM cpu as opposed to user cpu.   It was running at about 25% and would turn the fans on constantly even with the vm idle.   Well, shutting off the energy saving stuff (uncheck prevent your mac from automatically sleeping, wake for network access and enable power nap) in the VM seems to have solved this issue.   The fans are quiet and the vmware-vmx process that was constantly at 70-100% (via top) is now down to <20.   Can anyone else verify this?

0 Kudos