OmicronB
Contributor
Contributor

VmWare Fusion crash when using Altium designer

I have a consistent crash of VMWare Fusion 12.1.1 whenever I open a PCB document in Altium designer. The crash causes the VM to be shut down.

I see the following error report in mkSandBox.log:

moderator edit by wila: Moved pasted text to an attachment

26 Replies
wila
Leadership
Leadership

Hi,

Your log starts like this:

2021-05-03T23:58:53.902+02:00| main| I005: MKSMacos: Starting CFRunLoop...
2021-05-04T00:00:29.774+02:00| svga| E001: PANIC: Failed to create geometryShader compute pipeline state , error Compiler encountered an internal error

Not much we can do here to help you.

The only thing I can say is "disable 3D hardware acceleration to prevent the crash" ... but without 3D your Altium designer software isn't going to be great to use (putting it mildly)

If you have support with VMware then I recommend you to open a ticket.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
OmicronB
Contributor
Contributor

I tried to create a ticket, but the support system won't let me. My license doesn't show up in the list (and yes I did read all the knowledge base articles they link to, none of them seem to make any sense to my situation).

So how does one get crash reports to the Fusion developers?

0 Kudos
wila
Leadership
Leadership

Hi,

If you didn't buy the additional support option and are past the 30 days complimentary support time that comes with Fusion when you buy it, then basically your only option is posting it here and hoping it gets noticed by a VMware developer.

Sadly the forum is only for other Fusion users trying to help you out and not an official support channel.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Min-Yu
VMware Employee
VMware Employee

Please upload the complete mksSandbox.log next time, or it's really difficult to tell what's really wrong here.

So far, the only known issue we had that matches your case is "Altium Designer crashes on AMD GPUs with MacOS Big Sur".

Is it what you encountered?

It's AMD driver issue and we have notified AMD and is waiting for their fix.

Meanwhile, you could try to run Fusion on the integrated Intel GPU if you have one.

 

Regards,

0 Kudos
OmicronB
Contributor
Contributor

Complete log file attached. The crash is 100% reproducible so I can easily test any suggested patch.

I'm not sure what an AMD GCN1 GPU is, but I have an Apple made AMD Radeon Pro W5700 video card in my Mac Pro.

0 Kudos
scottbronikowsk
Contributor
Contributor

I am having the same issue, 100% reproducible when opening any PCB file.  My problem report zip is attached.

0 Kudos
Odineng
Contributor
Contributor

I am having the the identical problem with Altium running on a 2013 MacPro, after years of successful use. I bought a support incident from VMware but besides disabling video acceleration we are no closer to finding the cause. Is it possible this was induced by a driver change included in the Mac OS 11.3 update?

0 Kudos
scottbronikowsk
Contributor
Contributor

Yeah, that fits with my experience.  Everything ran fine with video acceleration enabled until I installed the 11.3 update last week.  Tried again after installing the 11.3.1 update last night, and the crash still happened.  I can get PCB docs to open with 3d acceleration disabled, but things are quite laggy.

0 Kudos
Min-Yu
VMware Employee
VMware Employee

Yes, this is a regression in AMD driver on all AMD GPUs after MacOS Big Sur 11.3, unfortunately.

If you have a Time Machine backup, you could try to go back to 11.2 to avoid this issue at this moment.

0 Kudos
OmicronB
Contributor
Contributor

The issue is still present in version 12.1.2.

Any news on if this problem is being worked on, either at VMWare's side or at Apple's side?

wila
Leadership
Leadership

Hi,

Min-Yu (a VMware employee) said:


this is a regression in AMD driver on all AMD GPUs after MacOS Big Sur 11.3

VMware does not write drivers for graphic cards.. so it is a macOS issue. You are at the mercy of Apple unless VMware is able to workaround this somehow.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
columbrian
Contributor
Contributor

Interestingly, I downloaded a trial version of Parallels and it works fine on the same hardware.

I know there are a lot of moving parts, but it sure seems like a solution, if not the actual problem, lies in the Fusion GPU virtualization.

cheers

OmicronB
Contributor
Contributor

I'm using both VMWare Fusion and Parallels. Although Parallels behaves differently, it can't run Altium correctly either. It will open the PCB document without crashing, but if you work on your PCB for a little while it will crash as well. And it has a tendency to crash the entire computer in this case while VMWare Fusion just crashes the virtual machine but not the host computer.

@Min-Yu: can you confirm that Apple is aware of this regression int heir driver and that it is being worked on?

0 Kudos
columbrian
Contributor
Contributor

Yes, sadly Parallels has turned out not to work as well as I originally had thought. I was hoping they would be a solution until the problem using Fusion got resolved.

So far as I can tell this seems to affect only Altium users. I wonder what it is that they're doing that's so special. Presumably the same AMD driver is being used by many other applications, including ones running natively under MacOS and in the Windows VM.

 

My experience with Altium in the past is that once you mention VM they respond with "unsupported". So I doubt they'll be much help.

0 Kudos
Odineng
Contributor
Contributor

For what it's worth, I was hoping the Mac OS 11.4 update might contain a driver update that would fix this issue. I just installed it, nope, same crash. Burning a lot of design time waiting for screen updates in unaccelerated Altium...

0 Kudos
wila
Leadership
Leadership

Hi,

One thing to try as a possible workaround.

Did it work in earlier versions of Fusion?
If so, then perhaps it will work again when not all the latest DirectX features are exposed. So keeping 3D enabled, but not the very latest version.

For being able to try that, shut down the VM and change the virtual hardware version to an earlier version (eg. instead of virtual Hardware Version 18, try vHW17 or vHW16)

You can find this under Settings -> Compatibility

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
columbrian
Contributor
Contributor

Same here

0 Kudos
OmicronB
Contributor
Contributor

Unfortunately Altium needs the latest DirectX features. In earlier HW versions you can't open the PCB documents at all.

System update 11.4 doesn't fix the issue either.

0 Kudos
columbrian
Contributor
Contributor

FWIW, turning off graphics acceleration was unusable. But it did clear up another minor, but perhaps telling, issue with Altium under Fusion. The dialog buttons had been showing some rendering artifacts that aren't present without DirectX. Parallels renders the buttons correctly, although with the eventual decline into total system instability.

 

Do the Fusion people know what the underlying trigger for the crash is? Or just that it's the AMD driver?

 

I am quickly reaching the point of abandoning the whole concept to VMs and moving to a NUC and RDP. Nobody involved in the chain of dependent software platforms actually feels like they own this problem. VMware says it's AMD, so talk to Apple. It's hard to go to Apple and say "my VM is crashing, it's your fault", as they respond with the expected "take it up with the VM vendor". And there's no path to AMD at all, not that I would expect a direct resolution with them anyway.

0 Kudos