OmicronB
Contributor
Contributor

VmWare Fusion crash when using Altium designer

I have a consistent crash of VMWare Fusion 12.1.1 whenever I open a PCB document in Altium designer. The crash causes the VM to be shut down.

I see the following error report in mkSandBox.log:

moderator edit by wila: Moved pasted text to an attachment

0 Kudos
9 Replies
wila
Leadership
Leadership

Hi,

Your log starts like this:

2021-05-03T23:58:53.902+02:00| main| I005: MKSMacos: Starting CFRunLoop...
2021-05-04T00:00:29.774+02:00| svga| E001: PANIC: Failed to create geometryShader compute pipeline state , error Compiler encountered an internal error

Not much we can do here to help you.

The only thing I can say is "disable 3D hardware acceleration to prevent the crash" ... but without 3D your Altium designer software isn't going to be great to use (putting it mildly)

If you have support with VMware then I recommend you to open a ticket.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
OmicronB
Contributor
Contributor

I tried to create a ticket, but the support system won't let me. My license doesn't show up in the list (and yes I did read all the knowledge base articles they link to, none of them seem to make any sense to my situation).

So how does one get crash reports to the Fusion developers?

0 Kudos
wila
Leadership
Leadership

Hi,

If you didn't buy the additional support option and are past the 30 days complimentary support time that comes with Fusion when you buy it, then basically your only option is posting it here and hoping it gets noticed by a VMware developer.

Sadly the forum is only for other Fusion users trying to help you out and not an official support channel.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Min-Yu
VMware Employee
VMware Employee

Please upload the complete mksSandbox.log next time, or it's really difficult to tell what's really wrong here.

So far, the only known issue we had that matches your case is "Altium Designer crashes on AMD GPUs with MacOS Big Sur".

Is it what you encountered?

It's AMD driver issue and we have notified AMD and is waiting for their fix.

Meanwhile, you could try to run Fusion on the integrated Intel GPU if you have one.

 

Regards,

0 Kudos
OmicronB
Contributor
Contributor

Complete log file attached. The crash is 100% reproducible so I can easily test any suggested patch.

I'm not sure what an AMD GCN1 GPU is, but I have an Apple made AMD Radeon Pro W5700 video card in my Mac Pro.

0 Kudos
scottbronikowsk
Contributor
Contributor

I am having the same issue, 100% reproducible when opening any PCB file.  My problem report zip is attached.

0 Kudos
Odineng
Contributor
Contributor

I am having the the identical problem with Altium running on a 2013 MacPro, after years of successful use. I bought a support incident from VMware but besides disabling video acceleration we are no closer to finding the cause. Is it possible this was induced by a driver change included in the Mac OS 11.3 update?

0 Kudos
scottbronikowsk
Contributor
Contributor

Yeah, that fits with my experience.  Everything ran fine with video acceleration enabled until I installed the 11.3 update last week.  Tried again after installing the 11.3.1 update last night, and the crash still happened.  I can get PCB docs to open with 3d acceleration disabled, but things are quite laggy.

0 Kudos
Min-Yu
VMware Employee
VMware Employee

Yes, this is a regression in AMD driver on all AMD GPUs after MacOS Big Sur 11.3, unfortunately.

If you have a Time Machine backup, you could try to go back to 11.2 to avoid this issue at this moment.

0 Kudos