chrisbx
Contributor
Contributor

Visual C# 2008 Express WPF display corruption

I've just installed Visual C# 2008 Express (9.0.1.21022.8 RTM) under Windows XP Pro SP3, and I'm noticing a lot of redraw issues in the WPF designer window, and in WPF-based apps while they're running.

If I load up Visual C#, select File > New Project, then "WPF Application", the first window that appears has a zoom slider in the top left corner, which doesn't draw correctly. If I add a few controls to the window and run the app, as soon as I move the application window it stops redrawing entirely and leaves trails behind it until I quit it.

I've found that the problem goes away if I turn down the video acceleration in the Windows XP display properties troubleshooting tab - setting it to the 3rd notch ('Disable all DirectDraw and Direct3D acceleration...') causes WPF to look OK again, although obviously it's not ideal. I wondered if anyone else had noticed this, or had any alternative suggestions I could try?

I'm using Fusion 1.1.3 (94249) with vmware tools installed, windowed and full-screen (not unity). It's running on OS X 10.5.3 on a Mac Pro (Early 08) with a Geforce 8800.

0 Kudos
7 Replies
ejstembler
Contributor
Contributor

I've just installed Visual C# 2008 Express (9.0.1.21022.8 RTM) under Windows XP Pro SP3, and I'm noticing a lot of redraw issues in the WPF designer window, and in WPF-based apps while they're running.

If I load up Visual C#, select File > New Project, then "WPF Application", the first window that appears has a zoom slider in the top left corner, which doesn't draw correctly. If I add a few controls to the window and run the app, as soon as I move the application window it stops redrawing entirely and leaves trails behind it until I quit it.

I've found that the problem goes away if I turn down the video acceleration in the Windows XP display properties troubleshooting tab - setting it to the 3rd notch ('Disable all DirectDraw and Direct3D acceleration...') causes WPF to look OK again, although obviously it's not ideal. I wondered if anyone else had noticed this, or had any alternative suggestions I could try?

I'm using Fusion 1.1.3 (94249) with vmware tools installed, windowed and full-screen (not unity). It's running on OS X 10.5.3 on a Mac Pro (Early 08) with a Geforce 8800.

I definitely think there is a WPF display issue. None of the Microsoft Expression applications display for me either, and they were written in WPF as well.

0 Kudos
bgertzfield
Commander
Commander

I've just installed Visual C# 2008 Express (9.0.1.21022.8 RTM) under Windows XP Pro SP3, and I'm noticing a lot of redraw issues in the WPF designer window, and in WPF-based apps while they're running.

Do you have 3D enabled in the virtual machine settings? If so, try powering off your VM and turning off 3D as a workaround.

Ben

chrisbx
Contributor
Contributor

Yes, 3D was enabled in the virtual machine settings. If I disable this, WPF seems to render perfectly without having to use the Windows display troubleshooting slider. I guess I'll cross my fingers for a fix in an upcoming release. Thanks for your help.

0 Kudos
bgertzfield
Commander
Commander

Yes, 3D was enabled in the virtual machine settings. If I disable this, WPF seems to render perfectly without having to use the Windows display troubleshooting slider. I guess I'll cross my fingers for a fix in an upcoming release. Thanks for your help.

OK. We've reproduced this internally and have a fix we plan to make available in the next Fusion 2.0 release.

The problem was that WPF apps (along with iTunes and a few other programs) combine 2D and 3D rendering in the same window. When 3D was enabled, Fusion's SVGA driver had an issue where the 2D and 3D rendering would both try to update the same area of the guest framebuffer at the same time, causing the rendering issues you described.

Sorry for the inconvenience, and stay tuned for this and lots of other fixes.

0 Kudos
Ghaby
Contributor
Contributor

Same issue with VMWare Workstation 6.5, any fix?

0 Kudos
patwolf
Contributor
Contributor

Same issue with VMWare Workstation 6.5.2 and from the change log of 6.5.3 it looks like it hasn't been fixed yet.

Is there any time estimate when this will be fixed?

Thanks,

Patrick

0 Kudos
Mihies
Contributor
Contributor

I'd like to see WPF support as well. Keeping fingers crossed.

0 Kudos