matthewj
Enthusiast
Enthusiast

Video is blurry since 11.5 update

Jump to solution

Either my eyesight just changed, or the video quality in my Windows VMs got blurry. I am viewing them on a 5k display, with the client OS at 2560 x 1440, without full resolution. Acceleration makes no difference.

It seems that something is probably anti-aliasing or something like that, but given I used to like how sharp it was, something has changed. If anyone knows what that might be, I'd welcome getting the nice sharp display back. Thanks.

Tags (1)
36 Replies
dlhotka
Champion
Champion

FWIW, it seems better on a catalina host.

Regarding a patch, I'm sure it's in the queue, but it'll take time to work its way through the development and QA process.  VMWare doesn't comment on upcoming release schedules.

zhus
VMware Employee
VMware Employee

For Windows and Ubuntu, the following workaround on Retina display for your references.

Win7:

Open VM Settings -> Display, enable the "Use full resolution for Retina display", disable the "Automatically adjust user interface size in the virtual machine".

In Win7 guest, go to Control Panel -> All Control Panel Items -> Display, click "Set custom text size (DPI)", set the Scale to 200% in Custom DPI settings window, click OK, then apply it.

Win10:

Open VM Settings -> Display, enable the "Use full resolution for Retina display", enable the "Automatically adjust user interface size in the virtual machine".

Ubuntu:

Enable the "Use full resolution for Retina display" in VM Settings -> Display.

Then open the Displays settings of the Ubuntu desktop in guest OS, set Scale to 200%.

If the guest OS is Ubuntu 18.04 or later version. There is problem that while the VM window size changing, the resolution is automatically refreshed, the 200% scale will be restored to 100%. So if you do not want to set it again and again, you have to select "Stretch the virtual machine in the window" for the Virtual Machine Resolution -> Single Window combo box in VM settings -> Display.

HabibAz
Contributor
Contributor

Hi zhus,

thank you for your work-a-round but in my case it's not very usefull... in my windows/display settings 150% is the maximum of the settings and it was already set.

The picture I made shows what's the result is shown in the picture attached:

IMG_8050.jpeg

(the dot in the middle is my logon icon)

0 Kudos
zhus
VMware Employee
VMware Employee

150% is not the maximum of the value, you should select "Set custom text size (DPI)" on the left side. See the screenshot below.scale200.png

0 Kudos
matthewj
Enthusiast
Enthusiast

Changing the client OS to work around a bug/change in VMWare doesn't really solve it. If I'm testing software and need the normal resolutions, then I can't be changing the client like that. And Windows and its applications are poor at retina resolution. It might work for some, but it isn't a fix. I look forward to it getting back to normal.

0 Kudos
ThoLie
Contributor
Contributor

Hi,

i have a MBP 15" 2013 with 10.14.6 installed and run Win10 in VM. For me this settings stopped blurring the Windows Screen:

MacOS:

Screenshot 2019-10-08 at 12.10.00.png

VMWare Fusion 11.5:

Screenshot 2019-10-08 at 12.10.51.png

Windows:

Builtin MBP Screen:

Screenshot 2019-10-08 at 12.11.40.png

I have attached 2 Monitors both set to 100% and their native resolution.

Now Blurring is gone! hooray!!!

0 Kudos
Joachim_Neudert
Enthusiast
Enthusiast

Thanks for the news that VMWare is thinking about it and offers these workarounds. While the static screen looks better with this workaround, shifting all the pixels for the maximal physical retina resolution slows downs videos and dynamic content in the VM to a slide-show. I had to switch back to the blurry but faster screen.

Please keep on repairing the display of VMWare. You should as well consider to postpone the distribution of VMWare Fusion 11.5, at least stop to urge the users to install this buggy update.

Kind regards.

0 Kudos
dlhotka
Champion
Champion

I'll chime in as well: the performance on a 4K screen with Win10 is worse with the workaround than the blur itself.  While the workaround is appreciated, we do need a fix.

0 Kudos
dlhotka
Champion
Champion

And on OSX guests too.  If 'use full resolution' is checked, they are tiny, if it's unchecked they are blurry.

Something pretty fundamental changed here....and needs to change back.

0 Kudos
zhus
VMware Employee
VMware Employee

The workaround is just for temporary reference. The engineer team are working on it.

0 Kudos
HabibAz
Contributor
Contributor

My Problem is gone after upgrading my OSX to 10.15 🙂

bolaz
Contributor
Contributor

Yes, looks much better 🙂

0 Kudos
dlhotka
Champion
Champion

11.5 doesn't help with OSX Guests unfortunately.  Either have the option of blurry video or tiny controls.

0 Kudos
Joachim_Neudert
Enthusiast
Enthusiast

Still no fix available? It's the end of October already and we are still waiting in front of ore our blurred screens...

Kind regards

0 Kudos
rann
Contributor
Contributor

Any news on this? Just upgraded to 11.5 on macOS Mojave and also noticed that all my VMs are blurry now. Please fix!

0 Kudos
Joachim_Neudert
Enthusiast
Enthusiast

Finally! The Bugfix Fusion 11.5.1 is released. I instantly installed it and it works, the display is clear and sharp again. Thank you, VMWare. But it is hard to figure out why nobody noticed this before the introduction of Fusion 11.5

View solution in original post

nitro_jawt
Enthusiast
Enthusiast

Nope, both 11.3 and 11.5 make Windows blurry in full screen - so the "fix" has been broken again.

I have "Use full resolution for Retina display" enabled, and using my non-retina 3840x1600 display in full screen is blurry. Windowed it's fine.

0 Kudos