tambal
Contributor
Contributor

VMware version 10 cut and paste does not work on my Mac

Jump to solution

Hi,

 

I am using VMware Fusion v.10. on my Mac (OS 10.14.6) and run Windows XP under this virtual machine. Everything works except I cannot cut and paste in the program I am running. If I use the mouse and click on "cut", and "paste" instead of the keyboard shortcuts, it works. I went through many steps that I read about in the forum w/o success. Any help would be appreciated.

0 Kudos
1 Solution

Accepted Solutions
tambal
Contributor
Contributor

I just solved the problem.

It is crazy!!! I disabled key mapping and then checked again to enable key mapping.

That took care of it.

Thanks again,

View solution in original post

0 Kudos
6 Replies
dlhotka
Champion
Champion

Fusion 10 isn't supported on Mojave.  You need Fusion 11 for that.  11.5 supports Catalina.  Fusion 12 supports Big Sur.

0 Kudos
tambal
Contributor
Contributor

Thanks.

It is still strange as everything else is working except cut and paste.

0 Kudos
tambal
Contributor
Contributor

So, now I upgraded to v 11.5. I have exactly the same problem. So I am afraid this was not the problem.

I am still stuck with this bug. Any clues now?

 

Thanks

0 Kudos
dlhotka
Champion
Champion

Hmm...did you upgrade the virtual hardware and VMWare tools?

 

If so, try checking the keyboard settings to make sure it's passing the keystrokes properly.

0 Kudos
tambal
Contributor
Contributor

I did upgrade the tools. 

What do you mean upgrade the virtual hardware? Where do you do that?

I have checked the keyboard settings and they seem to be OK. Is there a way to test if that works?

The problem clearly appears to be the keyboard keys though. If I use the mouse and select "copy" or "paste" in the virtual window, it does copy and paste. Also, when I try to use the control key to emulate the right click in the mouse that does not work either in then virtual window. However, I can type with the keyboard, so there is connection. Just the command keys do not appear to work.

Thanks for thinking about it and trying to help.

0 Kudos
tambal
Contributor
Contributor

I just solved the problem.

It is crazy!!! I disabled key mapping and then checked again to enable key mapping.

That took care of it.

Thanks again,

View solution in original post

0 Kudos