VMware Tools, Win 7 Home: local print spooler service is not running

Hi, I'm new to this forum - first question.

I have been using Fusion 2, with XP Pro as its guest, for some time. I have upgraded to Fusion 3 and have purchased Windows 7 Home Premium.

I installed the 64 bit Win 7 on Bootcamp quite successfully (clean install - formatted the disc). Bootcamp drivers working; installed drivers for my printer (Kyocera FS1020D, using the KX driver, on theLAN, standard TCP port) and everything was working well. So all was well running Windows7 Home Premium natively on my 20" iMac. Also, under Snow Leopard, Fusion 3 is running my existing XP guest quite happily.

I decided to experiment with running the Bootcamp Win 7 with Fusion. After recovering from a couple of standard pitfalls, I had the the Bootcamp Win 7 running as a guest under Fusion, complete with VMware Tools and printers working. However ....

When I booted natively into Win 7, the printers were no longer visible in the 'Devices and Printers' control panel. Clicking on 'Add Printer' gave me 'local print spooler service is not running'. No amount of restarting the print spooler had any effect. Switching back to MacOS and running the Bootcamp Win7 as a guest VM and the printers are all visible and the print spooler service is running.

After a while I tried removing the VMWare Tools, using 'Programs and Features' whilst the Win7 was running as a guest. Rebooting the Win7 natively and, remarkably, the printers are now back and all is well again.

And yes, I did repeat this by running up the Win 7 as a guest and re-installing the VMware Tools. Rebooting natively and once again the printers are not visible and the 'print spooler' error has reappeared.

Anyone else hit this problem? Anyone got a solution?



0 Kudos
2 Replies

I also had the same problem - all the installed printers and faxes were missing when running Windows 7 x64 Ultimate from the Boot Camp partition.

I was able to start the print spooler service, but it would stop when I tried to "Add a printer" The printers were still in the system registry.

The Event Viewer give an Event ID 808: The print spooler failed to load a plug-in module TPVMMon.dll, error code 0x7e.

It also gave an application error in the Event Viewer:

Faulting application name: spoolsv.exe, version: 6.1.7600.16385, time stamp: 0x4a5bd3d1

Faulting module name: TPVMMon.dll, version:, time stamp: 0x4a2faae7

Exception code: 0xc0000005

Fault offset: 0x000000000000863e

Faulting process id: 0xaa8

Faulting application start time: 0x01ca5b5788f833c9

Faulting application path: C:\Windows\System32\spoolsv.exe

Faulting module path: C:\Windows\System32\TPVMMon.dll

Report Id: 0f23093d-c74b-11de-ba60-0017f2ab4f90

I removed VMWare Tools and my printers reappeared.

I found by googling TPVMMon.dll, that it is a module that is part of the ThinPrint portion of VMware tools. I found instructions on how to remove that portion <>, but I have not tried those instructions yet. They pertain to VMWare Workstation 6.5.0.

I found this thread, VMware Fusion ThinPrint causing print spooler to stop working in Vista64 Bootcamp <> that has a couple of solutions including the one above at and also this Microsoft Knowlegebase article <>

I'll probably reinstall VMWare Tools then try uninstalling the ThinPrint module.


Many thanks Leslie, your response was very helpful.

Learning that it was a problem with ThinPrint, rather than taking the actions suggested in the threads you advised me about, I did the following.

VMware Tools had already been uninstalled using the 'Programs and Features' control panel - I had done that to establish it was a problem with VMware Tools.

I installed VMware Tools again but, when prompted, I selected the 'Custom' install rather than the 'Typical' install. Under 'Device Drivers' I deselected ThinPrint and proceeded with the install. My Bootcamp printers printers are now working whether booted natively or within Fusion.

Of course, I can't print to the Mac printer drivers from within the VM but I can live with that for now.

I shall pop over to thread 203793 and add a comment over there too.



0 Kudos