Highlighted
Contributor
Contributor

VMware Fusion does not support virtualized performance counters on this host

Just installed Big Sur on my iMac with VMWARE Fusion 12 and get the following error when trying to open my Windows 10 system;

Mware Fusion does not support virtualized performance counters on this host

Anyone know what this is or how I can fix it?

13 Replies
Highlighted
Contributor
Contributor

I have the same issue.

Highlighted
Contributor
Contributor

Same problem here. With googling I see related issues earlier. Not sure if the fix is also applicable here.

0 Kudos
Highlighted
Contributor
Contributor

~I solved it to

To change some settings in the advanced settings of the virtual machine:

disable the UEFI Secure boot

disable VBS in the advanced settings of the virtual machine

and mark the option Disable Side Channel Mitigations

 

Maybe the fix can be less dramatic as above, but now I can go back to work 😉

Hopefully there is a smoother solution.

 

0 Kudos
Highlighted
Contributor
Contributor

My VM is suspended, it won't let me change the setting, while it is this status.

It is so frustrating. 

0 Kudos
Highlighted
Contributor
Contributor

Hi,

I had the same problem.

Lucky I had a windows computer and installed a trail version of VMware workstation pro. With this I could start the VM and shut down it.

Ernst

 

0 Kudos
Highlighted
Contributor
Contributor

Thanks I'll give that a go.

Highlighted
Contributor
Contributor

In my case I solved it unchecking the "Enable code profiling applications in this virtual machine"on advanced options of the processors area.

Captura de Tela 2020-11-17 às 12.20.27 PM.png

Highlighted
Contributor
Contributor

Same problem here. 

 

How can I force a shut down?

0 Kudos
Highlighted
User Moderator
User Moderator

Hi All,

Starting with macOS Big Sur VMware has to use the Hypervisor Framework as is provided by apple. The result of that is that currently some features do not work on a number of processors (even very current processors!) The missing features are Performance counters and nested virtualisation.

In order to start your VM you have to go to the menu "Virtual Machine" -> settings -> Processors & Memory -> open Advanced options and then make sure the following checkboxes are unchecked:

  • Enable Hypervisor applications in this virtual machine
  • Enable code profiling applications in this virtual machine

see also this thread

If your VM has been suspended and you can't make the above changes, then you can go to the menu -> Virtual Machines -> Hold down the Option (Windows users -> Alt) key and choose "Power Off".
After that you should be able to make the changes so you can boot your VM again.

hope this helps,
--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Highlighted
Contributor
Contributor

Thank you for sharing claudiobh. This worked for me too!

0 Kudos
Highlighted
Contributor
Contributor

Thank you for the reply.  I unchecked "Enable code profiling applications in this virtual machine" and all worked.  Currently I have "Enable Hypervisor applications in this virtual machine" still checked and everything works.  Is this OK or should I also uncheck this box?

Highlighted
User Moderator
User Moderator

Hi,

lennyk said:
"Currently I have "Enable Hypervisor applications in this virtual machine" still checked and everything works. Is this OK or should I also uncheck this box?"

If the VM runs without unchecking enable hypervisor applications and you are running VM's in your VM then you can leave it checked. Your CPU apparently does have VMCS shadowing support.
If OTOH your VM is sluggish then you might want to disable that one too and see if it makes a difference.

--
Wil

 

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Highlighted
Contributor
Contributor

Thanks, worked for me.

0 Kudos