mpollicove
Contributor
Contributor

VMware Fusion - CTRL-CMD required?

Jump to solution

Question for all of you all...

In WMWare Fusion on my work MacBook, I am required to hit Control-Command to exit my VMs, however I don't have this issue when using WMware Workstation on my Windows system at home. Is there a way I can turn this off in Fusion as well?

Thanks!

0 Kudos
1 Solution

Accepted Solutions
wila
Leadership
Leadership

Hi,

Ok.

There's not a lot of info for me to go on right now (no guest OS, Fusion version, host OS version etc...), but one thing that changes this behavior is if you have made a change in VMware Fusion's configuration.

Under menu -> Preferences -> General tab -> Gaming:

The default is "Auto detect mouse for Games". If you have changed that to "Always optimize mouse ..." then you'll have to press those shortcut keys to leave the guest OS.

Other things to pay attention to are:

- the Guest OS has to be set to the correct OS (+ OS version) as it is what VMware Tools depends on for what installer to present to your VM

- that you reboot the guest OS inbetween uninstall and re-install of VMware Tools

If none of the above helps then you could try re-installing VMware Fusion itself.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva

View solution in original post

0 Kudos
4 Replies
wila
Leadership
Leadership

Hi,

Sounds like VMware Tools, in the guest OS, is not installed or not working properly.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
mpollicove
Contributor
Contributor

You would think. I've tried reinstalling a number of times. Interestingly enough when I move the VM back to a Windows host and run under Workstation, the behavior is as expected.

0 Kudos
wila
Leadership
Leadership

Hi,

Ok.

There's not a lot of info for me to go on right now (no guest OS, Fusion version, host OS version etc...), but one thing that changes this behavior is if you have made a change in VMware Fusion's configuration.

Under menu -> Preferences -> General tab -> Gaming:

The default is "Auto detect mouse for Games". If you have changed that to "Always optimize mouse ..." then you'll have to press those shortcut keys to leave the guest OS.

Other things to pay attention to are:

- the Guest OS has to be set to the correct OS (+ OS version) as it is what VMware Tools depends on for what installer to present to your VM

- that you reboot the guest OS inbetween uninstall and re-install of VMware Tools

If none of the above helps then you could try re-installing VMware Fusion itself.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva

View solution in original post

0 Kudos
mpollicove
Contributor
Contributor

Very good points, I will look into that, but I am using Fustion 11.5.3 running on a 2019 MacBook with an i7 and 32 GB or ram on Mojave.

The guest is windows server 2008R2

And yes, that option might have been touched.

Thanks

0 Kudos