VMware Communities

VMware Converter failure Error code: 2147754754 (0x80042302)

I have installed a fresh copy of Windows 7 Ultimate 64-bit and tried converting the machine with VMware vCenter Converter (version 4.1). Every time I run the software I get the following error in less than one minute:

FAILED: Unable to create a VSS snapshot of the source volume(s). Error code:

2147754754 (0x80042302).

I am oddly having a similar issue trying to use the Windows 7 Backup and Restore program to create a system image. I have scoured the vmware boards and the microsoft boards and nothing seems to work. Any help would be appreciated as this worked for me without a hitch with Vista Ultimate (except for the fact that Vista sucked!). Thanks.

0 Kudos
5 Replies

Hello Bernito,

This seems like a Windows issue. It is not a bad idea to disable the "Volume Shadow Copy (VSS)" service on the source Windows PC and then to try and run the converter again. Disabling the VSS service will remove all the shadow copy stored in the source PC thus allowing the converter to proceed further.


Aravind K

If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful

Regards, Aravind K If you find this or any other answer useful please consider awarding points by marking the answer correct or helpful
0 Kudos

Hi Aravind,

Turning VSS off in services unfortunately doesn't work, it continues to quit

nearly immediately and posts the same error message. Thanks for your

suggestion and I welcome any others you might have.



0 Kudos

I deleted all my backup files through Windows backup, used vssadmin to delete all shadows, and turned off system restore on the PC. Migration still does not work. I get the same code.

0 Kudos

same error when trying to convert a windows 2008 R2 server, not found a sollution yet?

0 Kudos

I know this is a really old post; however, I still ran into this issue many years later and have found a solution.  I was converting a 32 bit Windows 7 machine that was already a VM - I simply wanted to reduce the system volume's size.  It was too big and was making cloning take longer than it should.

The solution that worked for me is not my work.  I take no credit for it, nor do I take any responsibility for what it does.  I blindly followed these instructions and it worked perfectly for me.  I will provide a link to the original web site AND a copy of the instructions in case that website no longer exists one day.

I only followed these steps thru part 6.  I did not need to go any further after that.

Good Luck.  Hope this helps someone as it helped me.

I'd like to say Thank you to: STC-KevinH who appears to be the original author.

The website as of 12-19-2014 can be found here: http://www.storagecraft.com/support/kb/article/32

Below here is the information copied directly from the website I just listed above.


This article details how to troubleshoot VSS errors.


Backups may be failing due to Microsoft's VSS framework being in a bad state. This could be caused by clashes between ShadowProtect and other programs trying to use VSS at the same time. Only one writer can use VSS at any given time (See article on "Understanding VSS and ShadowProtect"). Another possible cause for VSS errors is that the necessary system services may have been mistakenly disabled.


If Microsoft's VSS framework and/or some of the VSS writers are in a bad state, you need to clean the system up before your backups will work.

Part 1:

    • Cancel any running backup jobs
    • End the ShadowProtectSVC process if necessary. (See Part 2, #3)

Part 2:Go to Start | Run and enter "services.msc" - Click OK.

    1. Navigate to MS Software Shadow Copy Provider. Startup Type should be set to "Manual" if it is not already.
    2. Navigate to Volume Shadow Copy. Startup Type should be set to "Manual"
    3. Navigate to ShadowProtect Service. Startup Type should be set to "Automatic"
    4. Navigate to StorageCraft Shadow Copy Provider. Startup type should be set to "Automatic"

Part 3:Next, you need to delete all greyed-out devices (non-present "Storage Volume shadow copies" devices) possibly left over from previous snapshots.

    1. Run the command prompt as Administrator
    2. Run vssadmin delete shadows /all and select yes to delete all
    3. Run Set devmgr_show_nonpresent_devices=1
    4. Run devmgmt.msc this will open the device manager with the option to show non-present devices
    5. From "Device Manager" select "View | Show hidden devices"
    6. Scroll down until you see "Storage volume shadow copies" in the list. If it is not listed go to step 5.  Under "Storage volume shadow copies" a listing called "Generic volume shadow copies" will be shown. The icon next to them will be greyed-out.


These can only be removed one at a time.  Select one from the list, right click, and then choose uninstall.  Repeat this process until all greyed-out devices are removed.  If there are devices still listed which are not greyed-out then the vssadmin delete shadows /all did not work properly. Try running it again.Part 4:Do not delete any of the Storage Volumes.Part 5:

    1. Go to Start | Run.. and enter "cmd" - Click OK.
    2. From the command line run the following command: vssadmin list writers. This will show you the state of any VSS-aware applications.
    3. If any of the VSS-Aware applications are in an unstable state you need to troubleshoot the individual writer and error,ORFor Server 2003 or Earlier ONLY: Manually reset the state of the VSS Writers. - These steps are at the bottom of the page.

Part 6:Reboot.Part 7:After you finish rebooting:

    1. Click Start | Run and type "cmd"
    2. At the C:\ prompt type vssadmin list writers (note: these services should all be in a Stable state)
    3. If you run the vssadmin list shadows command, no existing shadow copies should be shown.

ConclusionFollowing the steps listed above should clean the system up enough for you to start using ShadowProtect. Proper VSS interaction is very complex and many backup products leave various components (especially VSS writers) in bad states. This can cause problems for other backup products. If you are using any other backup products, it's very likely that they will corrupt the states of various VSS components.  You must always ensure that ShadowProtect does not run at the same time as other backup software such as Backup Exec, Acronis, etc.

Additional Information:

Related articles:Understanding VSS and ShadowProtect - gives more basic information on what VSS is, how it works and which Operating Systems and applications are VSS aware.
Reregistering VSS steps for Server 2003: (Also referenced in the article labled: VSS Backups fail with a VSS error of 0x8000FFFF)

Warning From Microsoft in reference to the information below:

MS VSS WarningTo attempt to reregister/reset VSS follow Microsoft's  support knowledge base article listed at:

Error message when you run the "vssadmin list writers" command on a Windows Server 2003-based comput...

Scroll down to the section labled:

"Let me fix it myself"

Follow this section of Microsoft's document.  .


    • On 64bit system's the path to some DLL's will need to be entered differently because they reside in the SysWOW64 section of the WINDOWS directory.  e.g.
Net stop vss
Net stop swprv
regsvr32.exe /i %windir%\system32\eventcls.dll
regsvr32.exe /i %windir%\system32\swprv.dll
regsvr32.exe %windir%\system32\vssui.dll
regsvr32.exe %windir%\SysWOW64\vss_ps.dll
regsvr32.exe %windir%\SysWOW64\msxml.dll
regsvr32.exe %windir%\SysWOW64\msxml2.dll
regsvr32.exe %windir%\SysWOW64\msxml3.dll
regsvr32.exe %windir%\SysWOW64\msxml4.dll
regsvr32.exe %windir%\SysWOW64\ole32.dll
regsvr32.exe %windir%\SysWOW64\oleaut32.dll
regsvr32.exe %windir%\SysWOW64\es.dll
regsvr32.exe %windir%\SysWOW64\comsvcs.dll
vssvc /register
    • You may not have the msxml4.dll installed.  Though they are not required, If you are missing msxml4.dll or msxml4r.dll (they should be in your system32 directory) and want to have them installed, then you can Windows Update and update Explorer. and then rerun the command for these DLLs after they are in your system32 directory.
    • After reboot you should run the following command and check if all the VSS writers states are good/stable:
"C:\> vssadmin list writers"
    • And this command should show no existing shadow copies:
"C:\> vssadmin list shadows"
    • At this point things should be cleaned up enough for you to start using ShadowProtect. Proper VSS interaction is a very complex affair and many backup products (including,Microsoft's own backup softwares) can leave various components, especially VSS writers, in bad states.  This can cause problems for other backup products. So if you are using any other backup products, it's very possible that they may continue to damage the states of various VSS components.
0 Kudos