coolerkid9090
Contributor
Contributor

VMWare on Retina MacBook

I'm running 5.0.1 on my Retina MacBook, the graphics for VMWare are updated for the Retina display, but Windows still runs in normal resolution, everything running in Windows is pixelated. I have seen Parallels running Windows and everything looks a lot smoother, the OS, a lot of the software, the text, ect. are displaying at the Retina resolution, not pixalated. I see they automatically change the DPI settings in Windows and VMWare doesn't. I've tried changing the VMWare settings in Windows to match what Parallels was using, but it still was pixelated in VMWare. Can I get VMWare to show the smooth, Retina resoluiton by changning any settings or does VMWare just not support this yet?

0 Kudos
6 Replies
dlhotka
Champion
Champion

1) What version of Windows?

2) Did you upgrade the virtual hardware and install the latest VMWare tools?

3) If you're moving a VM back and forth between the two, you're likely leaving bits of the other products drivers in the OS.  Try a clean OS install in Fusion.

0 Kudos
coolerkid9090
Contributor
Contributor

1) Windows 7

2) I updated the tools, how exactly do you upgrade the hardware, I thought that was done by the updater when you install the latest version? When it asked to upgrade the virtual machine after the update I said yes.

Does VMWare even support this functionality?

0 Kudos
wila
Immortal
Immortal

Hello,

2) I updated the tools, how exactly do you upgrade the hardware, I thought that was done by the updater when you install the latest version? When it asked to upgrade the virtual machine after the update I said yes.

Does VMWare even support this functionality?

The tools that enhance the support of the guest OS are not the same as the virtual hardware.

If you shut down your virtual machine and then go to: Virtual Machine menu -> Settings -> Compatibility.

You'll get a screen with a number of radio buttons. It should have the "Compatible with VMware Fusion 5 or higher" option selected.

When that's done, under settings still, go to Display and select the checkbox "Use full resolution for Retina display"

Hope this helps,

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
coolerkid9090
Contributor
Contributor

ok, so "Use full resolution for Retina display" wasn't turned on. After turning that on it still didn't work though. I had to go to the DPI settings and set it to 200%, then turn the resolution up as high as it goes, now I see the text smoothed out. Of course most apps get screwed up becuase they weren't designed to handle higher DPI, but at least the ones I use Windows for don't have this problem, so everything is cool now. Is this the correct way to do it?

0 Kudos
wila
Immortal
Immortal

Good question, that someone else will have to answer as I do have a new macbook pro, but not one with a retina display.

I would think that setting the checkbox and using the latest virtual hardware (Fusion 5 only) should be good enough.

Like you say "upscaling the DPI" is not something all Windows applications will handle with grace.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
wrhahn
Contributor
Contributor

I have been running VMWare Fusion V4 and V5.x on my MacBook Retina since July 2012.  Before that I ran VMWare Fusion on several MacBooks dating back to 2010.

Here are my successful experiences and configuration details I recommend for Retina MacBook colleagues:

My advice to colleagues moving to new Retina MacBooks:

1) Use VMWare Fusion V5.x for your Windows Guests, and make SURE you turn off Mouse Shadow in the Windows Guest

    1.1) VMFusion V5 seems to run Win7 faster and handles Retina graphics  better, including Win7 fullscreen on resume and initial boot.

2)  Make sure you turn Mouse Pointer Shadow OFF in your Windows Guests (I  had to say it again, since it caused me so much pain for weeks 🙂

     2.1) Ref: Thread > http://communities.vmware.com/message/2125917#2125917

3) Set Mac OS X System Preferences > Energy Saver > DISABLE (un-check) for Automatic Graphics Switching

     3.1) The only times I have experienced stability issues is when this has  not been disabled...spanning multiple OS X updates from Apple )

     3.2) VMWare forces Retina MacBooks into NVidia 'advanced' dedicated graphics mode anyway, so you might as well force it to stay there to avoid stability issues on Retina MacBooks when switching between graphics modes....which of course effects your battery life, but I'd rather have my MacBook not crash.

4) Set Mac OS X System Preferences > Energy Saver > Display Sleep NEVER (for BOTH Battery AND Power Adapter)

     4.1) This relates to a NASTY bug with Retina MacBooks where the screen becomes buggy/ragged after display resumes from sleep.  It looks like screen refresh/repaint problems.  You can surf the Apple community forums about this, as there are plenty of threads about it.

     4.2) Do yourself a favor and just force your display to NEVER Sleep if you have a Retina MacBook, regardless of whether you use VMWare or not.

The  above is based on my experiences with Retina MacBooks since June/July  2012 and also includes experiences with VMWare Fusion on MacBooks since  early 2010.

0 Kudos