Yvo999
Contributor
Contributor

VMWare Fusion 10.0.1 doesn't see USB devices anymore [SOLVED]

My previous setup was:

MacOS 10.12 Sierra

VMWare Fusion 7.1, running

- Windows 7

- Windows 10

All was fine until I upgraded to MacOS 10.13, High Sierra.

Started VMWare Fusion, all well. Started the Windows 7 VM and my iMac crashed instantly. Split second.

Upgraded to VMWareFusion 10.0.1.

Got the "System Extension Blocked" message and allowed VMWare Fusion in the MacOS Security & Privacy settings.

But both Windows 7 and Windows 10 VM's don't see USB devices anymore. No error message, no warning. They just don't see them.

I Googled around, even saw the other post related the subject below, but no solution found.

???

Edit: Completely removed VMWare Fusion and did a clean install. Still the same problem...

Edit 2: Shouldn't there be an usbarbitrator service running in the VM's? I don't see any. Also /var/run/vmware doesn't show anything related.

Edit 3: The service usbarbitration (on the host) doesn't run. /Library/Logs/VMware USB Arbitrator Service.log contents:

2017-10-07T19:47:01.361| ServiceImpl_Daemon: PID 833

2017-10-07T19:47:01.362| ServiceImplRef: Before start().

2017-10-07T19:47:01.576| Warning: UsbarbServiceCommon: exit status 6912.

2017-10-07T19:47:01.576| ServiceImplRef: After start().

2017-10-07T19:47:01.576| ServiceImplDaemon: Exiting with code 0.

Started VMWare Fusion and started usbarbitrator by hand: sudo /Applications/VMware\ Fusion.app/Contents/Library/vmware-usbarbitrator --kext /Applications/VMware\ Fusion.app/Contents/Library/kexts/vmioplug.kext

Same results, not working, not running. And log file shows the same.

Beats me.

Yvo

29 Replies
RickShu
VMware Employee
VMware Employee

Hi Yvo999,

Have you tried to restart your host OS? Also, you may need to quit Fusion and re-open it once you have allowed the "System Extension Blocked" setting.

Regards,

-Rick

0 Kudos
Yvo999
Contributor
Contributor

Hi Rick,

Yes, everything has been rebooted/restarted... No use.

Yvo

0 Kudos
swearsattechnol
Contributor
Contributor

0 Kudos
Yvo999
Contributor
Contributor

Thx, I will give it a try as soon as I am behind the respective Mac...

Yvo

0 Kudos
zinone
Contributor
Contributor

Hi.  I just upgraded to Mac OS 10.13 High Sierra and then upgraded to Fusion 10 from Fusion 6.  My guest machine is Windows 7 64-bit.  Under Fusion 6 and Mac Yosemite, I could plug in a USB device and Fusion would ask me which system I wanted to connect it to.  After the upgrade, it would only connect to Mac and didn't give me the choice any more.

I just spoke to support and they solved it immediately.  It appears to be the Mac blocking something, not a problem with VMWare.  They are in touch with Apple and will be addressing this in the next release.  There were two main steps, but I think it was really the second step that did it.

1.  Shut down the guest Windows machine (not suspend).  In the Fusion window, right click the name of the guest machine and choose Settings.  Then click USB & Bluetooth.  Then click Advanced USB options.  Then click Remove USB Controller.  Open the Windows guest machine and then shut it down again (not suspend).  Go back to USB & Bluetooth in Fusion Settings for the guest machine and this time click Add USB Controller.

2.  Click the Apple logo in the top left of the Mac screen.  Click Security & Privacy.  For me, there was an error message that said something like "Mac is blocking VMWare process".  Click Allow.  Problem solved.

As I said, I think it was probably just the second step, but that's what worked for me.

0 Kudos
Yvo999
Contributor
Contributor

Top, will try that as well!

Yvo

0 Kudos
bgoodz
Contributor
Contributor

Same here, tried all the above VM/windows 10 still not seeing USB thumb drive.  Mac  side recognizes it but still no "connect to Mac/Windows"message from VM.  No errors reported in Mac Security/Privacy either.

0 Kudos
bgoodz
Contributor
Contributor

Ok, might have found the fix ( at least for mine).  Followed the above instructions however VM/Win10 was still not recognizing the USB Thumb Drive. Went to Mac Security & Privacy / Firewall / Firewall Options.  Added VMFusion.app to allow incoming connections.  Shut down both VMFusion and Mac then rebooted both. Checked VMFusion virtual Machine Win 10 settings / USB & Bluetooth, now Thumb Drive listed. Inserted Thumb Drive and received message box "Connect to Mac / Connect to Windows"

Hope this helps

Yvo999
Contributor
Contributor

Makes sense, but your firewall is enabled then? Mine is off...

Yvo

0 Kudos
mlsmithjr
Contributor
Contributor

A variation of this worked for me.

I dragged the Fusion app to the trash, the used Put Back to restore it.

Then launch Fusion, open Preferences > Security & Privacy > General and there should be a message at the bottom with an "allow" button. Click that.

Now my VMs show all connected USB devices.

Whew, glad that is solved.

Yvo999
Contributor
Contributor

Hi All, a big thanks for all the contributions. The problem is solved.

I started with the most easy option, move the VMWare app to the recycle bin with "put back" moving it back in place. Started VMWare and quitted again. System preference security wanted me to allow VMWare to make changes. I unlocked the pane and clicked allow.

Started VMWare again.

In a terminal window I grep'd for VMware processes and YES, there it was: /Applications/VMware Fusion.app/Contents/Library/vmware-usbarbitrator

Hopeful fired up the Windows 7 guest, connected a USB stick and yes, now VMWare asked me to which platform I wanted to connect.

Big thanks again!

Yvo

ljl70478569
Contributor
Contributor

You can re-add an administrator through the MAC user, so the data re-import into the new administrator account (including VMWare Fusion), so re-open VMWare Fusion can use the USB option!

Hope to help solve!

0 Kudos
igsstern
Contributor
Contributor

My system is 10.13 High Sierra, and I'm running Windows XP for my old measurement devices. But, from the moment that I upgraded to High Sierra, Windows XP doesn't recognize any USB device.

I did everything in this post. But nothing works. So my problem hasn't been solved yet. It is very serious problem for me.

0 Kudos
Mikero
Community Manager
Community Manager

Please file a support ticket so we can help.

desktop-services@vmware.com

-
Michael Roy - PM/PMM: Fusion & Workstation
0 Kudos
PJG51
Contributor
Contributor

Solution : disable SIP !

Work with SIP disabled until update from VMWare.

Lenonking9
Contributor
Contributor

1、don't update 10.0.1 from the lower version,if you do this delete de VM ,then reinstall it from the 10.0.1 dmg file;

2、start the vm with win10/win7 template or mirror image;

3、in the top status bar,click usb log, the choose connect apple ibrige,then you can find you usb device

all is my personal  experience, hope it useful to you.

camner
Contributor
Contributor

Alas, this didn't work for me.  I did get the message with the "Allow" button in Security and Privacy, but USB devices still do not appear.

0 Kudos
javarithms
Contributor
Contributor

I'm running into the same issue. What is the fix??

Really, disappointed in VMware releasing software that was obviously not thoroughly tested.

0 Kudos
fisherd78
Contributor
Contributor

Disabling SIP (System Integrity Protection) in OS X worked for me. Thank you!

VMware fusion 10.0.1 on OSX 10.13.1 (high sierra)

running Windows 10 Pro

0 Kudos