Luminatio
Contributor
Contributor

VM became extremely slow after upgraded to macOS 10.14.6 [Officially Solved]

Jump to solution

------------20190827--------------------------

This issue is officially solved with Apple’s macOS 10.14.6 supplemental update.

Thanks to all of you.

A thumb down to Apple’s software team...

————————

After I upgraded my 2 MBP to 10.14.6, all of the Windows VMs became extremely slow and stuck at the login screen...

The VMs are set to use TPM, I don't know if it's relevant.

Anyone came across the same situation?

Now I cannot continue my work...really frustrating...

—————20190727————-

I’m updating this for convenient reference.

Status: This issue has not been solved yet.

Many users encountered this issue which leads to completely unusable of VMs.

And we got some replies from Fusion developers, you could help developers identify issues by replying your hardware models/is disk encrypted or have the VM encrypted etc.

We have some reports that some users found out that if set the memory of VM to 2G could help.

Re: VM became extremely slow after upgraded to macOS 10.14.6

If you don’t need to use much memory and can work with it, you might try set the memory to 2G, or maybe less than 4G is also okay?

Still we are waiting for an official solution.

------------20190809--------------------------

Thanks to ksc

Re: VM became extremely slow after upgraded to macOS 10.14.6

I updated to Fusion 11.1.1, confirmed that I can login to the system, and desktop shows normally.

As ksc says, it is a workaround which I'm not quite sure if I can trust it to do my work in it....

At least, I'm able to get my works out and change to other options now.

I'll mark this issue as resolved for now, but keep the [Workaround Released] tag in the subject.

Looks like it would take quite some time for a real fix, I'll keep an eye on this.

消息编辑者为:Liam

1 Solution

Accepted Solutions
dlhotka
Champion
Champion

And it looks like we might have just gotten a fix:

"- Fixes an issue that may degrade performance when working with very large files"

Apple Releases tvOS 12.4.1, watchOS 5.3.1, and a macOS Mojave 10.14.6 Supplemental Update - MacRumor...

---------------------------------------------------------------------------------------------------------

Was it helpful? Let us know by completing this short survey here.

View solution in original post

226 Replies
katt_man
Contributor
Contributor

Same issue here...no TPM.

0 Kudos
aykay123
Contributor
Contributor

Same here, my Windows VMs are practically unusable, with very high CPU load. Please fix this soon!!

0 Kudos
Sven1802
Enthusiast
Enthusiast

Having exactly the same issue. Testing VMware Fusion with Windows 10 and TPM. Now I cannot work with it anymore.

billearl
Enthusiast
Enthusiast

Working fine here with Mojave 10.14.6.

Update: I spoke too soon. It worked fine for a little while, but is now unusable.

KellyF
Contributor
Contributor

Same here!  We need a fix real fast...  😞

MacOS 10.14.6

Fusion 11.1.0

VM: Windows 10, 6 GB

dlhotka
Champion
Champion

Haven't upgraded yet - are there folks reading the thread who have, and are NOT having problems?  Trying to gauge how widespread this might be.

tonyfortpedroco
Contributor
Contributor

My VM is not completely stuck, it's as if it freezes at random intervals every ~30 seconds and stays frozen for 5-10 seconds. In between those freezes, it seems to work normally. Seeing similar behavior as other users after upgrading to 10.14.6 yesterday. Issue seems to occur whether using full screen mode or windowed. VMWare Fusion is 11.1.0, latest available. Mac Activity Monitor doesn't show high/abnormal CPU usage when the guest is idle.

vmware fusion host settings:
6144 MB memory, 4 cores for guest
VT-x/EPT not enabled
code profiling not enabled
IOMMU not enabled
3d graphics enabled

vm hwardware version 16
bridged networking: autodetect (using wired gigabit ethernet via CalDigit 3 thunderbolt dock)

256gb virtual disk, 72gb used

vmware guest:
windows 10 pro ver 1903 build 18362.239

host hardware:
macbook pro 15-inch 2018
2.2 GHz Core i7
16GB RAM
Hybrid graphics (Radeon PRo 555X 4GB)

0 Kudos
jcnika
Contributor
Contributor

Seems this isn't specific to Windows guests.

Ever since installing the latest macOS update last night I've begun experiencing terrible sluggishness when running anything fairly CPU-intensive with my Ubuntu 19.04 guests, even if it's merely upgrading software packages or launching a browser.

Running htop in the background on the guest while the problem is occurring indicates there's not a corresponding maxing out of memory or any swap file usage, and the virtual CPU spiking appears to coincide with heavy disk IO activity.

Host:

MacBook Pro Touch Bar (2017)

  • macOS 10.14.6
  • 4 Core 2.8 GHz Intel Core i7
  • 16 GB 2133 MHz LPDDR3
  • Radeon Pro 555 2 GB
  • Intel HD Graphics 630 1536 MB

VMware Fusion 11.1.0 (13668589)

Guest:

Ubuntu 19.04, fully updated, using Ubuntu's distribution of open-vm-tools

VMware Hardware Version 16

2 virtual cores

6144 MB virtual memory

Accelerated 3D Graphics, 768 MB Shared Memory, full resolution for Retina display

20 GB virtual disk, split into multiple files, not pre-allocated

VMware-encrypted

UEFI Boot

No TPM

2 Shared folders with host

Isolation: no drag-and-drop, no clipboard

0 Kudos
sshetty
VMware Employee
VMware Employee

Hi Everyone,

Thank you for staying alert and notifying about the issue.

While we watch this closely and find more about the issue, a list of hardware on which the issue is notice, should also help verify the trend.

I see a MBP 2017, 2018 do we have others?

0 Kudos
Luminatio
Contributor
Contributor

My 2 Macs are MBP 13'' 2015 and MBP 15'' 2018, both having the same issue.

0 Kudos
prpsarathy
Contributor
Contributor

Encypted vm has become unusable.  non encrypted vm are working ; but with a little snag

0 Kudos
reihl
Contributor
Contributor

My VMWare Fusion also slow on MBP mid 2012 i7 16GB RAM and SSD. CPU is sky high and the Disk also pick to 100%. The Fusion version is 10 (latest build) Windows 10 1903 (4 vm core cpu and 4096Mb RAM) unusable but Windows 7 works as expected also linux without GUI works as expected.

0 Kudos
jcnika
Contributor
Contributor

Okay, my Ubuntu guest is working fine after I changed three things in its VMware settings, but I'm not sure exactly which one was responsible for working around the problem because I didn't boot the guest again until I had done all three:

  1. I un-split the 20 GB hard disk: In Settings -> Removable Devices -> Hard Disk (SCSI) -> Advanced Options I un-checked Split into multiple files then clicked Apply
  2. After the split disk images were finished being merged into a single image, I disabled encryption: In Settings -> Other -> Encryption & Restrictions I un-checked the Enable Encryption option
  3. After the VM was finished being converted to unencrypted form, I changed Settings -> Other -> Advanced -> Troubleshooting from Default to None

This is of course not a solution, since the real cause of the problem still exists, and although I don't care about split disks or logging settings I do need encryption.

0 Kudos
Sven1802
Enthusiast
Enthusiast

Hi, iMac 2017 also fails. 16GB RAM, 8GB for the VM. Also with VMWare encrypted drive as I need to use TPM.
I want to move from Parallels to VMWare Fusion. With this issue it's stuck booting Windows.

0 Kudos
ChristosPas
Contributor
Contributor

With Latest Mojave update Vmware Fusion is not function well. Big damage for me as i can't work at all.

my Win10 become unused.  Macbook Pro Late 2013 16Gb ram SSD 1TB Nvidia Mojave Version 10.14.6 , Vmware Fusion Latest Professional Version 11.1.0 (13668589),

vm Windows 10 Build 1903.

Please we need fix ASAP.

Thank you

0 Kudos
Luminatio
Contributor
Contributor

Now I'm 80% sure that this issue happens to encrypted VMs only. Hope it will be fixed very soon...

0 Kudos
reihl
Contributor
Contributor

My VM isn't encrypted (However the MacOS is encrypted with FileVault) and The issue is happening

0 Kudos
michelstoffel
Contributor
Contributor

After upgrade to 10.14.6 my VMware fusion 11.1.0 version with Windows 10 is extremely slow with less memory. It's come be very difficult to work.

Please a fix as soon at possible.

Thanks

0 Kudos
aykay123
Contributor
Contributor

The situation got better for me after I removed the virtual TPM and disabled the VMWare Encryption. I still have the feeling that it doesn't run as well as before the update, but I can continue work.

0 Kudos