Luminatio
Contributor
Contributor

VM became extremely slow after upgraded to macOS 10.14.6 [Officially Solved]

Jump to solution

------------20190827--------------------------

This issue is officially solved with Apple’s macOS 10.14.6 supplemental update.

Thanks to all of you.

A thumb down to Apple’s software team...

————————

After I upgraded my 2 MBP to 10.14.6, all of the Windows VMs became extremely slow and stuck at the login screen...

The VMs are set to use TPM, I don't know if it's relevant.

Anyone came across the same situation?

Now I cannot continue my work...really frustrating...

—————20190727————-

I’m updating this for convenient reference.

Status: This issue has not been solved yet.

Many users encountered this issue which leads to completely unusable of VMs.

And we got some replies from Fusion developers, you could help developers identify issues by replying your hardware models/is disk encrypted or have the VM encrypted etc.

We have some reports that some users found out that if set the memory of VM to 2G could help.

Re: VM became extremely slow after upgraded to macOS 10.14.6

If you don’t need to use much memory and can work with it, you might try set the memory to 2G, or maybe less than 4G is also okay?

Still we are waiting for an official solution.

------------20190809--------------------------

Thanks to ksc

Re: VM became extremely slow after upgraded to macOS 10.14.6

I updated to Fusion 11.1.1, confirmed that I can login to the system, and desktop shows normally.

As ksc says, it is a workaround which I'm not quite sure if I can trust it to do my work in it....

At least, I'm able to get my works out and change to other options now.

I'll mark this issue as resolved for now, but keep the [Workaround Released] tag in the subject.

Looks like it would take quite some time for a real fix, I'll keep an eye on this.

消息编辑者为:Liam

226 Replies
reihl
Contributor
Contributor

It's solved on Apple 10.4.6 supplemental update build 18G85. Finally it's became to the end. I have windows 10 with 4GB of rum no 100% cpu and the machine is responsive. (VMWare 10.1.6)

0 Kudos
ksc
VMware Employee
VMware Employee

And it looks like we might have just gotten a fix:

"- Fixes an issue that may degrade performance when working with very large files"

Indeed they did!

I have a confirmation from Apple that "very large files" specifically refers to this issue.

rossco_au
Enthusiast
Enthusiast

Thanks for the confirmation ksc​.  Great to see Apple respond relatively quickly to this issue (and thanks again to VMWare).

I've installed the supplemental update and rolled Fusion back to 11.1 - all good on my iMac (but didn't hit the perf issues due to 40GB of RAM).  I assume going back to 11.1 is the best option for the moment to remove the workaround?

0 Kudos
pauljacobevans
Contributor
Contributor

Should we roll back to 11.1, or are we good to go?

Thanks again ksc for the insight and transparency throughout the process.

0 Kudos
ksc
VMware Employee
VMware Employee

I assume going back to 11.1 is the best option for the moment to remove the workaround?

Yes, though removing the workaround isn't strictly necessary.

The workaround (significantly) widened the interval where a crash could cause us to leave behind a large file in a temporary directory, which would get cleaned up at reboot anyway. Unless you are crashing a lot (and if so, hopefully we have heard about it for other reasons...), the effect is invisible.

We won't be releasing an 11.1.2 just to remove the workaround, though any future release is likely to remove it.

philadev
Contributor
Contributor

I still have problems, with a Windows Server 2019 VM that worked fine before upgrading to Mac OS 10.14.6, Fusion 11.1.0 (downgrade from 11.1.1 where I first observed the problem).

Prolonged total beach-ball freezes that happen intermittently.

I applied this:

> Named VMEM file switched off by adding these 2 lines to ~/Library/Preferences/VMware Fusion/config (create it if it isn't present):>

> mainmem.backing = "swap"

> mainmem.useNamedFile = "FALSE"

Accelerate 3D Graphics is off.

2015 MB Pro, 16Gb RAM, About 11Gb allocated to the VM, . Again, it's been fine in the past.

Can you summarize what would be the right combo of version & workarounds, assuming my problem is covered by this thread?

0 Kudos
lalee123
Contributor
Contributor

I've got Win10 running on a 2019 iMac running Mojave 10.14.6 (18G87) with 24 GB.

Upgrading to VMware 11.1.1 caused my VM to exhibit the slowdown / beachball issues described in this thread.

Deleting 11.1.1 and reinstalling 11.1.0 has restored original performance.

Thank you! Looking forward to the next update, glad this thread was here.

0 Kudos
dariusd
Leadership
Leadership

Hi philadev,

If you have not already done so, please install the latest macOS Supplemental Update which will upgrade your macOS host to 10.14.6 (18G95) or newer.  Neither the original macOS 10.14.6 (18G84) nor the first Supplemental Update (18G87) are capable of reliably running any version of VMware Fusion at full performance, regardless of which workarounds or Fusion versions you might try.

You can check your macOS build by choosing the Apple Menu (in the top left corner of the screen) and then choosing About This Mac, then clicking on the text "Version 10.14.6".  The build identifier (18G84, 18G87 or 18G95) will appear to the right of the version number.  Only 18G95 has the fix for this issue.

Cheers,

--

Darius

dariusd
Leadership
Leadership

Hi lalee123,

Interesting...  What you report is not what we would expect.

Anyway, macOS 10.14.6 (18G87) is affected by the critical performance regression discussed in this thread.  To remedy the problem, install the latest Supplemental Update, which should bring your host up to macOS 10.14.6 (18G95).  Please try installing that Supplemental Update if possible, as it should resolve this problem.

Thanks,

--

Darius

0 Kudos
philadev
Contributor
Contributor

Thank you dariusd, I'm sure that was the missing piece. I didn't have the right supplemental update.

0 Kudos
philadev
Contributor
Contributor

Back to normal and can confirm that 18G87 is insufficient, you need 18G95. For a little while I thought it was working with 18G87 (didn't know that's what I had) but it soon deteriorated back to the mess it was before I downgraded to Fusion 11.1.0.

All is well now with my system running 18G95 & Fusion 11.1.0.

0 Kudos
minigeeko
Contributor
Contributor

Hi all, I had most of the problems noted here; horrid hangs and plenty beachballs.

After reading plenty on this forum thread (thanks all!), and spending hours trying to implement all suggestions, finally simply DISABLING 'Accelerate 3D Graphics' seems to have solved the issue for me. (running OK for past 2 days now). Keep in mind though that I did perform some of the other suggestions, and then rolled them back.

Please try DISABLING 'Accelerate 3D Graphics' first and see how you go and hopefully that will save some headaches.

Running VMWare Fusion Version 11.1.1 (14328561)

Guest: Windows 10 (latest version as of today) 8gb / 60gb HD / 4 cores ENCRYPTED VM and with Bitlocker encryption on guest disk (corporate image) with TPM enabled

My configuration:

  Model Name:     MacBook Pro

  Model Identifier:     MacBookPro11,5

  Processor Name:       Intel Core i7

  Processor Speed:      2.5 GHz

  Number of Processors: 1

  Total Number of Cores:        4

  L2 Cache (per Core):  256 KB

  L3 Cache:     6 MB

  Hyper-Threading Technology:   Enabled

  Memory:       16 GB

  Boot ROM Version:     194.0.0.0.0

  SMC Version (system): 2.30f2

0 Kudos
RBuday
Contributor
Contributor

I can confirm the supplemental update to OSX 10.14.6 (18G95) does not fix the slowness problem in Fusion 11.1.1. on an iMac with 3.1 GHz Intel Core i7 with 16 GB RAM.

I installed the update and turned off encryption and waited for it to complete. I then cleaned up the virtual machine, shut down the VM and quit Fusion. After relaunching Fusion, I boosted the virtual machine's memory setting to 8GB, set to 2 out of 4 processor cores, and turned on accelerate 3D graphics. Then I opened the virtual machine.

Windows 10 took about 15 minutes to get to the login screen. It took another 3 minutes for the desktop to appear. There was about a 10 second lag between keystrokes. The only program running on the Mac side was Preview.

I tried again with the same settings, but with accelerate 3D graphics turned off. The speed increased by a factor of about two—which is still too slow to be used.

So, for me, the OSX 10.14.6 supplemental update did not fix the Fusion slowness problem. Resetting VM memory to 1996K makes Fusion usable, but just barely.

--- UPDATE ---

I downgraded from Fusion 11.1.1 to 11.1.0, upped the memory to 8 GB and left 3D graphics off. Fusion is now back to running at a decent speed.

0 Kudos
RaoulSchaffner
Contributor
Contributor

has the 11.1.1 update been partially pulled?

the update xml file still references it, but the actual directory is gone:

https://softwareupdate.vmware.com/cds/vmw-desktop/fusion/

https://softwareupdate.vmware.com/cds/vmw-desktop/fusion.xml

0 Kudos
RaoulSchaffner
Contributor
Contributor

reply to self:

depending on where you are, you get different dns name resolutions for softwareupdate.vmware.com.

in one location, it resolves to 23.54.113.177, which does not carry the 11.1.1 update packages.

in another location, it resolves to 23.211.4.34, which does carry the 11.1.1 update packages.

there seems to be a glitch in the akamai cds setup.

btw, sorry to hijack this thread.

i hope others might find this information useful.

r.

0 Kudos
dlhotka
Champion
Champion

Most likely your problem is that the guest has too many cores configured.  No individual VM should have more than N-1 physical (not virtual/hyperthreaded) cores assigned.  So on a 4-core machine, never assign more than 3 cores to any VM.  Otherwise you risk starving the host.

Note that host issues can be intermittent, so just because it ran fine in the past, doesn't mean it will in the future.  All depends on what the host is doing at at the time.

0 Kudos
itlifesaver
Contributor
Contributor

Confirming the same, OSX 10.14.6 18G95 did not resolve my issue here until I downgraded to Fusion 11.1.0.

iMac 5K 27" late 2015 with 32gb RAM

Graphics acceleration still disabled. May turn that back on if continues to be stable.

0 Kudos
ksc
VMware Employee
VMware Employee

has the 11.1.1 update been partially pulled?

Yes, it was partially pulled.

With Apple's supplemental update, there's no longer any need to update to 11.1.1 (it has nothing other than the workaround that is no longer needed). However, having 11.1.1 is not harmful.

And we would be releasing 11.5 just about as fast as we would release any 11.1.x version. 11.5 contains a very different solution to the problem that caused this bug - we've had enough time to test it out and are happy with the results.

VMworld 2019: Fusion and Workstation Announcements - VMware Fusion Blog - VMware Blogs

0 Kudos
itlifesaver
Contributor
Contributor

I still continue to have issues after the MacOS supplemental update and have tried both Fusion versions 11.1.0 and 11.1.1. Ultimately I had to decrease the RAM on the Windows VM to 2GB from the 8GB I was using before, and it's now been stable for days. I'm not sure if I'm just an edge case since the iMac has 32gb RAM or what, but hopeful the mentioned 11.5 resolves the problem.

0 Kudos
dlhotka
Champion
Champion

How many physical cores in the machine and how many are configured for the guest?

Also, are you using a fusion drive?

0 Kudos