Luminatio
Contributor
Contributor

VM became extremely slow after upgraded to macOS 10.14.6 [Officially Solved]

Jump to solution

------------20190827--------------------------

This issue is officially solved with Apple’s macOS 10.14.6 supplemental update.

Thanks to all of you.

A thumb down to Apple’s software team...

————————

After I upgraded my 2 MBP to 10.14.6, all of the Windows VMs became extremely slow and stuck at the login screen...

The VMs are set to use TPM, I don't know if it's relevant.

Anyone came across the same situation?

Now I cannot continue my work...really frustrating...

—————20190727————-

I’m updating this for convenient reference.

Status: This issue has not been solved yet.

Many users encountered this issue which leads to completely unusable of VMs.

And we got some replies from Fusion developers, you could help developers identify issues by replying your hardware models/is disk encrypted or have the VM encrypted etc.

We have some reports that some users found out that if set the memory of VM to 2G could help.

Re: VM became extremely slow after upgraded to macOS 10.14.6

If you don’t need to use much memory and can work with it, you might try set the memory to 2G, or maybe less than 4G is also okay?

Still we are waiting for an official solution.

------------20190809--------------------------

Thanks to ksc

Re: VM became extremely slow after upgraded to macOS 10.14.6

I updated to Fusion 11.1.1, confirmed that I can login to the system, and desktop shows normally.

As ksc says, it is a workaround which I'm not quite sure if I can trust it to do my work in it....

At least, I'm able to get my works out and change to other options now.

I'll mark this issue as resolved for now, but keep the [Workaround Released] tag in the subject.

Looks like it would take quite some time for a real fix, I'll keep an eye on this.

消息编辑者为:Liam

226 Replies
gebara
Contributor
Contributor

definitely my thoughts !!!

i'm deeply impressed by the patience shown here ... is there anyone really working with his virtual machine ???

now i´ve been kicked off productive usage for at least three weeks and there is only hope - perhaps Apple will fix it, perhaps VMware finds a workaround ...

i really have to ask myself whether this is an environment i´ll put my confidence in ...

Sincerely yours

0 Kudos
aykay123
Contributor
Contributor

I keep asking myself the same questions:

  • Why didn't VMWare notice this during testing?
  • Should we blame VMware or Apple for this?
  • How can it be that we have to wait weeks for a real solution?
  • What lessons can I draw from this misery with regard to my future working setup?

VMWare, we're not just using your product for gaming or for non-essential things. Our daily work is heavily based on reliable virtualization, but that doesn't seem to be what Fusion was made for Smiley Sad

0 Kudos
dlhotka
Champion
Champion

This was apparently a last minute change in a minor OS update.  Apple rarely makes a fundamental shift in memory management without notice, but in this case they did...and they broke something in the process.  We're talking about having to change something that's pretty core to how fusion works in order to get around the Apple bug. 

The best option going forward is to upgrade on a test machine first.  If that's not possible, then, unless there's an urgent security fix in the patch, wait a few days to see if anything breaks.

0f2g
Contributor
Contributor

This does nothing for those of us using company-issued VMs with limited flexibility; I am thoroughly disappointed that the Apple update (which cannot be easily rolled-back) rendered my VM entirely useless.  In an effort to "troubleshoot" this problem, I was forced to rebuild the image.  Only after trying that did the IT team realize the issue was not with "me", but instead was an "unresolved" problem found here.  I am absolutely livid I cannot simply reactivate my "old" VM.

Now I have completely abandoned all "official" images assigned by my company, because disabling encryption is "not an option".  At this point, I would be better off switching to some self-serviced bare-metal hypervisor or a container solution and dealing with any challenges it would create than ever trusting that something like this will "never" happen again.

Fck Apple for their archaic update methods & for ultimately creating this issue.

0 Kudos
ppatel1107
Contributor
Contributor

I have a company issued MacBook that encrypted (along with the VM) and this worked for me to at least roll it back to 10.14.5 and this may not be the case for every.   My MacBook came installed with High Sierra. I followed the below steps to get back to 10.14.5.

1. Backed up the VMWare file to an external location.

2. Factory reset the MacBook to original OS it came with (Option-Command-R)

3. Upgraded to Mojave once the notification came in the App Store that a new Mac OS was available.  When I talked to Apple Support, they said this solution wouldn't work and the update would upgrade me to latest OS version (10.14.6).  But it did not, it upgraded me to 10.14.5, I am not sure if this is because Apple is aware the issue and that's why they're not upgrading straight to 10.14.6. But whatever the reason, I'm happy i'm back to where I was before 10.14.6 update.

Hope this is a solution possible to many

0 Kudos
lfreitag
Contributor
Contributor

I am increasingly questioning why I have been willing to waste time and energy in trying to run Windows in a virtual machine on a Macbook Pro.  To spend the extra money to configure that expensive laptop to have the resources necessary to run some demanding Windows-based software for my business in a virtual environment (that still isn't as fast as it should be) while crushing the laptop's battery is bad enough---but now to deal with this crippling issue is the last straw.  I think the only correct solution to prevent this from ever happening again is to buy a dedicated Windows machine. 

0 Kudos
Luminatio
Contributor
Contributor

Doubt it.

I don’t think this is a "last minute" change, even 10.4.6 is a minor update, the beta was released for quite awhile,

besides that, this issue also happens in 10.5 betas, which released for a long time.

If there was anyone had tested VM in those betas, they could release a warning at least,

but VM did not notice this even after 10.4.6 officially  released 2 days!!

until I posted this issue, I searched all over the internet and didn’t find anything mentioning this.

0 Kudos
Wegener22
Contributor
Contributor

But wait! Although I do not know the English proverb: "a rogue, who thinks evil ..."

there will be a Fusion v12, where everything works just fine. Just upgrade! (irony)

0 Kudos
gebara
Contributor
Contributor

it works, it works

the latest mojave 10.14.6 supplemental update did it

today is the last day of my parallels trial, but i'll keep the new parallels vm as an emergency reserve😉

0 Kudos
gebara
Contributor
Contributor

NO NO NO - it doesn´t

i forgot to reset my memory to 8GB again, now i tried out and it´s as bad as before ;-(((((

so, good bye VMWare, hello Parallels

0 Kudos
brandtsak
Contributor
Contributor

Same issue here.  Just upgraded my mac and the VMware side is unresponsive and unusable.

0 Kudos
ktukker
Contributor
Contributor

I just got to this thread after upgrading to 10.14.6 this morning and noticing a slow "resume" on my Win10 VM ;-(

Aside from VMWare not catching the issue, merely the did not communicate pro-actively that there are issues currently with Fusion 11 and 10.14.6

Waiting for this to be resolved and running my VM at quarter capacity in the mean time.....

0 Kudos
JensBau12
Contributor
Contributor

I just got the info from support that they will provide a fix by 9th, latest 12th august via the regular update tool

pauljacobevans
Contributor
Contributor

Thank you for the update... Good to hear...

0 Kudos
nike8270
Contributor
Contributor

hi

Do you have all the same problem namely today i update my IOS to 10.14.6 and the machine doesn't start anymore ;

I get this black screen with following text ( see attached file )

do you have all same experience after download new latest IOS?

regards

rudi

0 Kudos
wila
Leadership
Leadership

Hi Rudi,

Apparently that's a different issue. See Re: 10.14.6 supplemental update hangs VMWare fusion after restart/reboot

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
ksc
VMware Employee
VMware Employee

Some good news...

We've just released Fusion 11.1.1. It hasn't hit the auto-update mechanism yet (and it will), but I do see it downloadable through the Fusion download page.

Download VMware Fusion | VMware

This has a workaround for encrypted VMs; they are usable again across all memory sizes. I'll call the workaround "good" but not "great" (and since I wrote it, I can describe my work that way...).

Two caveats.

First, to do this we had to weaken the encryption properties slightly - there will be a temporary, unencrypted file in $TMPDIR, which gets cleaned up when the VM turns off. This is a slight weakening of the security model in that now the user can peek at their data (whereas before, only 'root' could); but we felt that this weakened mode was better than leaving such VMs completely unusable.

Second, there still are some performance issues with MacOS 10.14.6 regardless of encrypted VMs, particularly related to heavy graphics usage. They are much more recoverable - wait tends of seconds and the VM will be usable again - but we still aren't happy with overall behavior. (And the "set memory to 2GB" workaround still applies). We're actively looking into other options, but I expect we won't have any better options in less than several weeks. All the remaining ideas are invasive enough to need much more testing.

Zongmin
VMware Employee
VMware Employee

Hi all,

Fusion 11.1.1 is just pushed live. We have a mitigation fix for the VM performance issue on macOS 10.14.6 with this release.

Root cause for the VM performance issue, is “the behavior of paging memory from an unlinked file.” Check KSC’s updates in community if you want to understand the technical details. And this one have further details: https://communities.vmware.com/message/2877617#2877617

Per our internal testing, the performance issue has been greatly improved. If you experienced performance issue with macOS 10.14.6, pls upgrade to this build and let us know if it works for you.

Thank you for your patience! We appreciate all of you working together with us to understand the root cause and figuring out the solution!

VMware Fusion Team

pauljacobevans
Contributor
Contributor

I'm rebuilding my encrypted (TPM) VM Win10 with 8GB RAM and I'm not seeing any issues right now... Look forward to a long-term solution as per ksc's comment, but for now it seems like I'll finally be able to build our website to do some dev work for now.

Thanks again

0 Kudos
Sven1802
Enthusiast
Enthusiast

Hi,

working well for me.

Thanks a lot for all your help !!

0 Kudos