office100
Enthusiast
Enthusiast

VM Fusion 10.1.0 Update no USB funktion

after Update VM Fusion to 10.1.0 USB is not working anymore

try USB 3.0 an USB 2.0 and reinstall VM ware tools.

Mac OS High Sierra Vm Fusion WIn 7 64  Win 10 64 bit .

rollbac to VM Fusion 10.0.1 USB work fine again.

14 Replies
office100
Enthusiast
Enthusiast

Problem solved again in 10.1.0 version

I dragged the Fusion app out  to the trash, then used Put Back to restore it.

Then launch Fusion, open Preferences > Security & Privacy > General and there should be a message at the bottom with an "allow" button

VMware, INC. Click that.

Now my VMs show all connected USB devices

ThePimento
Enthusiast
Enthusiast

You just ran the updater file again?

0 Kudos
office100
Enthusiast
Enthusiast

no, only delete the app a back an kopie it back

0 Kudos
misterrobot
Contributor
Contributor

I have the same message in System Preferences under Security & Privacy:  "System software from developer 'VMware, Inc.' was blocked from loading."

There is a button labeled "Allow", but no matter how many times I click it, it appears to do nothing.  I have rebooted and the message in System Preferences still appears.  Clicking the button has no effect.

I have also tried deleting the Fusion application, downloading the current rev (10.1.0) and the behavior is the same.  I'm assuming that VMware's kernel extensions that govern USB behavior are being prohibited from loading under High Sierra and this problem must be fixed before USB devices will work under Fusion.

Thoughts?

0 Kudos
office100
Enthusiast
Enthusiast

enabel the fusion app in the firewall an then allow in the security

0 Kudos
misterrobot
Contributor
Contributor

Thank you for your suggestion.  However, it did not help.

Enabling the Fusion application under the firewall in System Preferences has no effect on the issue.  All clicks on the "Allow" button are ignored and USB devices fail to connect to any VM.

0 Kudos
jmv2
Contributor
Contributor

I have the exact same problem for VM Fusion 10.1.0

Rolled back to 10.0.1, same issue Smiley Sad

0 Kudos
jmv2
Contributor
Contributor

Is there a way to go back to VM Fusion 8 once a VM has ben upgraded to 10 ?

I am getting desperate to get this USB recognised by 10. Smiley Sad

0 Kudos
office100
Enthusiast
Enthusiast

never testet to go back to Version 8 but I go back to 10.0.1 by delete  10.1.0 an install the older 10.0.1

I found this

There is a button labeled "Allow", but no matter how many times I click it, it appears to do nothing.  I have rebooted and the message in System Preferences still appears.  Clicking the button has no effect

in my Security Window there is a small Lock  sign in the  lower left corner that blocks all adjustments.

0 Kudos
jmv2
Contributor
Contributor

Office10, does your 10.0.1 install work ? Does it see your USB drive ?

Did the same as you but no luck for me (deleted 10.1.0 and installed 10.0.1)

What special thing did you have to do to make it see USB ?

Thanks

0 Kudos
office100
Enthusiast
Enthusiast

I got this issue also in der older 10.0.1 and this help.

after Update to 10.1.0 get the same issue.

Use Mac OS High Sierra 10.13.2

Additional I allowed the VM Fusion app in the Firewall but I`ll delete it now again.

Stop VM Fusion 10.1.0

I dragged the Fusion app out  to the trash, then used put back to restore it.

Then launch Fusion, and close again.

open Preferences > Security & Privacy > General and there should be a message at the bottom with an "allow" button VMware, INC.

I unlocked the pane (padlock left lower corner) and clicked allow.

Now my VMs show all connected USB devices.

0 Kudos
misterrobot
Contributor
Contributor

I spent some quality time with VMware support yesterday and during the session we tried multiple permutations of dragging the application to the trash then restoring it, deleting the application then reinstalling it, rebooting, deleting various files in /Library and ~/Library but on my system, nothing worked except disabling SIP. 

I was advised that if I want USB connectivity in my VMs, I must disable SIP until there is an update to Fusion which solves this problem.

This appears to be the solution for only a subset of environments that encounter this problem.  Apparently those other fixes work on many/most other systems.  Just my luck, I guess.

0 Kudos
jmv2
Contributor
Contributor

To all parties interested.

I have resolved the USB issue with assistance from technical support over email.

The main reason why USB was not recognised is because "vmware-usbArbitrator" service was not running.

With VMWare Fusion running (but not the VM) : check in Activity Monitor for process vmware-usbArbitrator .

If the task is not there, then that is the cause of the problem.

To resolve I followed these steps:

1. Manually uninstall Fusion. The link for the steps are - https://kb.vmware.com/s/article/1017838

2. Enable root account in MacOS. Link to enable root account in Mac - https://support.apple.com/en-us/HT204012

3. Download VMware Fusion again and install using root login account.

Also, click on Security and Privacy and under General tab check for any message to click on “Allow or Open” for VMware Fusion and check for USB devices.

JM

jsollender
Contributor
Contributor

Same problem here. I only had option to allow the fusion one time in security and privacy. My firewall is off in security (running little snitch). I could Never see USB devices. I shut down and restarted fusion multiple times. I could not downgrade from hardware 14 to any lower level. Somehow, on the 10th or 15th reboot of the win7 pro, the USBs were all recognized without having to change any settings. Just like that. Also, my network adapter had also stopped working with yellow exclamation point. When the USBs came back, so did network connection. May be as simple as multiple boots of VM to get it to work. I had also moved VM to trash and put back twice. That did not seem to make any difference. Maybe try rebooting several times as another option if above tricks fail you.

0 Kudos