VMware Communities
Bobk81
Contributor
Contributor

Unable to Extend Displays

I have now tried with both Fusion Pro 10 and 11, I cannot get my Guest Windows 10 system to extend displays or detect my additional monitor. The touch bar on the Mac shows Extend and mirror when I have another screen connected and on the Mac (host) side this works as required. However in Fusion, it doesn't work, I have all the VMware tools installed, I have even done a clean install of Windows 10 and no difference I have tried to use all displays in Full screen and single view, with no luck, it just keeps mirroring the Windows 10 (guest) on each screen. Please advise what else I can try to get it to detect my additional monitor.

Thanks

Reply
0 Kudos
19 Replies
RickShu
VMware Employee
VMware Employee

Hi Bobk81,

Have you tried it when 3D acceleration is off?

Also, it would be helpful if you can attach the vmware.log to this thread.

Regards,

-Rick

Reply
0 Kudos
Bobk81
Contributor
Contributor

Okay, So I turned off 3D and that does do something. If I press detect in display settings nothing happens, but If I press Windows Key and P then I can select extend, this does thne show two displays under the display settings, however, the second display stays black, I can just see the mouse course I can not drag anything to this screen and when clicking on identify, it only pops up on the primary screen, not the secondary. I cant seem to find vmware.log file, whereabouts would it be saved

Reply
0 Kudos
RickShu
VMware Employee
VMware Employee

Hi Bobk81,

You can find the vmware.log by following the steps in this KB article: VMware Knowledge Base

Regards,

-Rick

Reply
0 Kudos
Bobk81
Contributor
Contributor

I have attached all the log files.

Let me know if there is anything else you require

Thanks

Reply
0 Kudos
RickShu
VMware Employee
VMware Employee

Hi Bobk81,

Did you have the option 'Mirror Displays' checked in System Preferences==>Displays==>Arrangement in your Mac host? If yes, then it is expected behavior.

To use the Extend Display in guest, this option must be unchecked.

Regards,

-Rick

Reply
0 Kudos
Bobk81
Contributor
Contributor

HI Rickshu,

No Mirrored displays are not ticked, just to make sure I did turn it on and off, reboot both the Host and the guest, still the same problem.

Thanks

Reply
0 Kudos
RickShu
VMware Employee
VMware Employee

Hi Bobk81,

Would you please add the following options into the vmx file and give it a try again?

svga.autodetect="FALSE"

svga.numDisplays="4"

Please power off the VM before you edit the vmx file.

Regards,

-Rick

Reply
0 Kudos
Bobk81
Contributor
Contributor

Any other options that I can try?

Reply
0 Kudos
Bobk81
Contributor
Contributor

Apologies, I didn't see this post about adding

svga.autodetect="FALSE"

svga.numDisplays="4"

I turned off the VM, added it to the end on my file, save and then turn the VM back on, but still no change, the same issue.

Regards

Reply
0 Kudos
banackmatt
VMware Employee
VMware Employee

Hi Bobk81,

To use the second monitor, you should set the view setting View > "Use All Displays in Full Screen".  This is the same as the VMX config option:

gui.fullScreenOnAllHostDisplays="TRUE"

Make sure your Fusion preference Display > Full Screen is set to "Resize the virtual machine to fit the screen", and toggle full screen.

If that still doesn't work, you can also try specifying these four config options together to override the monitor autodetect settings.  (But it sounds like you already did, and it didn't help)

svga.autodetect="FALSE"

svga.numDisplays="4"

svga.maxWidth="3840"

svga.maxHeight="2160"

You can also try setting your screen resolutions manually, by setting the Full Screen preference to "Center the virtual machine in the screen", and Single Window preference to "Stretch the virtual machine in the window".  Then use the VMwareResolutionSet.exe binary installed with Tools.  With these settings, your guest topology should not change when you toggle between single window and full screen mode.  If you can set the modes, then you can see their layout in the single window.

"C:\Program Files\VMware\VMware Tools\VMwareResolutionSet.exe" 0 2 32 , 0 0 1920 1080 , 1920 0 1920 1080

"C:\Program Files\VMware\VMware Tools\VMwareResolutionSet.exe" 0 2 32 , 0 0 1280 1024 , 1280 0 1920 1080

Meaning respectively, "set a topology of 1920x1080+0+0, 1920x1080+1920+0", and "set a topology of 1280x1024+0+0, 1920x1080+1280+0".

Matt

Reply
0 Kudos
Bobk81
Contributor
Contributor

Matt

You are awesome, I ran this command C:\Program Files\VMware\VMware Tools\VMwareResolutionSet.exe" 0 2 32 , 0 0 1920 1080 , 1920 0 1920 1080

And now I have it running on two screens, not to see how great you are, the Built-in Mac display is showing me a duplication of both screens running on it. So just to be clear, I have two external monitors and its showing correctly on them now, the built mac laptop display is showing the two the external display side by side.

Let me know

Reply
0 Kudos
banackmatt
VMware Employee
VMware Employee

Hi Bobk81,

It sounds like you have three physical displays (Mac laptop builtin + 2 external displays).  So if you toggle to fullscreen with only two displays in the guest, we will put the full guest topology on one host display (both guest screen side by side, like you are describing).  Which display that is depends on your host topology.

If you tell me your host display topology (monitor resolutions and relative position), I can give you a better VMwareResolutionSet commandline to run.  Otherwise, the Display > Full Screen setting "Resize the virtual machine to fit the screen" is supposed to do this work automatically Smiley Happy

ie for three 1920x1080 displays in a horizontal layout,

"C:\Program Files\VMware\VMware Tools\VMwareResolutionSet.exe" 0 3 32 , 0 0 1920 1080 , 1920 0 1920 1080 , 3840 0 1920 1080

If you are trying to do something more complicated (like fullscreen the VM to two host displays, but leave one display without a VM display?), we might have to talk more about your use case.  You can also try using Unity to position guest apps on certain monitors, without displaying the full guest desktop.

Matt

Reply
0 Kudos
Bobk81
Contributor
Contributor

Okay, I tried this one, C:\Program Files\VMware\VMware Tools\VMwareResolutionSet.exe" 0 3 32 , 0 0 1920 1080 , 1920 0 1920 1080 , 3840 0 1920 1080 but it stays the same, with my two external monitors displaying in extended view, but the built-in mac display showing a mirroring of what happening on the two extended monitors.

So I require two setup's one for work and one at home

The work one I would prefer the built-in Mac display to be the primary monitor and this can run at 1920 X 1080, as the scaling with Retina is still just too small. Then I have two externally attached monitors that can both run at 1920 x 1080 so that the Build in Mac Display with 2 external monitors, give me a total of 3 display to extend on to.

Setup two is at home, where it will be the build in the display can also run at 1920 x 1080 and one external monitor running at 1920 x 1080.

Thank for the help so far, I am at least getting somewhere now.

I have attached a screenshot of my display setting in Fusion, with what you suggested, but it does not work as its duplicating on the build in Mac display still

Regards

Bob

Reply
0 Kudos
banackmatt
VMware Employee
VMware Employee

Hi Bobk81,

Just to make sure what settings are getting loaded, can you attach a vmware.log from the 3-monitor case?  It might also be helpful to see your vmware-vmfusion.log at "/Users/x/Library/Logs/VMware Fusion/vmware-vmfusion.log".  While you are getting things working, I would recommend setting the "Single Window" setting on the VM, rather than using the Fusion global preferences.  (Or else use the global preferences for both settings).

If your Full Screen setting is "Resize the VM", then simply enter full screen mode and we should use all 3 monitors.  In this case (if it works) you don't need any VMwareResolutionSet command.

If your Full Screen setting is "Center the VM", then enter fullscreen mode and run the VMwareResolutionSet commandline for 3 monitors.  (It sounds like you tried that and ended up with 2 monitors)

If your 2-monitor setup at home is still having problems, please also upload a vmware.log from that, and label them differently like -2monitor or -3monitor.

Matt

Reply
0 Kudos
Bobk81
Contributor
Contributor

Hi Matt

I got the Home setup to work by just running this VMwareResolutionSet.exe 0 2 32 , 0 0 1920 1080 , 1920 0 1920 1080, I attached the log, just in case you wanted to have a look.

I'll try the 2 external and one internal again next week as I am currently out of the office. but the setting are like in that last screenshot, in the previous post set to Resize to fit. I'll try and play around with these, possibly going to try 0 3 32 , 0 0 1920 1080 , 1920 0 1920 1080, 1920 0 1920 1080.

Will let you know next week if it doesn't work I'll send you a new log.

Thanks

Bob

Reply
0 Kudos
banackmatt
VMware Employee
VMware Employee

That ResSet line for 3 screens should be something like "0 3 32 , 0 0 1920 1080 , 1920 0 1920 1080, 3840 0 1920 1080" (three horizontal monitors) or "0 3 32 , 0 0 1920 1080 , 1920 0 1920 1080, 0 1080 1920 1080" (two horizontal monitors, and one below them).

Reply
0 Kudos
Bobk81
Contributor
Contributor

Okay so no luck with any of those commands, it extends across the two external monitors but shows a side by side of the two on the laptop monitor, I have attached the log file, the two external are to the left of the laptop monitor.

Let me know if you have another option for me.

Thanks

Bob

Reply
0 Kudos
Bobk81
Contributor
Contributor

I got it to work finally.

Thought, let's go back to the defaults, and I re-enabled the 3D Acceleration, started it all up and it worked, really not sure why it didn't want to work originally with the setting, but all is sorted now.

Thanks

Reply
0 Kudos
amende94
Contributor
Contributor

Can this also be applied to fusion 12? It's ridiculous how in F12 there's not a reset back to defaults, and the issue is still current.

Reply
0 Kudos