DanieleGregori
Contributor
Contributor

USB problem after upgrading to Fusion 11 and Mojave

Hi everyone,

after upgrading my mac from High Sierra to Mojave i updated Vmware Fusion 10 to 11 version

Now from guest machine (Windows 10 Enterprise lateest version) i cannot see any USB storage devices

Input usb device keyobard an mouse works

Usb Devices are correctly recognized by Mac host

I already tried to remove and re-add USB Controlelr to guest machine, update vmware tools and upgrade hardware version for guest machine from 11 to 14 (I need compatibility to Fusion 10)

Any suggestions?

Thanks

Daniele

7 Replies
RickShu
VMware Employee
VMware Employee

Hi DanieleGregori,

Have you already tried the solution from this thread: NO USB

Hope it helps.

Regards,

-Rick

meritMDW
Contributor
Contributor

I have the same problem but have already ensured that VMWare Fusion is under the Security & Privacy  - Privacy pane and has been checked to "Allow the apps below to control your computer".

Still do not have ability to access USB devices in the virtual machine (Specifically a Nuance Power Mike 2 microphone).

Running: Late 2015 iMac, Mac OS Mojave 10.14, VMware Fusion Professional Version 11.0.0 (10120384) - USB devices not able to connect to VMs.

Mark W

DanieleGregori
Contributor
Contributor

I SOLVED my problem

I removed Fusion App from application and then re-installed it

With no reasons for me, now i can conect USB Devices to VMs

In previous installation i applied the "Allow" button on System Preferences > Security & Privacy > General, with no effect

Thanks for your help

Daniele

0 Kudos
roeybh
Contributor
Contributor

Hi,

Same issue. VMware Fusion Pro 11. OSx Mojave. Linux 16.04 guest. USB is not detected!! It is owned by the host machine.

Roey

0 Kudos
Bill27VA
Contributor
Contributor

The previous "fix" works:  I just upgraded to iMac OS 10.14.1 and then (against better judgement, "upgraded" to Fusion 11.0.1.  My USB headache returned till I remembered this link.  The fix is all in the OS 10 System Preferences, Security & Privacy:  open, unlock it under OS 10 and do what you have to: uncheck VM Fusion in the Full Disk Access.  I had to shut down the running Fusion and quit VM Fusion all together to "uncheck the box."  Security & Privacy, still open and unlocked, I put a check BACK in the Full Disk Access (maybe Accessibility, too) box, fired up the closed VM Fusion and once running, before opening my Windows program, looked at the Virtual Machine tab and my printer + scanner now showed in the USB tab!  Your mileage may vary, but getting Fusion OUT and then Back IN from a fresh Fusion start-up were the key....all the while keeping the Security & Privacy "unlocked" to allow changes. 

roeybh
Contributor
Contributor

Thank You!!! Bill27BA

This solved the issue

0 Kudos
Steve_Graybill
Contributor
Contributor

Thanks Bill27VA, USB problem solved.  Allowing full disk access solved the problem for me.  My USB now shows up on the Virtual Machine USB & Bluetooth tab and connects.

0 Kudos