Highlighted
Contributor
Contributor

USB device not detected in Fusion 11.5.6

Jump to solution

I spent now nearly the whole morning in trying to make a USB3 device appear in my Linux Guest OS.

Mac OSX 10.15.5, Linux Guest: Ubuntu 18.04.5 LTS.

Setup is: MBP 2018->usb-C->USB-hub or dock->Magewell USB Capture device

I see that the device is recognized by the MAC, but not offered to connect to the guest system (see attachment for screenshot):

pastedImage_0.png

I tried a lot from other threads (trying to grant full file access, reinstall fusion, reboot mac, do woodoo with the security and privacy settings ...) but of no help.

Inserting a USB pen drive or external hard drive works. Also my phone connects and is offered, however the mice that I have connected are not.

Downgrading to 11.5.3 did not help either.

Thanks!

Jochen

Message was edited by: Jochen Rau, tried to make pasted image appear and add information that downgrading did not help. Attached image to try to make it available.

Message was edited by: Jochen Rau added OSX and guest OS version

1 Solution

Accepted Solutions
Highlighted
VMware Employee
VMware Employee

Hi ipsgen,

Would you please try with the following steps and see if it helps?

1) Quit VMWare Fusion

2) Add the following entries to "/Library/Preferences/VMware Fusion/config".  (If the file does not exist, create it with 'sudo vi /Library/Preferences/VMware Fusion/config')

usb.generic.allowHID = "TRUE"

vusbcamera.passthrough = "TRUE"

3) Open VMWare Fusion and launch your VM to give it a try.

Regards,

-Rick

View solution in original post

0 Kudos
11 Replies
Highlighted
Contributor
Contributor

just as a follow up, downgrading did not resolve the issue. I still cannot forward the device to the Guest.

0 Kudos
Highlighted
User Moderator
User Moderator

Hi,

What version of operating system do you have on Mac?

What distribution and version do you have on the linux guest?

ARomeo

Blog: https://www.aleadmin.it/
0 Kudos
Highlighted
Contributor
Contributor

Having the same issue here with a usb joystick - works fine in OS X but does not get offered up to the guest OS as a USB device.  I have a support case open and will post back here if I get anywhere but I'm following your progress as well.

Highlighted
Contributor
Contributor

Hi!

OSX 10.15.5, Ubuntu 18.04.5 LTS. Even though the latter should not be relevant as Fusion does not display the USB in the dialog as I tried to depict in the screenshot.

Thanks!

Jochen

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi ,

It would be helpful if you can collect a Fusion Support Bundle from "Help > Collect Support Information". It would be good to enable USB Verbose logging before reproducing the issue. You can do that from "Virtual Machine > Settings > Advanced > Enabled Verbose USB Debugging".

The support bundle is large so it would probably be best to upload it to VMware's FTP. Check out the "Uploading through the FTP portal using your web browser" section in VMware Knowledge Base . You can name the directory in FTP, say, community+yourID.

Regards,

-Rick

0 Kudos
Highlighted
Contributor
Contributor

Hi RickShu​,

I enabled USB verbose logging and prepared an Support Bundle and placed it in community_ipsgen directory.

I hope you can take a look! Let me know if you need more/other information.

Thanks!

Kind regards,

Jochen

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi ,

Thanks for providing the support bundle, the development team will take a look at it.

Regards,

-Rick

0 Kudos
Highlighted
VMware Employee
VMware Employee

Hi ipsgen,

Would you please try with the following steps and see if it helps?

1) Quit VMWare Fusion

2) Add the following entries to "/Library/Preferences/VMware Fusion/config".  (If the file does not exist, create it with 'sudo vi /Library/Preferences/VMware Fusion/config')

usb.generic.allowHID = "TRUE"

vusbcamera.passthrough = "TRUE"

3) Open VMWare Fusion and launch your VM to give it a try.

Regards,

-Rick

View solution in original post

0 Kudos
Highlighted
Contributor
Contributor

Hi!

That worked out, now I can connect and use it.

Thanks a lot for your help!

May I suggest a change in the USB dialog to increase ease of use: Make it visible that there are additional USB devices and give advice what needs to be done if this device should be connected to the VM. E.g. a list with USB devices that are not available yet, and if you click on one, you get information that you need to adjust the config file.

Anyway, thanks a lot for your help!

Kind regards,

Jochen

0 Kudos
Highlighted
Enthusiast
Enthusiast

This did not work in my case. I can't connect any USB devices in Windows 10, jump drive, USB connected devices are not accessible. Works great on 11.5.3. Any release after that does not work.

0 Kudos
Highlighted
Enthusiast
Enthusiast

This did not work for me. Still broke.

0 Kudos