Piggy
Enthusiast
Enthusiast

ThinPrint Broken

Haven't been able to print from Windows XP Pro to the Mac OS printer side since upgrading to Snow Leopard. Toggling Printer Sharing in Fusion didn't update the list of printers which contained two Mac OS printers. I tried deleting manually, removing Tools and re-installing Tools. Still can't print to the Mac side as toggling Printer Sharing in Fusion still doesn't update the printer list.

Is this a known problem? I did not find any current postings regarding it.

0 Kudos
9 Replies
WoodyZ
Immortal
Immortal

I couldn't get it working under Snow Leopard and I uninstalled/reinstalled VMware Tools and Fusion several times and that coupled with the other issues I've removed Fusion from Snow Leopard and went back to Parallels and the latest 4.0 released last week has been working in every way that Fusion wasn't.

0 Kudos
Mikero
Community Manager
Community Manager

Hi there,

Snow Leopard replaces the entire /etc/cups directory, which removes the configuration files that point to the ThinPrint filter driver.

It would also affect some 'Print to PDF' functionality (specifically, ones which rely on CUPS)

This is a known issue with 10.6, and we're tracking it internally as PR: 464356

-
Michael Roy - PM/PMM: Fusion & Workstation
0 Kudos
Piggy
Enthusiast
Enthusiast

Thanks for the explanation Mikero.

I am sorry to report that I have switched to Parallels. I am and plan to remain a Fusion customer but I have reached my limit. I have migrated all of my Windows VMs over to Parallels and while the GUI isn't as polished as Fusion, every single problem I had in Fusion including but not limited to broken SL printing, SL loss of focus when switching VMs and general performance problems that have persisted for a year are all gone. Parallels also adds a "pause" feature that I have repeatedly requested in Fusion and the ability to check for updates whenever I want (Fusion seems to have a built in feature to check weekly or something like that). I have Parallels set to check daily since SL support is only "experimental" for them as well. The performance with Outlook is better and extremely noticeable with IE. I recently built a fresh Windows XP VM, so I don't think the migration fixed some deep rooted issue.

I suggest VMware look long and hard at Tools which I think is related to the performance problems that people experience. One of my complaints about VMware is too few, and too long a period, between product updates to address issues. I don't care whose fault it is and have no doubt VMware is sometimes blindsided by Apple. Update your software and get it out to customers quickly (days not months). Be forthcoming and maintain a list of known and suspected problems so customers can be aware of the pitfalls of updating Mac OS before Fusion has been updated. FWIW, you don't do any better with your technology previews. In fact worse, because there really is no excuse for not releasing updates every week or two for betas.

Thanks again for your message and all the hard working technical employees. Show this email to executive management...

0 Kudos
kendtd71
Contributor
Contributor

Hi

I just experienced the same problem.

However, I did find a workaround that might help you. I put in more detail

than might be necessary so as to help someone not familiar with networked

printers.

My Environment

-


-

I have 3 network printers. 2 x HP2100TNs and 1 x HP L7500 all in one.

The printers are connected via ethernet connections to my router. I do this

via a small Netgear switch. Each printer and my 2 IMACs connect to the

switch with standard ethernet cables. Then one cable connects the switch to

my router.

The Symptom of the problem

-


-

After upgrading to OS X 10.6 (Snow Leopard) when I used Fusion (2.0.5) and tried to

print from my virtual XP machine I got reams of gibberish. Looked like it was

trying to print the actual printer raw codes.

In addition, each time I started up the Virtual Machine, my printers were being

duplicated. The duplicated printers had (#2, #3, etc) appended to the end of their

names.

The Solution/Workaround

-


-

You have to do 2 things.

1) Shut down your virtual machine and change the Virtual Machine Printer settings

by UN-CHECKING the "Enabled" check box. This shuts off the automatic addition

of your MAC printers to the Virtual Machine. The reason for this might be due to

the fact that the the "/etc/CUPS/" directory no longer exists under OS X 10.6 as it

did on 10.5. (That was noted by one of the previous responders to this thread)

2) You need to install each of your printers on your Virtual Machine in the standard XP way.

(like you were on a real XP machine) Because I am using networked printers,

this step requires IP addresses for your printers that will not change. (Either Static or DHCP Reserved addresses)

I like the DHCP reservation method which is described below:

-- Reserve an IP address for each printer in the router's DHCP section.

-- Ensure that the printer is DHCP enabled and can accept

IP addresses assigned from the router's DHCP server. For this

you need to look at the printer itself - print out a configuration page.

Using Control Panel, DELETE ALL existing printers and then ADD each one back.

Use HP TCP/IP Printer ports (Not the Fusion ThinPorts) to connect the XP "Printer"

to the IP of the printer on the network. You may need to create new ports to do this.

(Standard TCP/IP ports will also work if your version of XP does not have HP Printer Ports.)

XP has most of the drivers built in so there was no need for a special disk for my printers.

I hope this helps.

KJH

0 Kudos
moisetsjombe
Contributor
Contributor

Hello

You mentioned a problem with the Thin Print Filter driver that is a known issue.

"This is a known issue with 10.6, and we're tracking it internally as PR: 464356"

Does this issue have a solution?

I tried about everything short of reinstalling Fusion.

The printer keeps spitting out dozens of pages with gibberish.

The workaround suggested by KJH in 'ThiPrint Boken" is too complicated and prone to new problems.

Kind regards.

Jo Van Rafelghem

0 Kudos
Mikero
Community Manager
Community Manager

The solution is to simply re-install Fusion (this does not affect your VM's)

10.6 makes changes to how /etc/cups behaves (specifically removes some necessary files), and as such a re-instal of Fusion replaces that folder (or rather adds to it) with the files which we depend on for ThinPrint.

-
Michael Roy - PM/PMM: Fusion & Workstation
0 Kudos
moisetsjombe
Contributor
Contributor

Hi

Thanks for the fast answer!

I installed the Brother drivers from Apple and reinstalled VMWare Fusion 2.0.5.

Printer didn't respond at all when trying to print a page from acrobat reader.

When reviewing the printer settings, I got this error report (see attached file).

Finally the VM shut down without asking and after ten minutes the print finally came out correct.

So the printing is OK now but the delay is unacceptably long.

Can I do anything about that?

Kind regards.

Jo Van Rafelghem

0 Kudos
moisetsjombe
Contributor
Contributor

Hi

I solved the problem myself by reinstalling VMWare Tools on the VM.

I run two VMWare Fusion programs with XP Home on two separate Macs (and yes I have two licenses for each!) and the one on the MacBook Pro worked flawlessly after just reinstalling Fusion.

That put me on the wrong foot when the VM on the Mac Mini continued to have problems with printing and demonstrated a series of erratic disorders.

It took me a while to figure out that maybe, just maybe repairing VMWare Tools would change things.

It did.

I see version 2.0.6 is out.

So let's see what happens when I try this one out!

I' ll throw in a reinstall of VMWare Tools for good measure.

I 'll be back!

0 Kudos
gbintexas
Contributor
Contributor

It worked guys...

I had Fusion 2.0.5, I upgraded to Snow Leopard, and the printing from my image of Win XP would only print gibberish...

So, I Reinstalled VMWare Fusion 2.0.5... all is well now...

thanks for the lead...

0 Kudos