jsturtridge
Enthusiast
Enthusiast

Swapping Option/Command - or - Alt/Windows in Win10 Guest VM

Jump to solution

All,

So that I can keep my muscle memory when using Windows 10 in my guest VM, I'd like to be able to swap the Alt/Windows keys such that when I'm in the (full-screen) VM, when I press the Option-⌥ key on my Mac keyboard, it triggers the Window key in the VM; and when I press the Command-⌘ key on the keyboard it triggers the Alt key in Windows.

I've found an old post: https://communities.vmware.com/t5/VMware-Fusion-Discussions/tip-swap-option-and-command-keys-or-wind... which says that it should be possible to put "mks.keyboard.swapAlt=TRUE" into the config file.

I've tried this with Fusion Player Version 12.1.1 (17801503) running on Big Sur 11.2.3 (20D91) - but it doesn't seem to work. I've also tried putting in:

mks.keyboard.swapAlt = "TRUE"

but this doesn't work either.

Anybody know how I might achieve swapping the Alt and Windows keys in the VM?

Thanks in advance - Jonathan.

 

Tags (2)
1 Solution

Accepted Solutions
jsturtridge
Enthusiast
Enthusiast

Hey all - checking back in with a fix to my own issue.

Although the user interface isn't very intuitive - you should follow these steps.

  1. Start Fusion
  2. Go to Settings / Keyboard and Mouse
  3. Edit the keyboard profile you're using, e.g. "Windows 10 profile" by double-clicking on the entry in the left-hand panel
  4. Click "+" in the bottom of the next dialog to appear.
  5. Click the ⌘ button in the top row and then click the "Alt" button in the bottom row. Click OK.
  6. Click "+".
  7. Click "Option" in the top row and then click the Windows logo in the bottom row. Click OK.
  8. Close the open dialogs and head back to your VM - the two keys should be swapped!

Screenshot 2021-07-19 at 14.48.14.pngScreenshot 2021-07-19 at 14.48.01.pngScreenshot 2021-07-19 at 14.48.28.png

View solution in original post

0 Kudos
6 Replies
Chrysler1984
Contributor
Contributor

Parrallels Desktop has no issue swapping the two, though I really want VMware to support this as Fusion runs faster.

I have the same issue on Catalina. I added mapping (Cmd->Alt and Option->WIN) from Mac OS (host) to Windows 10 (guest) but seems no effective. 

I suspect this is because Fusion mapped the Cmd key to WIN key by default and thus overriding any user defined key mappings. As you can see in Setting->Keyboard & Mouse->Mac Host Shortcuts, under the option "For Windows key, use: " there are only 3 options, either both Cmd key, left or right. 

I think VMware really should fix this issue because if one compare the keyboard layout of a Mac and PC. The Cmd key position corresponds to the WIN key position, and the same for Option key to the Alt key position on PC.

By enabling the mapping of Cmd->Alt and Option->WIN, one can utilize all the shortcuts from Windows on a Mac keyboard.

0 Kudos
jsturtridge
Enthusiast
Enthusiast

Hey all - checking back in with a fix to my own issue.

Although the user interface isn't very intuitive - you should follow these steps.

  1. Start Fusion
  2. Go to Settings / Keyboard and Mouse
  3. Edit the keyboard profile you're using, e.g. "Windows 10 profile" by double-clicking on the entry in the left-hand panel
  4. Click "+" in the bottom of the next dialog to appear.
  5. Click the ⌘ button in the top row and then click the "Alt" button in the bottom row. Click OK.
  6. Click "+".
  7. Click "Option" in the top row and then click the Windows logo in the bottom row. Click OK.
  8. Close the open dialogs and head back to your VM - the two keys should be swapped!

Screenshot 2021-07-19 at 14.48.14.pngScreenshot 2021-07-19 at 14.48.01.pngScreenshot 2021-07-19 at 14.48.28.png

View solution in original post

0 Kudos
Chrysler1984
Contributor
Contributor

Thanks but it doesn't work. Did you actually test it on a mac keyboard?

That is exactly what I did in the first place but it has no effect. The Windows Key is still mapped to the Mac Command key no matter what mappings I added. Hence I said in my reply I suspect VMWare mapped Windows Key to Command key by default (under the tap Mac Host Shortcuts). 

0 Kudos
jsturtridge
Enthusiast
Enthusiast

Chrysler1984,

 

Hmm - that's baffling. Yes - I'm using a standard Mac keyboard (Apple Magic Keyboard with Numeric Keypad - British layout) via Bluetooth - and it works a charm - and on more than one machine, too, so I don't think that it's something that I've done to the configuration either. 

I do have one custom setting which I don't think affects the keyboard at all - as I want to pass through a USB web cam through to the VM - so perhaps you should add the following entries to "/Library/Preferences/VMware Fusion/config". (If the file does not exist, create it with 'sudo vi /Library/Preferences/VMware Fusion/config')

usb.generic.allowHID = "TRUE"
vusbcamera.passthrough = "TRUE"

 

And report back on how you get on.

Lastly, just to check - I've taken screenshots of all of my keyboard settings so you can compare. The critical ones I've highlighted in red.Screenshot 2021-07-24 at 23.18.13.pngScreenshot 2021-07-24 at 23.13.58.pngScreenshot 2021-07-24 at 23.13.52.pngScreenshot 2021-07-24 at 23.13.47.png

 

Hope that helps - Jonathan.

0 Kudos
Chrysler1984
Contributor
Contributor

Thanks I finally got it working following your setup!

Turns out in the profile I must select "Windows 10 Profile" to add the two mapping. Not sure why selecting other profiles doesn't work.

Great thanks mate! Now I can use all the PC excel shortcuts I am used to on my Mac.

0 Kudos
jsturtridge
Enthusiast
Enthusiast

You're very welcome - I'm glad it worked. It's so much easier for your muscle memory ... 🙂

0 Kudos