VMware Communities
Lacer
Enthusiast
Enthusiast
Jump to solution

Specify non-default Mac audio hardware as hardware for Windows VM

I have a 2.8 Ghz Core 2 Duo iMac running Leopard 10.5.4 running Fusion 2.0.1 (recently upgraded from 1.x). I have a Firewire audio interface (Focusrite Saffire) that I use as my main audio device for the Mac. Fusion uses this as the audio device that Windows plays through. I'd like to specify that Fusion use the iMac's internal audio device as the device Windows plays through. Is this possible? The VM settings only indicate that the default audio device as set in my System Preferences will be used by Fusion. Is there a setting in a .vmx file that can be set to override this? Thanks in advance.

Reply
0 Kudos
1 Solution

Accepted Solutions
Silica_V
Hot Shot
Hot Shot
Jump to solution

Fusion uses virtual hardware's, it will use all default Mac hardware's that are configured in Mac system. You can not assign any additional devices to the Virtual Machine.

Regards,

Silica V.

Regards, Vijaykumar B.

View solution in original post

Reply
0 Kudos
4 Replies
Silica_V
Hot Shot
Hot Shot
Jump to solution

Fusion uses virtual hardware's, it will use all default Mac hardware's that are configured in Mac system. You can not assign any additional devices to the Virtual Machine.

Regards,

Silica V.

Regards, Vijaykumar B.
Reply
0 Kudos
Lacer
Enthusiast
Enthusiast
Jump to solution

Thanks for the information. That would be a good option to give you the choice, in cases like this, instead of just blindly looking at defaults. Any reason that that couldn't be done?

Reply
0 Kudos
StuartPreston
Contributor
Contributor
Jump to solution

I have just upgraded from 1.1 to 2.0.2 today and found this behaviour myself. This is a change from v1.1. I have an external Firewire audio device and no matter what my selected audio device is, the sound is routed through the internal card.

I can see myself downgrading back to 1.1 very shortly...

Reply
0 Kudos
StuartPreston
Contributor
Contributor
Jump to solution

Actually I managed to work around this myself by editing the .vmx file for my VM in TextEdit.

Then I found the line:

sound.autodetect = "TRUE"

and changed it to

sound.autodetect = "FALSE"

Now my VM honours the output settings I choose in System Preferences > Sound

Reply
0 Kudos