VMware Communities
gryphel
Contributor
Contributor

Solaris appliances don't work in Fusion - one solution

The Solaris appliances described on

http://www.vmware.com/appliances/directory/420

would not work (at least "Solaris Express Developer Edition

2/07" and "Solaris 10 11/06") in VMWare Fusion 1.0 (51348)

Evaluation version. When it should show the graphical log

on screen, there is just a big white screen.

This might have been simple to fix if I knew anything about

Solaris, but I was trying the appliance because I don't.

Anyway, the clue to solving this was in

http://pubs.vmware.com/guestnotes/guestos_solaris10.html

under Known Issues, Display Too Small After Installation.

One must run kdmconfig, and choose Xsun.

The next problem was how to run kdmconfig. I found a

solution in

http://www.mattzone.com/solx86_single.html

which describes how to boot in single user mode. (Using

GRUB to add '-s' option)

After booting in single user mode, running kdmconfig to

choose Xsun, and rebooting, Solaris worked fine. I also

tried using kdmconfig to set 24 bit color instead of 8 bit

color, which also worked, and looks much better.

There are probably better solutions. Does anyone know

of one?

Reply
0 Kudos
1 Reply
Wes_W_
Enthusiast
Enthusiast

I can think of two probable solutions:

1) Run "sys-unconfig", as root, once you have logged in to revert the system to defaults, where you can specify the screen resolution and network settings.

2) Install a newer version of Solaris 10, Solaris Express Developer Edition (SXDE), or Solaris Express Community Edition (SXCE) from DVD yourself. The newer versions of SXDE or SXCE are much easier to install than even Solaris 10 was, and have a multitude of other improvements.

Reply
0 Kudos