VMware Communities
MikeFromABQ
Enthusiast
Enthusiast

Slow graphics with Fusion 11.5.3 macOS 10.15.4 MacBook Pro 2016

The machine has 8GB of RAM and half is dedicated to VMWare Fusion 11.5.3 and the RAM is PCIe which should be faster than regular SSD of the day.

The MBP 2016 15" came with macOS Mojave but now as latest Catalina 10.15.4

The guest is Windows 10 (1909) which is the same as on a desktop that doesn't exhibit any graphical anomalies using no VM.

Accelerate 3D Graphics is selected

256MB is the shared graphics limit

I do not specify "Use full resolution for Retina display".

Battery Life is set to "Use High Performance Graphics for 3D Applications Only"

The MacBook Pro is running on AC power.

In MS-Excel 2019, vertical scrolling a small spreadsheet is slow and jumpy.

When running apps I build, dragging the sliders to change contrast or brightness on a small JPG file (2MB) in the VM on the MBP, I see that the slider just jumps to the ending location as the image is updated all at once instead of incrementally, whereas on an old Windows desktop with no VM, the graphics are smooth.

Is this expected performance?  Are there changes to settings I could consider that would improve this?  Any other selections?

Reply
0 Kudos
5 Replies
MikeFromABQ
Enthusiast
Enthusiast

It also makes no difference if I choose Battery Life - Always Use High Performance Graphics

Reply
0 Kudos
ColoradoMarmot
Champion
Champion

Try reinstalling VMWare tools in the guest.

Reply
0 Kudos
johnnygood
Contributor
Contributor

Got exactly the same behavior 🤔

Reply
0 Kudos
ColoradoMarmot
Champion
Champion

The only other thought is to make sure you're running in windowed mode.  That machine is pretty lightweight on graphics capability, but should be ok.

Oh, and I do recall that older versions of excel had scrolling issues regardless of being in a VM.  Have you tried upgrading to the current rev?

Reply
0 Kudos
wila
Immortal
Immortal

Hi,

I don't have excel 2019, but in earlier versions of MS Excel there's an option under File -> Options -> Advanced -> Display

where you can turn off "Hardware graphics acceleration". By disabling the graphics acceleration in Excel itself, excel then tends to work faster and more smooth. (The irony is big on that one)

I'm also thinking that your 256MB of display RAM is very low for the current demands from VMware Fusion if you enable 3D.

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos