pepperbc
Contributor
Contributor

Screen Flickering in Fusion Player 12.0.0 w/ Full screen and 3D Graphics enabled

When in full screen with 3D graphics enabled, I get a pulse of the screen dimming/brightening about every second. Turning off 3D Graphics solves the problem, but my intended use uses 3D graphics so that doesn't really help me. The suggestion in a 2012 Knowledge Base article of turning Full Screen Minibar to "always on" also works, but I'd prefer not to have that always there.  (And it claims the underlying issue was fixed in 5.0)

On the latest Big Sur beta, and Fusion Player 12.0.0. This is a brand new VM with a brand new installation of Windows 10.

Similar issues:

Re: VMware Fusion 12 flicker problems on Mac Catalina 10.15.6

VMware Knowledge Base

Tags (1)
0 Kudos
19 Replies
RickShu
VMware Employee
VMware Employee

Hi ,

Would you please turn the 3D acceleration on and re-install the vmware Tools and see if it helps?

Regards,

-Rick

0 Kudos
scottyrotten
Contributor
Contributor

Also having the same issue. Although adjusting 3D acceleration is not fixing it for me.

I'm using an Ubuntu VM. 

I tried disabling 3D acceleration and re-installing open-vm-tools. 

0 Kudos
JerryHuang007
Contributor
Contributor

Hi, In the VMware Fusion menu bar, click View > Full Screen Minibar > Always Show fixed my issue, enable 3d and Retina doesn't matter.

 

toonvdd
Contributor
Contributor

I have the same problem even without 3D Graphics enabled. It only happens when using full screen mode on my second, hdmi connected, monitor. No issues when using the screen of my MacBook Pro. Started after upgrading to MacOS Big Sur.

dwilhelm99
Contributor
Contributor

I have Fusion 12.1 and I see this as well. The interesting thing is I didn't see it in 12.0, but I was running Catalina. When I upgraded to Big Sur I also upgraded to 12.1 and started seeing the flicker in full screen, so I think it happens only with Big Sur. I also tried turning off "Accelerate 3D Graphics" and it did not improve.

0 Kudos
toonvdd
Contributor
Contributor

It's definitely caused by the Big Sur upgrade. I also tried the Fusion 12.1 update, but still the same issue.

When I use VMware Horizon cliënt in full screen on my second display, I also have the same Issue. I don't have those issues with other applications in full screen mode.

0 Kudos
Raz0rEdge
Contributor
Contributor

This worked for me, while I didn't want the bar on the screen, it's a small price to pay for not having the constant flickering!

0 Kudos
cerdrifix
Contributor
Contributor

After upgrading to big sur I have now two main issues: the screen is flickering and vpn started on mac does not propagate to vm (in previous osx everything worked).

Please give it priority because I paid for this product and I want it working.

I wish I had gone with Parallels, which is fully operational

toonvdd
Contributor
Contributor

The VPN issue is a known issue:

toonvdd_0-1608212270524.png

Flickering issue is gone after enabling the "full screen minibar". Hope VMware fixes both issues soon. 

0 Kudos
Boondoggle
Contributor
Contributor

I am having this exact issue.  it also appears to be linked to mouse / cursor movements in the VM

0 Kudos
asaba1
Contributor
Contributor

Same. Problem started after upgrade to Big Sur.

  • External HDMI connected monitor
  • Full screen mode
  • VMware Fusion 12.1.0 Pro
  • No flickering if any native windows, like the VM settings or VMware preferences windows are open
0 Kudos
PS88
Contributor
Contributor

Same here

0 Kudos
powerdev
Contributor
Contributor

Same Here

0 Kudos
dsisola
Contributor
Contributor

Same issue

0 Kudos
tgvw
Contributor
Contributor

Same here. Turning off 3D or displaying sidebar does not help.

0 Kudos
mamet23
Contributor
Contributor

I tried this - does not resolve the issue. VMWare Fusion 12.1.1, Mac OS 11.3.
0 Kudos
mamet23
Contributor
Contributor

Having had the same flickering issue for several months now, I tried this, selecting the the Repair Installation option. Did not resolve the issue. VMWare Fusion 12.1.1, Mac OS 11.3. Any other suggestions? Thanks.

Tags (1)
0 Kudos
bayindirh
Contributor
Contributor

With VMWare 12.1.1 and macOS Big Sur 11.3.1, the issue is still present and prominent as before. The guest I'm running is Debian Stable with all updates applied and running open-vm-tools 11.2.5, which is the latest version available in the repositories as of today.

Also, there's a prominent UI lag while running the guest operating system. Sometimes, key presses are not reflected to the screen until another letter is typed into terminal (vim, bash, etc.). The flashes are also coming after UI updates, too. So, there's something with interrupt handling or display refreshing. IDK internals of VMWare, so it's just an educated guess.

0 Kudos
nzlamb
Contributor
Contributor

I have the same flickering issue with fullscreen VMs on the internal display. Permanently enabling the minibar fixes the flickering, but the minibar itself is annoying.

 

macOS 11.3.1

Fusion 12.1.2

0 Kudos