VMware Communities

Recovery partition interfering with increase C: size in Win10 VM

Fusion 8.5.3 on OSX 10.12.6, with a Win10 1709 VM.

I have a Win10 1709 VM that was sized at 32GB. I ran out of room and needed to increase it, so I shut down the VM, opened Fusion Settings for it, and increased the disk size from 32GB to 64GB.

However, upon re-starting Win10, the disk size wasn't changed.

Investigating why, I opened Disk Manager in Win10, and it shows four partitions: a 100MB "System Reserved", the 32GB C: drive, a 450MB Recovery Partition, and an unallocated 32GB partition, in that order. Thus, increasing the VM disk size gave me a new partition instead of increasing the size of the C: drive partition (which is what has happened with the Win7 VM's prior; I've had to do this several times in the past prior to Win10).

So, this may not be a Fusion thing, but I'm still stuck unable to increase the C:\ partition size. I don't see any way to move and/or delete the recovery partition. Can a Win10 boot partition really not be increased in size after initial install? That sounds … well, very Microsoftian, actually, but still pretty stupid, even for them. Hopefully I'm missing something obvious.

If anyone has any ideas, or there's a different way to do this, I would appreciate some pointers.


Tags (1)
1 Reply

Hate replying to my own question, but…

I continued to search around the web after I posted, and what I found indicated that, in fact, this couldn't be done while the VM was active, at least with Win10 disk manager. A bit later, I found this. I dl'd the first one and it did the trick — let me move the recovery partition to the end of the disk, and then increase the size of the C: since the free space was now adjacent. Just took a couple of minutes.

Not affiliated, not endorsing, etc., etc., but it worked for me. If there's a way to do this without third-party software, I'm still interested in hearing about it.