javier_C
Contributor
Contributor

Promiscuous mode on Fusion 11.5

Hi. Anyone know how to enable promiscuous mode on a network adapter on Fusion 11.5 (not Pro)?

I've used the product for quite a while, but right now I NEED to test some stuff with promiscuous mode.

I even entered this command

sudo touch “/Library/Preferences/VMware Fusion/promiscAuthorized”

But still can't find any optino to enable it.

Thanks!

0 Kudos
4 Replies
Leica
Enthusiast
Enthusiast

As far as I know it is enabled. If a VM starts promiscuous mode, then you will be notified and prompted to enter your password to authorize it.

This password prompting can be disabled in preferences under the Network tab.

0 Kudos
Mikero
Community Manager
Community Manager

Correct... if you do it through the guest, the host UI notifies and enables the feature. It has to be enabled on both the guest OS and in Fusion for it to function.

-
Michael Roy - PM/PMM: Fusion & Workstation
0 Kudos
wila
Leadership
Leadership

Michael,

It has to be enabled on both the guest OS and in Fusion for it to function.

The TS does not have VMware Fusion Professional though, only the non professional version.

So no network tab in the Fusion Preferences panel.

Not sure if you can do this without Professional. I don't have a non professional license here to try.

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos
Mikero
Community Manager
Community Manager

oh yah... I didn't mean to suggest more config was needed...

You literally just set it in the guest like you would on a physical adapter, and then click 'allow' when Fusion prompts.

That's what I meant by 'both sides'... you set it in the guest, and approve it on the host.

-
Michael Roy - PM/PMM: Fusion & Workstation
0 Kudos