maj1
Contributor
Contributor

Problems with Windows Fall Creators update

I am running VMware Fusion Pro 10.0.1 on a Macbook Pro (Retina, 13-inch, Early 2015).  I recently upgraded Fusion to 10.0.1 specifically to get support for the Windows Fall Creators update, version 1709.

My guest VM was working perfectly at version 1703.  After doing a normal Windows feature update, the VM started behaving disastrously, with signs of Windows Explorer crashing. It was so bad that I immediately reverted to a snapshot, which was fine.

Having got my VM functioning again, I made a linked clone and tried the update again on the clone. Curiously, the result was not quite as bad the second time, but still unusable - in particular the "Start" menu does not appear. Since this is a "throw away" clone, I tried a number of the "fixes" suggested by Google search, but none made any difference.

In desperation I then tried the "Reset Windows" option (i.e. the one that reinstalls a fresh Windows system, deleting all of the applications but preserving personal files). Even this did not work - the Start menu still does not appear.  Every time I click on the start button the following event appears in the event log:

Log Name:  Application
Source:    Application Error
Date:      2017-11-28 12:32:30
Event ID:  1000

Task Category: (100)

Level:     Error
Keywords:  Classic
User:      N/A
Computer:  sykes

Description:

Faulting application name: ShellExperienceHost.exe, version: 10.0.16299.15, time stamp: 0x59cda974

Faulting module name: Windows.UI.Xaml.dll, version: 10.0.16299.15, time stamp: 0xf6706fe0

Exception code: 0xc000027b

Fault offset: 0x00000000003fa23d

Faulting process ID: 0xe34

Faulting application start time: 0x01d36844f51cc8bd

Faulting application path: C:\Windows\SystemApps\ShellExperienceHost_cw5n1h2txyewy\ShellExperienceHost.exe

Faulting module path: C:\Windows\System32\Windows.UI.Xaml.dll

Report ID: 27f05b98-1303-40b9-a3f2-d47c6e897fb1

Faulting package full name: Microsoft.Windows.ShellExperienceHost_10.0.16299.15_neutral_neutral_cw5n1h2txyewy

Faulting package-relative application ID: App

Event Xml:

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

  <System>

<Provider Name="Application Error" />
<EventID Qualifiers="0">1000</EventID>
<Level>2</Level>
<Task>100</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2017-11-28T12:32:30.483205800Z" />
<EventRecordID>605</EventRecordID>
<Channel>Application</Channel>
<Computer>sykes</Computer>
<Security />

  </System>

  <EventData>

<Data>ShellExperienceHost.exe</Data>
<Data>10.0.16299.15</Data>
<Data>59cda974</Data>
<Data>Windows.UI.Xaml.dll</Data>
<Data>10.0.16299.15</Data>
<Data>f6706fe0</Data>
<Data>c000027b</Data>
<Data>00000000003fa23d</Data>
<Data>e34</Data>
<Data>01d36844f51cc8bd</Data>
<Data>C:\Windows\SystemApps\ShellExperienceHost_cw5n1h2txyewy\ShellExperienceHost.exe</Data>
<Data>C:\Windows\System32\Windows.UI.Xaml.dll</Data>
<Data>27f05b98-1303-40b9-a3f2-d47c6e897fb1</Data>
<Data>Microsoft.Windows.ShellExperienceHost_10.0.16299.15_neutral_neutral_cw5n1h2txyewy</Data>
<Data>App</Data>

  </EventData>

</Event>

Again there is a fair amount of lore about dealing with this error, and I've tried most of the "fixes" to no avail.  The Start menu still does not appear even if I start the system in "safe mode", though curiously, in this case I don't see anything in the event log.  There is some advice to try making a new account in case it is a corrupt profile, but unfortunately the "Settings" tool also crashes if I try. (Other advice is that this is a waste of time anyway).

I haven't had this trouble on any of the real machines that I've upgraded from 1703 to 1709. I don't think I'm doing anything particularly unusual on this VM; it just runs a few tools for me that aren't available natively on MacOS.

Any ideas?  For the time being I have deferred the upgrade on the main VM, but I assume that I will have to move forward eventually (in any case, I want to).  Obviously I can clone it again to do further experiments, but I'm not sure what to try next.  Any ideas?

0 Kudos
3 Replies
Mikero
Community Manager
Community Manager

The issues with 1709 are largely related to Tools.

Tools will be shipping an update very soon to address this very issue.

Our sincere apologies you've hit this, the fix is on the way.

-
Michael Roy - PM/PMM: Fusion & Workstation
maj1
Contributor
Contributor

Many thanks for the reassurance.  It's no problem for me to wait as long as Windows doesn't start getting aggressive about demanding the update.  I presume that at some point I will see a message that VMware Tools can be updated.

0 Kudos
sfjogger
Contributor
Contributor

Looks like there are memory issues as well as interaction with the shared drive - docs keep 'not responding' and disappear, only to reappear after some time has passed. I can't save anything to the shared drive, even if it was opened from there. You can save them to the desktop, then drag them back to the shared folder.

Hope you can get this fixed soon! I managed to do the upgrade without making a backup first, so am limping along until it's repaired.

0 Kudos