lmoglie
Enthusiast
Enthusiast

Problem with keyboard mapping after upgrade to Fusion 7

Jump to solution

Hi

I noticed that the keyboard layout has changed in the guest after upgrading to VMware Fusion from version 6 to version 7 even if nothing has changed in the "Region and Language" settings into guest Windows 7.  The keys that have changed are "\" with "<" and "|" with ">" everything else is OK. The keyboard is set to Italian :smileyconfused::smileyshocked:

Has anyone noticed the same problem ?

Have you fixed?

Thanks in advance.

0 Kudos
1 Solution

Accepted Solutions
lmoglie
Enthusiast
Enthusiast

The problem was solved by technical support of vmware with a workaround. They know the issue about keys are interchanged in the Virtual Machine after upgrading to Fusion 7.

Their development team currently working on this issue on priority. This will be fixed in the next update.

However, they have a workaround to fix the keyboard issue. Following the instructions below to map the key manually in VMware Fusion.

Note : Kindly make a note of the keys interchanged in Windows before enabling key mapping.

1. Click VMware Fusion -> Preferences -> Keyboard & Mouse -> Key Mappings

2. Ensure "Enable key mappings" option is enabled

3. Click on '+' sign at the bottom

4. Press the key which you want to send from the Mac keyboard in From text box

5. Press the key which you want to receive on the Virtual Machine in To text box

Note : You can also use the combination of Shift/Control/Option/Cmd if required.

View solution in original post

0 Kudos
6 Replies
admin
Immortal
Immortal

Hi lmoglie

Your host and your keyboard is English or French?  Could you clarify your issue?

0 Kudos
admin
Immortal
Immortal

BTW, could you please provide your env and Fusion information Such as your host is Mac 10.9.5 or later, Fusion 7 using GA build?

0 Kudos
lmoglie
Enthusiast
Enthusiast

Hi LeoWang18,

Host MacBook Pro 13-inch (mid 2009) , CPU 2,53 GHz Intel Core 2 Duo, RAM 8GB 1067 Mhz DDR3

Keyboard setting on the Host is Italian

Language setting on the host  is Italian (default) and English as secondary

Software  OS X 10.9.5 (13F34)

Fusion Pro 7.0.0 (2103067)

Guest OS Windows 7 Enterprise

Keyboard on the guest is Italian

Language of the OS is English

Regional and Language is Italian

If you need any other information feel free to ask.

Thanks

lmoglie

0 Kudos
lmoglie
Enthusiast
Enthusiast

Hi LeoWang18

more info,

I powered on an old machine and  I have the same issue with Guest OS Ubuntu

lorenzo@lif:~$ cat /proc/version

Linux version 2.6.35-32-generic (buildd@vernadsky) (gcc version 4.4.5 (Ubuntu/Linaro 4.4.4-14ubuntu5) ) #67-Ubuntu SMP Mon Mar 5 19:35:26 UTC 2012

lorenzo@lif:~$ lsb_release -a

No LSB modules are available.

Distributor ID: Ubuntu

Description: Ubuntu 10.10

Release: 10.10

Codename: maverick

Guest OS keyboard preferences is Italian

Guest OS Language & Text is English (United States)

With VMware tools not updated

I have the same issue with a Window XP

Keyboard on the guest is Italian

Language of the OS is English

Regional and Language is Italian

All VMs configured on FUSION are affected

0 Kudos
lmoglie
Enthusiast
Enthusiast

The problem was solved by technical support of vmware with a workaround. They know the issue about keys are interchanged in the Virtual Machine after upgrading to Fusion 7.

Their development team currently working on this issue on priority. This will be fixed in the next update.

However, they have a workaround to fix the keyboard issue. Following the instructions below to map the key manually in VMware Fusion.

Note : Kindly make a note of the keys interchanged in Windows before enabling key mapping.

1. Click VMware Fusion -> Preferences -> Keyboard & Mouse -> Key Mappings

2. Ensure "Enable key mappings" option is enabled

3. Click on '+' sign at the bottom

4. Press the key which you want to send from the Mac keyboard in From text box

5. Press the key which you want to receive on the Virtual Machine in To text box

Note : You can also use the combination of Shift/Control/Option/Cmd if required.

View solution in original post

0 Kudos
wila
Leadership
Leadership

Hello,

For your information, Fusion 7.0.1 was just released and the release notes mention a fix in this area.

VMware Fusion 7.0.1 Professional Release Notes

You can download it from Download VMware Fusion 7

Or you can use the update button under menu VMware Fusion -> Check for Updates

Hope this helps,

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
0 Kudos