VMware Communities
smslavin
Contributor
Contributor

Private network configuration?

Hi,

I've been struggling all day in trying to create a private network for some VMs. I have Fusion 3.1.2 with a 2008 Server R2 VM and a Win7 VM. I'd like these to be able to communicate on their own network. Both VMs have 2 network adapters. One is set as bridged with the host (OS X 10.6.7). The second NIC is set as the internal NIC with hardcoded addresses, 192.168.16.x, on a custom vnet.

I have manually tweaked the Fusion config files to add a vmnet2 network.

My networking file looks like this:

VERSION=1,0
answer VNET_1_DHCP yes
answer VNET_1_DHCP_CFG_HASH 291E2CFFBB4221F9C0576CF9ECEA1A1822FA1C08
answer VNET_1_HOSTONLY_NETMASK 255.255.255.0
answer VNET_1_HOSTONLY_SUBNET 172.16.79.0
answer VNET_1_VIRTUAL_ADAPTER yes
answer VNET_2_DHCP no
answer VNET_2_DHCP_CFG_HASH 96B6C065D06D8A80CD2CA019FDB995C3AD4948C0
answer VNET_2_HOSTONLY_NETMASK 255.255.255.0
answer VNET_2_HOSTONLY_SUBNET 192.168.16.0
answer VNET_2_VIRTUAL_ADAPTER yes
answer VNET_8_DHCP yes
answer VNET_8_DHCP_CFG_HASH 679F6B91ED697FD0B1BD2AFFD29BAEEDCE09334C
answer VNET_8_HOSTONLY_NETMASK 255.255.255.0
answer VNET_8_HOSTONLY_SUBNET 172.16.91.0
answer VNET_8_NAT yes
answer VNET_8_VIRTUAL_ADAPTER yes

In the .vmx files for both VMs, I have added the following:

ethernet1.present = "TRUE"

ethernet1.connectionType = "custom"

ethernet1.displayName = "Custom Host Only vmnet2"

ethernet1.virtualDev = "e1000"

ethernet1.wakeOnPcktRcv = "FALSE"

ethernet1.addressType = "generated"

ethernet1.vnet = "vmnet2"

ethernet1.bsdName = "vmnet2"

ethernet1.linkStatePropagation.enable = "FALSE"

Since vmnet2 is not using DHCP, I have hardcoded the address for both VMs. ipconfig shows both adapters with correct addresses. However, the machines do *not* communicate over vmnet2. I can ping the host at 192.168.16.1 from the guests but not the addresses given to the individual machines. The machines cannot ping each other. The host cannot ping the vmnet2 addresses either.
In the networking file, I tried setting VNET2_VIRTUAL_ADAPTER to no and that didn't make a difference either.
I need to get this working for a demo I have to give so any help would be much appreciated.
Thanks.

0 Kudos
2 Replies
WoodyZ
Immortal
Immortal

If you can ping Guest to Host but not Host to Guest then I'd be looking a Firewall settings and make sure that ICMP packets (echo requests) aren't being blocked.

smslavin
Contributor
Contributor

Doh! Thanks Woody. I turned off the Windows Firewall on both VMs and they are now talking freely. Can't believe I overlooked that.

0 Kudos