Contributor
Contributor

Persistent Window Size Possible?

Not the biggest issue but is it possible to have windows in the VM keep a persistent size? For example, if I switch from unity view to single window view and then back to unity view I lose my window size. Is there a way to keep window sizes persistent? I am running max os 10.5.1 and win xp.

0 Kudos
11 Replies
Immortal
Immortal

Just to clarify things as an example when my WinXP VM is windowed its resolution is 1024x768 and when I go from windowed to Unity to windowed it is still 1024x768 each and every time.

Are you saying it's not for you, in other words it this a random event or it's always something different each time?

Has it always been like this?

0 Kudos
Immortal
Immortal

When you use Unity mode, the guest sees a screen as large as your host screen (necessary so that you can move Unity windows around anywhere on that screen). However, when in Single Window mode, your guest probably doesn't want to be the same size as your host screen (or else you'll have to scroll around, and it'll get in the way of your other applications).

Can you point out a specific example (e.g. a particular application and what it does under these circumstances vs. what you want it to do) of something that's bothering you about the different window sizes?

0 Kudos
Immortal
Immortal

Is this only a problem for you with maximized windows?

0 Kudos
Contributor
Contributor

Thanks for your help. One example is when I am running Quicken. I start in Unity and expand my window size. Then I switch to single window view then I switch back to Unity and it does not remember my window size in Unity mode. I am not running in windows maximize mode. Again, not the biggest issue but it would be nice if Unity would remember windows sizes.

0 Kudos
Enthusiast
Enthusiast

When you resize your Quicken window its size is beyond the windowed VM resolution. When you exit Unity mode the Quicken screen is resized to fit the VM windowed mode. When you then switch back to Unity, it retains the size from windowed mode.

I think the solution here is is to give your VM a higher resolution so that you won't have to resize Quicken in Unity mode, but maybe there are other options as well?

0 Kudos
Contributor
Contributor

To give my VM a higher resolution is that just using the regular XP display settings in control panel or is there something special I have to do in VM Ware?

0 Kudos
Enthusiast
Enthusiast

That is one option. The other is to simply click and drag the corner of your VM like you would resize any other window. The resolution of your VM should be adjusted to match the window size.

0 Kudos
Contributor
Contributor

I tried to increase my resolution both ways and neither seemed to work. I do have VM ware SVGA II driver installed. Any other ideas to increase resolution?

0 Kudos
Enthusiast
Enthusiast

I am sorry if this is obvious, but

- Make sure the guest os in your vm is fully started up and logged in (ie, visible desktop with start menu etc)

then

- Right-click on the desktop, choose properties, choose settings tab - set resolution. The VM window should resize to reflect the new resolution

-or-

- Drag the bottom right corner to resize the window. Once you release the mouse button the desktop should resize to reflect the new window size

I'm sorry but that's all there is to it. If that doesn't work than I don't know what does.

0 Kudos
Immortal
Immortal

VMware SVGA II is the correct driver. You can actually force the guest to a specific resolution with two keys in the VM'x .vmx file, e.g.

svga.MaxWidth=1900

svga.MaxHeight=1200

You can set the resolution larger than your screen or what you can stretch a window to. The resolution can be overridden by full screen or hitting the maximize button which will reset the resolution. Another possible problem is you may have to adjust virtual video memory if you choose too large a resolution at a high bit-depth. Try experimenting with the above options first and if that doesn't work, I can help you with more options.

0 Kudos
Contributor
Contributor

The problem I'm running into with Unity is that maximized applications don't retain their "maximization" after I dock them. They end up shrinking back a smaller window size or whatever their default size is, then I have to re-maximize it to stretch across the screen. This does not happen in single user mode or full screen.

My workaround is to stretch the application window to the full size of the screen manually, and then after I minimize it to the dock and then open it back up, it looks maximized, although technically it's not (I actually stretched it to look maximized).

I tried increasing the res in the Windows XP session to match the Mac's: 1440x900, but it does the same thing.

Thanks for any help.

0 Kudos