Contributor
Contributor

Operation inconsistent with current state

Pop-up window when resuming a suspended virtual machine:

Operation inconsistent with current state

What does this mean?  Why is it appearing?  What should I do about it?

Clicking on OK merely dismisses the pop-up error.  No detectable change elsewhere.  Activity monitor shows machine mostly idle with no CPU or memory hogs.  Nothing else running on machine except normal maintenance and system tasks.  Incidentally, the suspended machine never resumed after an hour when I gave up.

Application:

   - VMWare Fusion 11.5.0 (14634996)

      + Display: Accelerate 3D Graphics: off

      + Compatibility: hardware version 16

OS:

   - MacBook Pro running High Sierra 10.13.5

Hardware:

   - MacBook Pro (15-inch, Early 2011)

      + 2.3GHz Quad-core Intel Core i7

      + 8GB 133MHz DDR2 SDRAM - 2x4GB

      + 500GB Serial ATA Drive @ 7200 rpm

Thank you for your time.

11 Replies
VMware Employee
VMware Employee

Hi jkkastner,

Can you help to reproduce this issue and then attach the vmware.log (under ~/Virtual Machines.localized/yourvm.vmwarevm/) and vmware-vmfusion.log (under ~/Library/Logs/VMware Fusion/)

Thanks for your cooperation.

0 Kudos
Contributor
Contributor

Contents of ~/Documents/Virtual Machines.localized/loquat.vmwarevm/vmware.log

moderator edit by wila: Moved copy&paste log to attachment

0 Kudos
Contributor
Contributor

Contents of: ~/Library/Logs/VMware Fusion/vmware-vmfusion-0.log

Moderator edit by wila: moved copy&pasted log to attachment.

0 Kudos
Contributor
Contributor

The incident happened when I was trying to revive an old machine.  I upgraded to the latest VMWare Fusion (11.5.0 - 14634996), did a fresh install of Fedora 30 from downloaded ISO (Fedora-Workstation-Live-x86_64-30-1.2.iso), tested for some time and shut down the machine.  The next day when I attempted to use my virtual machine, it would not continue out of the suspended state.  The only message on the screen was the pop-up window with "Operation inconsistent with current state."

0 Kudos
VMware Employee
VMware Employee

It looks like there are some mess with vm state.

please shutdown this vm from menu, "Virtual Machine" --> hold the "option" key and click "Shut off".

0 Kudos
Contributor
Contributor

I have tried restarting, full shutdown and restart, and more.  It appears the corruption isn't ephemeral.

0 Kudos
VMware Employee
VMware Employee

please try hard resume. it may work better.

in vm setting, change "Power options" ->  change "Resume" to "Resume (hard)".

0 Kudos
Contributor
Contributor

No change.  I tried the experiment a couple of times.

Thank you for your attempt to help.

0 Kudos
Enthusiast
Enthusiast

I do have the same issue since I upgraded my Macbook Pro to Catalina (10.15). Every time I reboot my computer I get the pop-up :"Operation inconsistent with current state" right before the VM even started. On top of the pop-up, I get the VM library window open and another pop-up with a progress bar "Resuming" which never goes away as long as I do not click on Mac OS desktop, not to mention the icon in the dock having the "resuming" bar forever. If I switch from Unity to a simple window, I have the "Resuming" progress bar at the bottom forever.

My VM is configured to start with Vmware Fusion which starts on Mac OS boot. The VM is configured to work in Unity mode as Vmware Fusion is designed to.

If I boot the system with the VM configured to start in simple window, I get no pop-up which means that the message is linked to Unity.

So how could I avoid to get the nasty pop-up and its friends while keeping my VM to boot in Unity mode as it is a requirement for this machine? Is there a way to delay the start of Unity?

0 Kudos
Contributor
Contributor

Try closing all tabulated VMs. Remove the offending VM from your library list.  Go to File | Open to select the VMX you wish to start.   if there is a LCK folder, delete it first.  If I were to guess I'd suggest that the latest VM-ware (15.5.2 build 15785246) gets confused about the state of a VM saved in its "library" list.  Simply removing it and reopening it using File | Open appears to work (for me at least)

0 Kudos
Enthusiast
Enthusiast

I found a solution which is working for me.

I first edited the .vmx file of my VM to remove the "migrate.hostlog" line which was referring to a deleted folder.

As this VM is starting automatically with MAC OS, I removed all "Vmware Fusion" stuffs from the user's config panel "Login" tab. The VM was added a long time ago and maybe the reference was not good anymore.

Then, I added my Windows 10 VM, not the program Vmware Fusion, in the user's config panel "Login" tab, on next boot, a VMware Fusion helper will be added automatically.

I restarted the computer multiple times to makes sure my issue is solved and I don't get the message anymore.