mbridges
Contributor
Contributor

New to VMWare on Mac. 'Could not open /dev/vmmon: Broken pipe.' ... 'Please make sure that the kernel module `vmmon' is loaded.' ERROR

Jump to solution

Downloaded VMWare this afternoon after reading/hearing about how good it is after experiencing some frustration with VirtualBox.

Paid 70 pounds, downloaded and installed ... upon first attempt of setting-up a Windows VM, I get the 'Could not open /dev/vmmon: Broken pipe' error, try again with Linux Mint and get the same.

Reading these forums, it says lots about granting access through security settings which I have done.  These weren't set so I made the changes and re-started but the error was still there.

I then attempted to uninstall the program to reinstall it ... this was also problematic as the program is not easy to fully remove - even with the removal instructions that uses the finder to remove hidden library files.  Upon re-installation, things are still there from the first installation which suggests not everything had been removed.  Two re-installations later and the error still comes up.

Could anybody please tell me how I even get support from VMWare?  The 'get support' page asks me to select the program I require, but it is not listed in my account profile, despite me purchasing it from the account.

Help needed.  Just paid 70 pounds for something that doesn't work.

Mac OS Mojave 10.14 MBP 15in mid-2014

Many thanks,

Michael

1 Solution

Accepted Solutions
Parveen1988
Enthusiast
Enthusiast

Hi,

Try this as well.

  1. Shut down the Virtual Machine.
  2. Ensure VMware Fusion is quit.
  3. Click on Apple logo on the top left of the Mac screen -> System Preferences -> Security and Privacy ->General>See if you get any messages, "System Software from VMware is being blocked" if yes, please click on Allow.
  4. Re-launch Fusion.
  5. Restart your virtual machine.

___________________________________________________________________________

Did you find this helpful? Let us know by completing this survey (takes 1 minute!)

View solution in original post

20 Replies
zhus
VMware Employee
VMware Employee

Hi Michael,

Could you try the following commands to load vmmon kext manually?

> sudo kextload /Applications/VMware\ Fusion.app/Contents/Library/kexts/vmmon.kext/

> kextstat | grep vm

What is the output?

Would you please also provide the support bundle if possible?

To collect the support bundle, you can launch Fusion, then select Help -> Collect Support Information.

Regards,

Shan

Parveen1988
Enthusiast
Enthusiast

Hi,

Try this as well.

  1. Shut down the Virtual Machine.
  2. Ensure VMware Fusion is quit.
  3. Click on Apple logo on the top left of the Mac screen -> System Preferences -> Security and Privacy ->General>See if you get any messages, "System Software from VMware is being blocked" if yes, please click on Allow.
  4. Re-launch Fusion.
  5. Restart your virtual machine.

___________________________________________________________________________

Did you find this helpful? Let us know by completing this survey (takes 1 minute!)

View solution in original post

Mario_m
Contributor
Contributor

I have the same Problem but cannot open a support Ticket. Are there any new informations?

BlueBlazes
Contributor
Contributor

that does not work.

Parveen1988
Enthusiast
Enthusiast

Did you get any message, could you let me know the output of below command in terminal.

kextstat | awk '$6 !~ /^com.apple/ { print $6 " \t " $7 }'

Also try this:

1. Run First Aid.

2. Shutdown the Mac(Not restart).

3. Power it On.

4. Look for the message as mentioned in my previous reply.

americancompute
Contributor
Contributor

I tried and got this:

/Applications/VMware Fusion.app/Contents/Library/kexts/vmmon.kext failed to load - (libkern/kext) authentication failure (file ownership/permissions); check the system/kernel logs for errors or try kextutil(8).

peterdun
Contributor
Contributor

this worked for me

Parveen1988
Enthusiast
Enthusiast

Could you please mark the answer as "Correct Answer"

Parveen1988
Enthusiast
Enthusiast

Hi,

It looks like that still the Kernel extensions are blocked by the Mac OS, I would recommend uninstalling and re-installing Fusion as well (in case you haven't tried that).

brlum
Contributor
Contributor

Michael-- Just to let you know that my new Fusion 11 on new MacBook Pro is giving the same error despite ALL of the proposed fixes in this thread. I hope to spare you wasting time on circular pursuits.

I did open a support ticket w/VMW & Apple and spent about 12 hrs over 3 days w/engineer types from both w/o an acceptable fix.

However, the second  engineer from VMW Global Support did come up w/a "terminal command string" that disabled OS High Sierra's SIP (security policy) and then Fusion 11 worked fine. He then enabled SIP again and Fusion 11 was "broken pipe" again.

I shared the SIP workaround w/Apple's engineer, but after he escalated that higher up, the answer was that they could not provide me with any timely fix.

Bottom line is it appears that VMW & Apple need to work together to fix the SIP blocking and man-up to the problems customers are experiencing.

I just filed a case w/VMW for a full refund.

sixLambda
Contributor
Contributor

I experienced all these issues and tried everything mentioned to no avail.  Here is what worked:

I uninstalled the program and reinstalled it.
Got same issue.

I rebooted and tried the command line manual starts and that did not work.

My security setting allowed VMware.

However, what worked:

1) If you have Firewall on in Security, add VMware to allow incoming connections to the firewall.

2) Shutdown the computer (not reboot)

3) Turn it back on.

The message of the /dev/vmmon: Broken Pipe went away.

hammer_clover
Contributor
Contributor

Here is what I tried:

Checked "System Preferences > Security and Privacy > General'

Allow apps downloaded from : App Store and identified developers

Started VMware Fusion, selected my VM, tried to start it, got the error (Could not open /dev/vmmon: Broken pipe...)

Completely shut down VMware.

Checked "System Preferences > Security and Privacy > General'

Same, no "blocked" messages or otherwise.

On to the command line:

$ sudo kextload /Applications/VMware\ Fusion.app/Contents/Library/kexts/vmmon.kext/

/Applications/VMware Fusion.app/Contents/Library/kexts/vmmon.kext failed to load - (libkern/kext) kext (kmod) start/stop routine failed; check the system/kernel logs for errors or try kextutil(8).

$ sudo kextutil /Applications/VMware\ Fusion.app/Contents/Library/kexts/vmmon.kext/

Untrusted kexts are not allowed

Kext with invalid signature (-67062) denied: /Library/StagedExtensions/System/Library/Extensions/42DBC50C-DC4C-4C03-978B-76AA3CE41C28.kext

Bundle (/System/Library/Extensions/HoRNDIS.kext) failed to validate, deleting: /Library/StagedExtensions/System/Library/Extensions/42DBC50C-DC4C-4C03-978B-76AA3CE41C28.kext

Unable to stage kext (/System/Library/Extensions/HoRNDIS.kext) to secure location.

/Library/StagedExtensions/Library/Extensions/A20ABBBA-3437-416D-A216-979981BD83BD.kext does not appear in strict exception list for architecture: x86_64

Untrusted kexts are not allowed

Kext with invalid signature (-67049) denied: /Library/StagedExtensions/Library/Extensions/A20ABBBA-3437-416D-A216-979981BD83BD.kext

Bundle (/Library/Extensions/HoRNDIS.kext) failed to validate, deleting: /Library/StagedExtensions/Library/Extensions/A20ABBBA-3437-416D-A216-979981BD83BD.kext

Unable to stage kext (/Library/Extensions/HoRNDIS.kext) to secure location.

(kernel) Kext com.vmware.kext.vmx86 start failed (result 0x5).

(kernel) Kext com.vmware.kext.vmx86 failed to load (0xdc008017).

(kernel) Failed to load kext com.vmware.kext.vmx86 (error 0xdc008017).

Failed to load /Library/StagedExtensions/Applications/VMware Fusion.app/Contents/Library/kexts/vmmon.kext - (libkern/kext) kext (kmod) start/stop routine failed.

Found this: Can't load VMWare Fusion Pro 10.1.1 Kext modules

Going to reboot again now. Fingers crossed.

0 Kudos
hammer_clover
Contributor
Contributor

After checking for updates, and finding one, installing it, then doing a shutdown/start (not restart), Istarted vmware and I was prompted by my MAC to stop blocking a component of VMware.  I went to the security preferences and selected "Allow" (It finally showed up).

I did another shutdown, followed by a start (not restart).

I started VMware right after booting, and was able to start my VM.

How hard can it be?

0 Kudos
quasimoto
Contributor
Contributor

Thanks a million!!  That did the trick.  I found the error on a sunscreen just like you stand and presto!!!  You saved me a lot of grief as I brought mu Macbook on my business trip with my DVD drive to install windows.  I  would have been crushed if it did not work.  Life saver!!!  😃

0 Kudos
buamod
Contributor
Contributor

I am having the same problem .. after I install Virtual box

0 Kudos
saber16
Contributor
Contributor

You should load in recovery mode, disable sip, restart in recovery again and then re-enable sip.

Detailed steps:

  1. From the Apple menu select Restart.
  2. As your Mac restarts, press and hold down the Command(⌘) + R keys immediately upon hearing the startup chime. Hold the keys until the Apple logo appears to get the computer in Recovery mode.
  3. The computer is now in Recovery mode. From the Apple menu select Utilities -> Terminal
  4. Run the command: csrutil disable
  5. From the Apple menu, select Restart.
  6. After the macOS is loaded, open terminal and type: sudo kextutil /Applications/VMware\ Fusion.app/Contents/Library/kexts/vmmon.kext/
  7. From the Apple menu, select Restart.
  8. As your Mac restarts, press and hold down the Command(⌘) + R keys immediately upon hearing the startup chime. Hold the keys until the Apple logo appears to get the computer in Recovery mode.
  9. The computer is now in Recovery mode. From the Apple menu select Utilities -> Terminal
  10. Run the command: csrutil enable
  11. From the Apple menu, select Restart.
PaulHSV
Contributor
Contributor

Had the same problem on Catalina, after moving OS to different drive. Per notes below, go to Apple/preferences/security & privacy/general. Unlock the system and look for "VMware tried to access system" message on bottom of window, click Allow.

0 Kudos
quasiDigi
Contributor
Contributor

At first this procedure did not worked. No message was showing up in the Security and Privacy -> Genera tab.

I had to restart my computer to get to see it.

Thx!

0 Kudos
Biixi
Contributor
Contributor

I think you are trying to say check your firewall security system if its allowing or rejecting the VMware fusion?

 

if that is the scenario. this is not the solution for me.

 

thanks for your info.

0 Kudos