Contributor
Contributor

New installation of Vmware fusion 11 pro on macos Mojave Could not open /dev/vmmon: Broken pipe

Why is this happening on a an upgrade to the lates version on the latest version of Macos....

Any clues

I am getting fed up with these sort of issues with VMware when Parallels works perfectly...

????

59 Replies
Champion
Champion

Did you grant it permission in the security preferences when prompted?

VMware Employee
VMware Employee

Hi jp4tey

Does that problem still persist if you shut down your Mac host and start up it again?

If yes, could you please provide Fusion support bundle which can be created by selecting Fusion menu "Help" > "Collect Support Information"?

0 Kudos
Contributor
Contributor

I contacted VMware support directly with the issue.

They responded very quickly, and resulted in one of the support team working through a series of tests with me.

The final issue appeared to be related to the fact the I had previously installed VirtualBox  and that this installation was interfering with the installation process of VMware.

Once I removed VirtualBox and tried VMware again it came up with the Dialogue that showed I had to approve the Kernel extension in the Security & Privacy General Tab (this dialogue never appeared when VirtualBox was installed).

After that everything seemed to be working correctly.

0 Kudos
Contributor
Contributor

I am having this same issue with fusion 11.

I do not have virtual box installed (I did in the past).

I have Vmware Fusion checked in Security & Privacy in Privacy section.

Any other ideas on how to fix?

0 Kudos
Contributor
Contributor

Do you have docker installed as the VMware tech said it could have a similar issue

I uninstalled Docker at the same time as VirtualBox, I have not re-installed it yet.

0 Kudos
Contributor
Contributor

I do not have Docker installed but thanks for the idea.

Any other ideals?

0 Kudos
Champion
Champion

Did you fully uninstall virtual box?  just dragging to the trash may not be enough to get rid of all the bits.

0 Kudos
Contributor
Contributor

Yes, I used AppCleaner to uninstall. I just scanned for any remaining bits of VB but I don't see anything.

Any particular thing I should look for?

0 Kudos
Contributor
Contributor

Specifically I am getting this message:

Could not open /dev/vmmon: Broken pipe.

Please make sure that the kernel module 'vmmon' is loaded.

0 Kudos
VMware Employee
VMware Employee

Hi, there

The kext file was not loaded successfully.

Check:

1. Open Fusion

2. Open terminal and input kextstat | grep vmware

There should be 4 kext running.

If not, please got System Preferences > Security & Privacy > General tab,

press the allow button if there it is.

If the issue still happens, please help check the following command output

sudo kextutil /Applications/VMware\ Fusion.app/Contents/Library/kexts/vmmon.kext

(input the password)

The following content means the allow button was not pressed

vmwares-Mac:~ vmware$ sudo kextutil /Applications/VMware\ Fusion.app/Contents/Library/kexts/vmmon.kext

Kext rejected due to system policy: <OSKext 0x7f970850f210 [0x7fffa9b538d0]> { URL = "file:///Library/StagedExtensions/Applications/VMware%20Fusion.app/Contents/Library/kexts/vmmon.kext/", ID = "com.vmware.kext.vmx86" }

Anyway, if the kext couldn't be load and you got no chance to press it. Please remove all Fusion contents and reinstall it.

And this time, please press the Allow button once the macOS alerts security thing that related to fusion.

Best Regards

Contributor
Contributor

Same exact problem here...

MacOS 10.14 Mojave

VMWare Fusion 11.0.0

Have 4 kext running vmci, vmnet, vmx86, vmioplug

Fusion allowed in "Security and Privacy"

Have run the kextutil command w/ password and it completes successfully

Have completely uninstalled and reinstalled 3x, no change.

Have run VMWare Fusion daily for years on this machine including 11.0 until today and just started getting "Could not open /dev.vmmon: Broken pipe".

Ideas?

Thanks.

0 Kudos
VMware Employee
VMware Employee

Hi, Eskimoke

Sorry for such thing happens.

In such case, we need the log files to find the root cause at your side.

Would you please collect and send it to us please?

1. Make sure the vm is powered off

2. Open VM settings > Advanced > TroubleShooting and choose Hang/Cash

3. Try to power on the VM

4. Fusion main menu > Help > Collect Support Information

5. A zip file will be generated and would you please send it to us?

If the log files size is big, would you please send it to my Dropbox file request?

Dropbox - Submit files

Thanks and best regards

0 Kudos
VMware Employee
VMware Employee

Hi, Eskimoke

Log files received.

A first simple checking is the launchd against VMware Fusion issue.

Fusion will register some helper tool into /Library/PrivilegedHelperTools/

Would you please help verify if the VMware Fusion.app was code-signed correctly?

Open terminal and input codesign -dv /Applications/VMware\ Fusion.app

And was there any some security application at your PC?

(This may stop the registration into launchd process.)

And an initial proposed solution is disable SIP(system integration protection).

(

  1. Click the  menu.
  2. Select Restart...
  3. Hold down Command-R to boot into the Recovery System.
  4. Click the Utilities menu and select Terminal.
  5. Type csrutil disable and press return.
  6. Close the Terminal app.
  7. Click the  menu and select Restart....

)

We will look into the details of your log files and update soon.

Best Regards

Contributor
Contributor

Same issue as the others and I have read the responses and tried the various fixes but nothing doing. Until....

What I did find was that the other logged in users were being asked the VMWare security question but I didn't know this until I was about to reboot and went to log them off (family members). Once they were logged off, I went back to my login and started VMWare 11.0 and this time I was asked about the security options and once this had been confirmed my virtual machine finally started.

Just make sure you're the only user logged on before installing/moving etc.

Contributor
Contributor

I wasn't able to to give permissions to the installer via the "allow" dialog due to corporate policy, so I cancelled out of the installer.  I've since been given access to system preferences, but no matter what I do I can't get the installer to prompt me again.  If I run the installer after following these instructions .. I was able to build and boot a win10 vm, which is great.  However, I can't leave it in this mode. I re-enabled it and vmware is broken again.  How should I proceed?

0 Kudos
Contributor
Contributor

Hi !

This solved may problem.

Thanks.

"

The kext file was not loaded successfully.

Check:

1. Open Fusion

2. Open terminal and input kextstat | grep vmware

There should be 4 kext running.

If not, please got System Preferences > Security & Privacy > General tab,

press the allow button if there it is.

"

0 Kudos
Contributor
Contributor

This works perfectly fine for me. Thanks a lot!  

0 Kudos
Contributor
Contributor

had the same symptom on a brand new iMac install (still on High Sierra though) and with a newly registered Fusion 11.

all i did to solve it was to hammer that "Allow" button in the Security pane... for some reason it would not go away when clicking it once! Hammering it like 30 times in probably 10 to 15sec would take care of it and my VM would start even without having to restart Fusion or even the iMac.

"kextstat | grep vmware" returned nothing but i saw 4 lines in About this mac > System report > Software > Disabled Software.

These four lines are now gone and everything seems fine - till when though!?

0 Kudos
Contributor
Contributor

Forgive my ignorance. I followed your suggestion, and it appears that I did not "allow" upon initial startup.

Would you be able to give me some additional information regarding removing the Fusion contents

Anyway, if the kext couldn't be load and you got no chance to press it. Please remove all Fusion contents and reinstall it.

Nix this request, I was missing the critical step of making sure that Fusion was exited/quit, in order to see the "allow" button. Thanks for all of the good info!

0 Kudos