Highlighted
Contributor
Contributor

Network Settings options greyed out in Fusion Pro 7.1.0

I have uninstalled VMware Fusion 7.1.0 Professional edition 3 times, emptied trash deleted all settings files as listed in KB article 1017838

installed Fusion 7.1.0 .. it somehow still gets my license keys and vminventory and when i go to Preferences > Network .. unlock to make changes but the entire settings area is still greyed out.

any clues or ideas on getting this fixed?

28 Replies
Highlighted
Contributor
Contributor

I had VMWare Fusion 7.0.1 Pro and cannot change my network prefs away from 'share with my mac' -- I upgraded to VMWare Fusion 7.1.0 Pro  and still I cannot change to Autodetect

0 Kudos
Highlighted
Immortal
Immortal

Hi VAppsCloud,

Thx for using Fusion.

Could you pls give a snapshot of your setting panel to help us what's going on?

Thx a lot & Nice day.

0 Kudos
Highlighted
Contributor
Contributor

I was having a similar problem and in the process of searching this forum and coming across this thread, I discovered a possible fix.

Problem: After upgrading to 7.1, my Windows 7 VM could not activate the network adapter (Local Area Network/VMWare's virtual Intel ethernet adapter). In Windows, I tried to disable and enable it. No go. Shutting the VM down and opening the Fusion "Settings, Network Adapter" for the VM resulted in the dialog showing all of the adapter options as greyed out. I could click the "Connect Network Adapter" check box on and off to no avail. Also tried:

1) Going to advanced options and removing the Network Adapter. Recreated it, same problem. However, it was then configured to use "Share with my Mac" now as default. (I use bridged mode with my primary Mac Pro ethernet port.)

2) Rebooting the Mac itself.

Possible fix: Tinkering around, I decided to "Add Device..." and create a second Network Adapter. Upon doing so, the second Network Adapter settings could be changed and then suddenly the original Network Adapter settings could be as well. I then removed the second Network Adapter and the first was still working. Quit Fusion and re-opened to confirm the settings were still changeable. Booted VM and confirmed network adapter was working.

I am not sure why this appeared to work better than removing and re-creating the first adapter but it did. My only other guess is something was happening in Fusion in the background that finally "released" (un-greyed out) the options while I was tinkering. But that would not be expected behavior and how long one would actually have to wait is not clear.

0 Kudos
Highlighted
Contributor
Contributor

I uninstalled, then reinstalled VMWare, but that did nothing.

A reboot of my Mac afterwards did fix the greyed out network options, though.

0 Kudos
Highlighted
Contributor
Contributor

This is unbelievably frustrating.  VMware really needs to get this fixed.  I just graded, going from 6.5 to 7.1 and now have this problem.  I have tried all the steps mentioned on this forum so far nothing has worked.

Highlighted
Contributor
Contributor

Hi.

I have the same problem on 7.1.1 Pro

Reinstalled and rebooted Mac - same problem.

When I deleted Fusion like this: VMware KB: Manually uninstalling VMware Fusion

And then reinstalled Fusion - it worked.

0 Kudos
Highlighted
Contributor
Contributor

I'm having the exact same problem.  Upgraded to VMWare FUsion 7.1.2 and upgraded my OS to 10.10.4 and now all the networking options are GHOSTED out.

Bridged no longer works either and I can't change it.


I had to delete the network devops in VMWare Fusion and then readd it, and STILL the option for Bridged is still ghosted out.

And I still have no networking.

PLEASE FIX THIS!!!!!

0 Kudos
Highlighted
VMware Employee
VMware Employee

Does a reboot of your Mac OS X make sense?

0 Kudos
Highlighted
Contributor
Contributor

I'm having this same problem with Fusion 7.1.2.  Has anyone seen a resolution for this?  This is extremely frustrating!

0 Kudos
Highlighted
Contributor
Contributor

Has anyone found a fix for this?  I can not upgrade beyond 7.0 or else this network GHOSTED out issue happens & I can't change any settings.

2015-11-12_11-30-22.png

0 Kudos
Highlighted
Contributor
Contributor

Hi,

I know this is old but since there were still some apparent problems, I'll revive.

I recently had this issue (albeit on Fusion Pro 8.1.0), and I found this thread and none of the solutions worked. What had caused my issue was I modified my dhcpd.conf file to add an IP reservation to keep my VM at a predictable IP so I could reference it in my hosts file. Unfortunately after I modified my network settings my network settings were greyed out for all adapters on all VMs.

To fix, I deleted all of the .bak files in my /Library/Preferences/VMware\ Fusion/vmnetX folders, then I edited /Library/Preferences/VMware\ Fusion/networking and removed the DHCP configuration hash lines. I then rebooted and I had control of my network preferences.

I hope this helps someone else who might be having this issue.

-GNS

Highlighted
Contributor
Contributor

Hi,

it looks like this is a never ending story...

I upgraded to Fusion 8.1pro because I use Mac OS X ElCapitan now and had the same issues regarding the Network Settings.

I decided to wipe out Fusion completely (was a user since V5) and deleted all settings and sub folders according to KB1017838

VMware KB: Manually uninstalling VMware Fusion

After a new install the problem was gone...

Took me 2 hours of my spare time... well hopefully this will not happen again when I update to 9.x...

HTH,

Holger

0 Kudos
Highlighted
Hot Shot
Hot Shot

0 Kudos
Highlighted
Contributor
Contributor

I'm running 8.1 and encountered the same issue. The work-around I've found is to select the VM you wish to edit, then using the main menu bar, select the interface and then select the desired connection.

Highlighted
Contributor
Contributor

@TomSoutherland.

Thanks a lot.

I'm running Fusion 8.1.1.

I've handled my networks manually by editing the vmx files since the networking adapters turned gray in the adapter settings.

Best regards,

Lars

0 Kudos
Highlighted
Contributor
Contributor

Worked like a charm on Pro 8.5.3. I recently upgraded from version 7 and after the update this error was occuring. Don't forget to reboot your Mac after the changes.

0 Kudos
Highlighted
Contributor
Contributor

HI,

I was having the same problem greyed out network settings after upgrading to Fusion 8.5.8.

Since I was using a VM created in another partition(I was migrating to MacOS High Sierra), thought it could be related to folder permissions.

So I moved the VM to "/users/shared" and the Problem was solved!

Hope this help.

See ya

0 Kudos
Highlighted
Contributor
Contributor

@schmitgreg

> To fix, I deleted all of the .bak files in my /Library/Preferences/VMware\ Fusion/vmnetX folders,
> then I edited /Library/Preferences/VMware\ Fusion/networking

> and removed the DHCP configuration hash lines. I then rebooted and I had control of my network preferences.

This solved the problem for me (VMware Fusion Pro 8.5.8 on macOS 10.13). Thank you schmitgreg!

Highlighted
Contributor
Contributor

Tried this, but it did not worked. What it did worked was removing all the files from "/Library/Preferences/VMware Fusion" except

- thnuclnt
- license-fusion-....

- lastLocationUsed

It did assigned new IP's inside the VM, but at least I had again connectivity.

Fusion 8.5.9 on High Sierra 10.13.1

0 Kudos