VMware Communities
Dynomite567
Contributor
Contributor
Jump to solution

My windows 10 network adapter is not working

So when I load up my Windows 10 vm and login, it indicates that the ethernet cable is not plugged when in my settings, the network adapter is on. How do I fix this?

Reply
0 Kudos
1 Solution

Accepted Solutions
Dynomite567
Contributor
Contributor
Jump to solution

Ok, I figured it out. Apparently, for some reason, you have to go to the VMware preferences and go to network pane and uncheck the box Require Authentication... It worked fine after that. Thanks for all the help everyone!

View solution in original post

Reply
0 Kudos
12 Replies
zhaokaiy
VMware Employee
VMware Employee
Jump to solution

Hi, Dynomite567

Would you like to try to disable and enable the network adapter please?

And the second way may resolve your problem is to remove the network adapter then add a new one.

Hope this can work.

Reply
0 Kudos
nancyz
VMware Employee
VMware Employee
Jump to solution

Hi Dynomite567 ,

How did you crate the VM? Which network does the VM use, bridged or NAT?

Reply
0 Kudos
Dynomite567
Contributor
Contributor
Jump to solution

nancyz

I used the default option, NAT. I tried different network configurations, including reinstalling the os on the virtual machine. It did not work.

zhaokaiy

I tried disconnecting and reconnecting the network adapter, I also tried removing and adding the device back in the machine. No luck.

Reply
0 Kudos
nancyz
VMware Employee
VMware Employee
Jump to solution

Dynomite567 ,

How did you install the VM? You created via Fusion or imported it from other products. Would you please reboot your Mac OS and see if the could help?

Reply
0 Kudos
Dynomite567
Contributor
Contributor
Jump to solution

nancyz

I installed it using VMware fusion using the iso provided by Microsoft. Nothing was changed and it installed with default settings. Rebooting does not help as well as uninstalling VMware and reinstalling it.

Reply
0 Kudos
nancyz
VMware Employee
VMware Employee
Jump to solution

Hi Dynomite567

Did you approve the KEXT form the Security preferences pane?

Installing VMware Fusion triggers System Extension Blocked notification on Mac OS 10.13 High Sierra ...

Reply
0 Kudos
Dynomite567
Contributor
Contributor
Jump to solution

nancyz

No, I never got that problem, just checked. It also seems to be a problem from Fusion, not the vm

Here are my specs (should have said this a while ago):

MacOS Siera 10.2.6

VMWare Fusion 8 (Latest)

Reply
0 Kudos
Dynomite567
Contributor
Contributor
Jump to solution

Ok, I figured it out. Apparently, for some reason, you have to go to the VMware preferences and go to network pane and uncheck the box Require Authentication... It worked fine after that. Thanks for all the help everyone!

Reply
0 Kudos
nancyz
VMware Employee
VMware Employee
Jump to solution

Hi Dynomite567 ,

Thanks for your information.Could you please upload your vmx file? Did you install vmware tools inside the VM? Do you have other virtual machines? Does network work for them?

Also, please check if the service vmnet-natd is running.You could do that by launching Terminal application and type 'ps aux|grep vmnet-natd'.

Reply
0 Kudos
mothukuri
Contributor
Contributor
Jump to solution

Where is the option?, I don't see it. Do you have screenshot?

Reply
0 Kudos
truckin
Contributor
Contributor
Jump to solution

Any luck? I'm trying to solve the same problem and don't see the option mentioned either.

The first time I had this problem, I had to re-install fusion and upgrade back to the latest. Other suggestions of adding and deleting network interfaces did not help.  I just took a Windows 10 update and am back to this problem.

Reply
0 Kudos
AgtShadow
Contributor
Contributor
Jump to solution

Where is this option at? 

I feel as if I've done everything and nothing is working. I might just have to reinstall the entire VMware Pro 16 and I'm afraid that will not work either. 

I've reset all virtual network adaptors and I've also reset all my Ethernet and wifi adaptors. 

Nothing works. 

- Agent Shadow
Reply
0 Kudos