journonyc
Contributor
Contributor

Mouse problems w/fusion 5?

I upgraded to Mountain Lion. I upgraded to the trail of Fusion 5 professional (standard trial version not available). Running Windows Vista. Now my mouse, as the cursor runs over any line that separates sections in Outlook, for example, makes a black square appear and then quickly disappear. So as I open an email, for example, move the cursor from text to recipient to some other part of the email, I keep seeing quick flashes of black -- so annoying. Also as I move the cursor anywhere on the Window, the text describing what I've quickly moved over pops up. I've changed the mouse preference from games to never games, but these annoying black boxes keep appearing everywhere as I move the mouse around. I upgraded because fusion 4 became so so so slow. Hope there's a fix, otherwise I'm getting rid of Windows & Fusion for good and hoping to find only Mac software for everything I need for my small business. Anyone have the same problem and a fix?

0 Kudos
65 Replies
journonyc
Contributor
Contributor

Unfortunately, changing the pointers to be the same in text & normal does not work in Vista, at least not for me. This is horribly annoying as my work is publishing a digital business report via email so I'm using Outlook all day & night, every day, and I continue to have these huge squares appear in the emails and in Excel and Word.

I'm very grateful for all the suggestions, but none work so far. VMWare says it was fixed in the update to Fusion; it was not.

0 Kudos
ErginOzturk
Contributor
Contributor

I have not set any specific icon for select text or Normal Select.

Please see attached file for changed fields ..

This solution is for Windows 7 only I have no Vista or any guest operating system other than Win 7, so maybe these settings may give clue to others.

Ergin Ozturk

0 Kudos
wrhahn
Contributor
Contributor

Solution >>> Disable Mouse Pointer Shadow or Replacing "Text Select" icon/graphic in mouse settings if you need mouse shadow on

Two Solutions >>> #1 Below completely solved for me while #2 Below was an effective workaround if you need pointer shadow


1) DISABLING (un-checking) "Enable Pointer Shadow" made this flicker black box problem COMPLETELY go AWAY for Me!

Mouse-Pointers-Scheme-Config-Disable-PointerShadow.jpg

2)  In Addition, the technique documented in my earlier post, with screenshots, works when Pointer Shadow is enabled  as well >>> Replacing the "Text Select" icon/graphic made this  problem go away for me (ref:
http://communities.vmware.com/message/2121320#2121320 )

0 Kudos
djphat2000
Enthusiast
Enthusiast

I was instructed by a VMware tech (Fusion) to do the following.  Seems as though it has helped.  I have only seen the black box once so far, of really really tring to make it happen like before.  I have my mouse settings back to normal as well (both for XP and Win 7).

You will have to open up your Virtual Machine Library.  Right click your "VM", while holding the "alt-option" key.  Open Config File in Editor, and add the following line to the bottome of the text.

mks.noHostCursor = "TRUE"

this seems to have helped me, while keeping everything else normal.  I hope it helps. 

0 Kudos
djphat2000
Enthusiast
Enthusiast

I don't know if this is related or not.  However, I'm not able to start my VM of Win 7 now.  Smiley Sad

Was working fine.  My Mac had a KP (From what I don't know).  Started back up, and booted my XP vm.  That went fine.  Started up my Win 7, and that play button greys out after clicking, then goes back to white.  Like it tried to start, but didn't. 

AHhhHHHHHHHHhhhhHhhHhhH!!!!!!   :smileycry:

0 Kudos
Dr_Gary
Enthusiast
Enthusiast

Greetings djphat2000,

I tried the fix that you received from tech support…i.e., adding the mks.noHostCursor = "TRUE" to the VMX file.  It does indeed solve the infamous “black box” issue, however, I am now receiving kernel panic’s and long freezes with the old spinning beach ball when running my VM’s in 5.0.1.

So…back to release 4.1.3 I go.

I am both surprised and disappointed that it has now been over a month since 5.0.1 patch was released, however, no further update has been available to address this and many other issues.

Good Luck.

0 Kudos
xtremesniper
Contributor
Contributor

I'm surprised at the lack of patches too, but perhaps not even VMWare has any idea why this is happening... Either that, or it might be out of their hands (graphical driver issue via Apple).

Granted, if this was the case then I wish VMWare would at least issue a statement or an update so people stop playing the blame game without warrant.

0 Kudos
Dr_Gary
Enthusiast
Enthusiast

I agree with your synopsis of events. 

The thing that I can’t understand is that all of my VM’s…from Windows XP through Windows 8 RTM actually work fine in 4.1.3.  So I would think that after a month…they would have been able to figure out what modifications/enhancements were included in the new version 5 hardware/drivers, etc., and come up with a fix.

0 Kudos
wrhahn
Contributor
Contributor

Solution UPDATE!  I am HAPPY!

Simply turning Mouse Shadow OFF in my Win7 Guest has worked VERY well for me for over a week now!

I consider VMWare Fusion V5.x with Win7 and Mouse Pointer Shadow OFF to be a permanent solution for me!!!

I have been running for over a week now on VMWare V5.0.1 and pushing my Win7 Guest hard with a lot of heavy lifting computing.  I write software and demo for a living inside my Win7 Guest, so I use some fairly CPU/Graphics intensive Development, Business and BizAnalyst tools.

My system has not crashed and I have not seen the Black Box Flicker issue by my mouse pointer at all for over a week!

I consider my configuration for Retina MacBook + VMWare V5.x + Win7 Guest ready for prime time.

I'll update this community forum thread if things change...

My advice to colleagues moving to new Retina MacBooks:

1) Use VMWare Fusion V5.x for your Windows Guests, as long as you turn off Mouse Shadow!

     (VMFusion V5 seems to run Win7 faster and handles Retina graphics better, including Win7 fullscreen on resume and initial boot)

2) Make sure you turn Mouse Pointer Shadow OFF in your Windows Guests (I had to say it again, since it caused me so much pain for weeks 🙂

3) Set Mac OS X System Preferences > Energy Saver > DISABLE (un-check) Automatic graphics switching

     ( The only times I have experienced stability issues is when this has not been disabled...spanning multiple OS X updates from Apple )

4) Set Mac OS X System Preferences > Energy Saver > Display Sleep NEVER (for BOTH Battery AND Power Adapter)

     ( This relates to a NASTY bug with Retina MacBooks where the screen becomes buggy after display resumes from sleep )

The above is based on my experiences with Retina MacBooks since June/July 2012 and also includes experiences with VMWare Fusion on MacBooks since early 2010.

0 Kudos
Theodrake
Contributor
Contributor

Turning off the mouse shadow does not work for me. The only thing that worked was setting the Gaming option to "Always optimize mouse for games". This makes the mouse very slow.

0 Kudos
aprabhas
Enthusiast
Enthusiast

I am pretty sure that the folks at VMware would have alerted the development team on this bug as this was seen since the release of Fusion 5.0. I'm not sure if as a workaround disabling the 3D Acceleration from the Settings>Display would help, anyways worth a try.

0 Kudos
Theodrake
Contributor
Contributor

Changing the 3D Acceleration doesn’t solve the problem.

0 Kudos
mm201
Contributor
Contributor

Let's keep things straight. There are 3 different ways a cursor might be drawn:

1. As a hardware cursor.

2. In software, by VMware. Windows thinks the cursor is in hardware.

3. In software, by Windows. VMware thinks the cursor is invisible.

Turning on cursor shadow on an RMBP will trigger #3. Dragging windows around also temporarily causes #3.

VMware does #2 if it thinks the cursor is inverting, like the I-beam cursor.

The bug is encountered when switching from #1 to #2.

0 Kudos
webbie2012
Contributor
Contributor

I am also having this problem with an unwilling mouse ... an unworkable situation - can move the mouse most of the time but it is painstakingly slow and in-accurate (this problem came out of the blue, worked fine before ... so no recent updates).

I use XP,  tried disabling mouse shadow, no solution;

Tried adding the cursor "TRUE" line in config, no good either;

!!!

But there is a way to overrule the unwillingness, this may also be a hint to where this bug comes from?!

When clicking ctrl+cmd twice and simultaniously, you gain control of the mouse (the shortkey for that behaviour), although it changes into the hand symbol, it works then to get the mouse moved normally.

To get it select something then (as a normal mouse pointer), you need to click twice again - clicking works then, after which you need to repeat the protocol again to move the mouse.

Please, is there a fix for this by now? This is just unacceptable imo.

Another rather remarkable issue: not having normal support to report this bug ...

0 Kudos
jerrythea
Contributor
Contributor

Fusion 5.0.2 was just released.

The release notes make no mention of this bug.

Has anybody tried the update to see if it fixes this problem?

0 Kudos
Dr_Gary
Enthusiast
Enthusiast

Yes...I have tried it with 5.02 and it does not fix the problem.

The workaround that does fix it, at least for me, is adding the mks.NoHostCursor = "TRUE" to the vmx file.

0 Kudos
Berknip
Contributor
Contributor

Same issue.  VMWare 5.0.2 on latest Mountain Lion release.  Truly very annoying.

0 Kudos
HanSooloo
Enthusiast
Enthusiast

Added mks.noHostCursor = "TRUE" to the VMX file ... fixes black box issue, but now Unity mode mouse behavior is bad.

When I move the mouse fast, as it approaches the border of a guest window and crosses into the host, the guest's mouse icon is left inside the guest window with a few dozen pixels the spare (say, it was going from left to right, and pointer froze 10-20 pixesl away from the right edge of the guest window).

In addition, the host's pointer is now *invisible*, even though it has transitioned from guest windowing system to host windowing system.  One *has to* click the mouse button to be able to view the pointer in the host windowing system.

0 Kudos
kendallb
Contributor
Contributor

Any updates on this? None of the workarounds work for me, and I see the same problem now in Windows 8 as I was seeing in Windows 7. Very annoying ....

0 Kudos
xesmajew
Contributor
Contributor

Same issue with MtLion and 5.0.2 Fusion. Windows 8. It was fine with 4, I should haave stayed on 4 very annoying...

0 Kudos