journonyc
Contributor
Contributor

Mouse problems w/fusion 5?

I upgraded to Mountain Lion. I upgraded to the trail of Fusion 5 professional (standard trial version not available). Running Windows Vista. Now my mouse, as the cursor runs over any line that separates sections in Outlook, for example, makes a black square appear and then quickly disappear. So as I open an email, for example, move the cursor from text to recipient to some other part of the email, I keep seeing quick flashes of black -- so annoying. Also as I move the cursor anywhere on the Window, the text describing what I've quickly moved over pops up. I've changed the mouse preference from games to never games, but these annoying black boxes keep appearing everywhere as I move the mouse around. I upgraded because fusion 4 became so so so slow. Hope there's a fix, otherwise I'm getting rid of Windows & Fusion for good and hoping to find only Mac software for everything I need for my small business. Anyone have the same problem and a fix?

0 Kudos
65 Replies
Larskl1
Contributor
Contributor

In Windows XP, config->mouse->pointers-> turn off "enable pointer shadow"

0 Kudos
djphat2000
Enthusiast
Enthusiast

ok.  checking it. 

0 Kudos
journonyc
Contributor
Contributor

Hi.. I started this post & nothing has helped yet but at least I'm not alone! I've got Windows Vista - tried running config & msconfig & looking at Control Panel Mouse, looking for anything about mouse shadow but can't find it. Any idea where I would turn it off in Vista? Thanks!

0 Kudos
utahRed5
Contributor
Contributor

The "jittery" problem that I was seeing wasn't anything to do with mouse shadow. It was more like the mouse was losing control and bouncing all over while individual windows flashed. Once I got rid of the 5.0.1 patch, everything started working again. The trouble I was having was with Win7 and XP on Mountain Lion.

0 Kudos
djphat2000
Enthusiast
Enthusiast

did not work.  In XP.  Smaller box though, but still happens. 

0 Kudos
Larskl1
Contributor
Contributor

It worked here (recall that my mouse driver failed to install when I converted my VMware image to Fusion) - I also changed to my "pointers" to 3d-Bronze (system scheme). To me it appears that part of the animation of pointers were missing.

0 Kudos
djphat2000
Enthusiast
Enthusiast

not seeing it so much ofter 10.8.2 update.  In fact I am not sure I have seen it at all really.  Gotten used to it, that I haven't paid it much attention.  However, I'm almost positive that I don't see it.  Will keep an eye on it. 

0 Kudos
Dr_Gary
Enthusiast
Enthusiast

I have this issue on my 2008 Mac Pro, 10.8.2 with Fusion 5.01, with a clean install of 10.8.2 and only installing Fusion 5.01.

I do not, however, see this "black box" mouse issue on my 2012 mac-mini, 10.8.2, Fusion 5.01, with a clean install.

Using the same Windows 8 x64 VM on both.

The obvious difference is that the Mac Pro has a discrete Nvidia graphics card...while the mac-mini uses integrated Intel graphics.

I wonder if this offers VMware any insight?

0 Kudos
djphat2000
Enthusiast
Enthusiast

Also running an Nvidia GPU (285 GTX, 2 of them)

0 Kudos
xtremesniper
Contributor
Contributor

I'm on a Nvidia 330M 512MB.

0 Kudos
utahRed5
Contributor
Contributor

I'm using an iMac i3 with the ATI card. I don't see the black box. The windows inside Win7 flash and jitter. I wonder if I have a different issue than the rest of you.

0 Kudos
Washburn76
Contributor
Contributor

Short version:

I think 10.8.2 update fixed the problem.

Long version:

Disabling mouse pointer shadows seemed to have helped in XP, but it was still somewhat noticeable if I paid extremely careful attention. I doubt the average user would have noticed the problem unless he/she was aware of it in the first place. Like I said before, I'm running a late 2008 Macbook "13" unit which comes with a dedicated on-board NVIDIA GeForce 9400M GPU. Running OSX 10.8.1.

For some reason yesterday morning, my Windows XP VM was having some trouble starting up and loading the profile sign-on screen. Then *POOF*, the entire Macbook spontaneously rebooted on itself with no warning what-so-ever. I don't think it's ever done that before for the entire time I've owned this unit. That would be like what, over 4 years ago? Wow! Anyways, I went ahead and upgraded to 10.8.2 last night and have been running my VM of XP ever since without issue. While I can't say for sure, I'm wondering if the problem was a Mountain Lion bug all along. Perhaps this latest OSX update updated the video drivers?

0 Kudos
Dr_Gary
Enthusiast
Enthusiast

If you read my previous post...I am still having the issue on a clean install of 10.8.2 on my 2008 Mac Pro.

Possibly, the 10.8.2 update fixed it for your hardware, but certainly not for mine.

0 Kudos
Blahdiblah
Contributor
Contributor

It is still a problem on 10.8.2 for me too. Mind you, I find it less irritating than other problems that still haven't been fixed from Fusion 4 (unity stealing focus, for example...)

0 Kudos
djphat2000
Enthusiast
Enthusiast

I'm seeing it more in Win 7 (64bit).  XP i'm not noticing it as much (if at all) anymore.  I did that mouse curser trick previously, so it was still "active" after the update. It does still annoy me in in 7 though, especially in my emails.  Smiley Sad

0 Kudos
xtremesniper
Contributor
Contributor

Definitely still there after upgrading to 10.8.2 running Windows 7.

0 Kudos
wrhahn
Contributor
Contributor

WORKAROUND to Eliminate Black Box Flicker Problem

***

IMPORTANT SOLUTION UPDATE on 20120927:

1) DISABLING (un-checking) "Enable Pointer Shadow" made this flicker black box problem COMPLETELY go AWAY for Me!

2) In Addition, the technique below works when Pointer Shadow is enabled as well >>> Replacing the "Text Select" icon/graphic made this problem go away for me

***

ORIGINAL Post Below:

This is just a workaround, but it does reliably minimize, or in my case eliminate 99% of the Black Box Flickering problem:

On my Win7 VMWare Guest:

1) Go to Start > Mouse > Pointers

2) Configure the "Text Select" pointer icon to be the SAME as the "Normal Select" icon

(On my system, I like the 3D Bronze pointers, but this works regardless of the color/style of pointer Scheme you have)

The "Text Select" icon transition occurs when you mouse/move over/into/outof fields and text, etc.  So, that's the one pointer icon transition that causes MOST of the black box flicker problems.

When I did this on my Win7 VMWare Guest, my Black Box Flicker problems went away almost completely.  There are a few niche cases where it still appears (scroll wheel, special program-specific mouse icons/shapes), but THIS GOT RID OF 99% of my Black Box Flicker Problems.

Of course the one side-effect is that you see the mouse pointer instead of the thin line of the cursor icon when you begin typing, and sometimes your mouse pointer follows you as you type...as did the default "Text Select" pointer icon that is not as noticible as the new icon....so this is JUST A temporary WORAROUND.

But, bottom line, until VMWare fixes this issue, THIS IS THE ONLY WORKAROUND that has given me a HUGE relief of the Black Box Flicker Problems.

Mouse-Pointers-Scheme-Config-TextSelect-Icon.jpg  Mouse-Pointers-Scheme-Config-NormalSelect-Icon.jpg

***

IMPORTANT SOLUTION UPDATE on 20120927:

1) DISABLING (un-checking) "Enable Pointer Shadow" made this flicker black box problem COMPLETELY go AWAY for me on my Win7 Guest!!!

2)  In Addition, the technique above works when Pointer Shadow is enabled  as well >>> Replacing the "Text Select" icon/graphic made this  problem go away for me

***

Message was edited by: wrhahn on 20120927 >>> Added "DISABLING (un-checking) "Enable Pointer Shadow" made this flicker black box problem COMPLETELY go AWAY for me on my Win7 Guest!!!

0 Kudos
ErginOzturk
Contributor
Contributor

Hi folks,

I was also having annoying black squares on my new Macbook retina with Windows 7 Ultimate guest on Fusion 5.0.1 and gone through threads. I had a solution at last, I guess problem is related with mouse cursor settings. I have no need for cursor animations so I have changed cursor settings as follows and I had never seen black boxes anymore.

Please see attached screenshot.

Best regards,

Ergin Ozturk

BIZCON Consulting

0 Kudos
djphat2000
Enthusiast
Enthusiast

This seems to have helped as well for me. 

I could make the black box come and go easily in Outlook 2010 just by going over the lines/boarders.  Seems to have gone away after doing this. 

This is maybe a graphics drive bug maybe?  Just a guess. 

Thanks for the help guys.  Smiley Happy

0 Kudos
wrhahn
Contributor
Contributor

ErginOzturk,

Did you set "Text Select" to the same icon as "Normal Select" like I did in my "WORKAROUND to Eliminate Black Box Flicker Problem:" post above your post?

I don't see anything special in your screenshot of the Mouse settings.  Maybe you didn't notice that the "Text Select" setting is cutoff in your screenshot?

Thanks in advance for additional clarification about what was *special* about what you did and/or what you were trying to show in your screenshot.

0 Kudos