macdamit
Contributor
Contributor

Mouse disappears in Windows 10 Guest

My guest operating system is Windows 10.  I have the latest version of Fusion 11.1 installed on the host (MacBook Pro) and VMWare Tools installed on Windows 10. 

My problem is that inside the guest operating system the mouse pointer disappears from view.  If I right click the mouse the menu comes up, so I can tell that the mouse is working.  It is just invisible. Sometimes it reappears for a short time but then it disappears again.  I've spent hours and hours going through the various VMWare KB articles with no success.  Please help! 

6 Replies
wila
Leadership
Leadership

Hi,

It's something I have seen happen, but in my case very rare and usually easy to reset by clicking somewhere.

Can you check the following two settings please.

With your VM selected, go to menu -> Virtual Machine -> Settings -> Keyboard & Mouse

I have this:

pastedImage_0.png

So in my case I have a Windows 10 Profile selected.

Next up in menu "VMware Fusion" -> Preferences

pastedImage_1.png

Normally the default for Gaming "Auto-detect mouse for games" works well.

If that doesn't help, then you might want to try "Never optimize mouse for games"

Still no success?

Do you perhaps have a driver or other software installed that can interfere with your mouse?

--

Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
fredrikwidmark
Contributor
Contributor

I had problem with invisible mouse pointer with VmWare Fusion 11.1.1 and running a "Windows Server 2012 R2" guest OS. The problem did occur several times last months, mostly after Windows updates. It usually went away after a few reboots, but the last time I couldn't get rid of the problem, until I tested the suggested change above:

Checking "Never optimize mouse for games"

...and rebooting I finally get my mouse pointer visible again. Thank you for posting a solution!

0 Kudos
dsohayda
Enthusiast
Enthusiast

this issue was driving me crazy, but your suggestion of changing to "Never optimize mouse for games" fixed it for me.

Thank you for posting this

0 Kudos
stazeii
Contributor
Contributor

Setting Never Optimize for Games fixed this issue with a Windows Server 2016 guest OS.

THANK YOU!

0 Kudos
Nick_tnt
Contributor
Contributor

I spent a long time, VMwas good on another Mac, import another vm it also has the same problem.  So everything pointed to accessibility so this is what worked for me

1 shutdown vm and vmfusion

2 go to system preferences > Security and privacy

3 click on accessibility on the bottom of the left table.

4 click on the lock icon and put in you admin password

5 in the table select VMfusion

6 at the bottom of the table click the " - " to delete it. .. It should not be int the table at all now.

7 at the bottom of the table click on "+" to add an item.  got to application directory and selected vmfusion

8 make sure it is now selected

9 close up and restart VMware. 

10. Big smile and fist pumps.  helps to the world all is good again.  @

let me know how you went...

0 Kudos
shiiki
Contributor
Contributor

This work-around really works great on my Mac with the Fusion.

Great job, Nick_nut! Kudos to you!You saved may day. Thank you so much!Smiley Happy

0 Kudos