VMware Communities
ccalabro
Contributor
Contributor
Jump to solution

Monitor all network activity

Hi All,

I am running the latest update of Fusion 13.5

I have an issue where I a have setup a test lab and am running Kali Linux to dsniff the network traffic.  This prompts Fusion to throw up the require Administrator access required box which I authenticate.  This seems to have no effect.  

It would seem as though Fusion is blocking the functionality as it won't remember the permission granted.

Any assistance greatly appreciated.

CC

Labels (1)
Reply
0 Kudos
1 Solution

Accepted Solutions
palter
Enthusiast
Enthusiast
Jump to solution

In Fusion's settings, in Network, you can turn off "Require authentication to enter promiscuous mode".

Promiscuous Mode.png

Mac mini (M2 Pro/32GB/2TB), Intel NUC10i5FNH w/ESXi 7.0,
iPhone 15 Pro Max (256GB), iPad Pro 12.9" (5th gen, M1/16GB/1TB)
41mm Watch Series 9 (Aluminum), TV 4K (3rd gen), TV 4K (1st gen)

View solution in original post

Reply
0 Kudos
7 Replies
palter
Enthusiast
Enthusiast
Jump to solution

In Fusion's settings, in Network, you can turn off "Require authentication to enter promiscuous mode".

Promiscuous Mode.png

Mac mini (M2 Pro/32GB/2TB), Intel NUC10i5FNH w/ESXi 7.0,
iPhone 15 Pro Max (256GB), iPad Pro 12.9" (5th gen, M1/16GB/1TB)
41mm Watch Series 9 (Aluminum), TV 4K (3rd gen), TV 4K (1st gen)
Reply
0 Kudos
ccalabro
Contributor
Contributor
Jump to solution

I dont see that option.  Is that because I am not on Pro?

Reply
0 Kudos
palter
Enthusiast
Enthusiast
Jump to solution

Yes, it requires a Professional license.

Mac mini (M2 Pro/32GB/2TB), Intel NUC10i5FNH w/ESXi 7.0,
iPhone 15 Pro Max (256GB), iPad Pro 12.9" (5th gen, M1/16GB/1TB)
41mm Watch Series 9 (Aluminum), TV 4K (3rd gen), TV 4K (1st gen)
Reply
0 Kudos
ccalabro
Contributor
Contributor
Jump to solution

OK that makes sense.  

It was for a study lab for school.

Thanks for the reply.

Reply
0 Kudos
ccalabro
Contributor
Contributor
Jump to solution

Can I please ask, just to confirm.  that this will only work in Pro?  In player it pops the dialogue box up asking for Administrator permission which i give it but then does nothing.  Just trying to exactly work out if its not working as intended or will never work.

Sorry for the follow up.

Reply
0 Kudos
palter
Enthusiast
Enthusiast
Jump to solution

It works. I run Linux VMs configured with bridges (brctl) on their network interfaces. I then run emulators in those Linux VMs that generate network traffic with MAC and IP addresses different from their host Linux VMs.

I configure all my VMs to use VMware bridged networking.

Mac mini (M2 Pro/32GB/2TB), Intel NUC10i5FNH w/ESXi 7.0,
iPhone 15 Pro Max (256GB), iPad Pro 12.9" (5th gen, M1/16GB/1TB)
41mm Watch Series 9 (Aluminum), TV 4K (3rd gen), TV 4K (1st gen)
Tags (1)
Reply
0 Kudos
wila
Immortal
Immortal
Jump to solution


@ccalabro wrote:

Can I please ask, just to confirm.  that this will only work in Pro?


It used to work in Player too.. but we don't know if VMware has tightened this up to make it work on Pro only. Would be silly to ask for a password and then not work.

edit: to clarify, the UI is only in the pro version.
The popup in both player as well as pro. But in the past you could also make the setting manually in the config files (google it).

--
Wil

| Author of Vimalin. The virtual machine Backup app for VMware Fusion, VMware Workstation and Player |
| More info at vimalin.com | Twitter @wilva
Reply
0 Kudos