VMware Communities
borosga
Contributor
Contributor

MacOS Fusion Player 13.5 + Win 11: mouse not working

I am running Fusion Player 13.5 on my macbook pro (macOS Sonoma 14.3.1 (23D60), M1 Pro CPU). In the windows 11 arm virtual machine, the mouse does not work (I can't see the cursor and it doesn't respond to clicks) but the keyboard works. Is there a solution to the mouse problem?
Thanks

Tags (3)
Reply
0 Kudos
19 Replies
Technogeezer
Immortal
Immortal

What build of Windows 11 ARM are you using, and was it an installation from the ISO downloaded through Fusion's built-in "Get Windows from Microsoft" tool?

Are VMware Tools installed in the VM? If I remember correctly, Tools installs a VMware USB Pointing Device mouse driver.

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides
Reply
0 Kudos
borosga
Contributor
Contributor

Yes the win 11 was downloaded through "Get Windows from Microsoft" tool: 

Edition Windows 11 Pro
Version 23H2
Installed on ‎2/‎19/‎2024
OS build 22631.3155
Experience Windows Feature Experience Pack 1000.22684.1000.0

Yes VMware Tools is installed.

Reply
0 Kudos
Technogeezer
Immortal
Immortal

That's the same build I'm using on a Mac mini M1 also runing Sonoma 14.3.1.

If you can get Settings in the VM open using the keyboard, what does that say for the mouse? And if you can do that, can you open Device Manager in the VM and see if there's a VMware USB Pointing device in the "Mice and other pointing devices" category?

Are you using the integrated trackpad of that MacBook, or do you have an external mouse with its own mouse software?

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides
Tags (1)
Reply
0 Kudos
borosga
Contributor
Contributor

I'm using the integrated trackpad. Photos about mouse settings: 

mousesettings.pngdevicemanager.pngmousesettings3.pngmousesettings2.png

The strange thing is if i hover my mac cursor on the VM window then windows cursor appear but freeze in one location and I can't click with it neither. I upload a screen recording about this: https://youtu.be/xJS5qE9QSM8

 

Reply
0 Kudos
borosga
Contributor
Contributor

I created an ubuntu VM and got the same error: integrated keyboard works but integrated trackpad not works

Reply
0 Kudos
msimanyi
Contributor
Contributor

I'm guessing you already figured out a workaround, but for anyone else searching on this, I reverted to Hardware Version 19 (not 21) to restore mouse function in my Win 11 vm hosted on an Intel-based Mac.

For anyone using that combo of software: virtual machine / settings / compatibility / advanced then "downgrade" from hardware version 21.

It's not a solution, but it'll let you get on with your day.

Reply
0 Kudos
borosga
Contributor
Contributor

No, i haven't found a solution yet. I can't even use hardware version 19 because of this: "This hardware version does not support the guest OS of this virtual machine."

borosga_0-1708891077266.png

 

Reply
0 Kudos
Technogeezer
Immortal
Immortal

Can you post the .vmx file of one of the VMs that are exhibiting this problem?

Also, the vmware.log and mksSandbox.log files?

All of these are found in the VM's bundle: see https://docs.vmware.com/en/VMware-Fusion/13/com.vmware.fusion.using.doc/GUID-F28A030E-D726-4F65-827D... if you don't know how to find them. 

 

 

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides
Reply
0 Kudos
msimanyi
Contributor
Contributor

That is... unfortunate.  I'm guessing you updated the encryption version to the latest.  Mine still posts the option along with the warning that it's not backwards compatible with older versions of Fusion.

Have you tried using an external mouse?  It might be useful to know whether or not that works, though personally I'd gather the logs requested by Technogeezer.

Reply
0 Kudos
borosga
Contributor
Contributor

I compressed the requested files in the attachment.

Reply
0 Kudos
Technogeezer
Immortal
Immortal

Here are some initial impressions that I see from the log files:

You are running with virtual hardware version 20.  Did you ever run this with virtual hardware version 21? You should be running with version 21 so that you get all the enhancements that VMware put in Fusion 13.5 (e.g. copy/paste/drag/drop, 3D acceleration). 

By the way, the reason that you could not set the virtual hardware version to 19 like  @msimanyi suggested is that  Fusion on Apple Silicon Macs (M1/2/3) only provides virtual hardware versions 20 and 21 for ARM architecture VMs. Virtual hardware versions 19 and lower apply to Intel arcitecture VMs only. 

First, make sure that VM is powered off, not suspended. Then with Fusion shut down, make a copy of it through the Finder. Just in case.

The logs seem to indicate that you're using a custom keyboard and mouse profile. If you are, please check the Fusion Settings > General and make sure that "Enable per-virtual machine keyboard shortcuts" is checked. Then go the to VM's Settings > Keyboard and Mouse  and select the "Windows 10 Profile" .

I'm also seeing that you have the Fusion mouse preferences set to "always optimize for games". Can you set that to "Auto-detect mouse for games" or "Never optimize mouse for games" and see if that changes things. 

 

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides
Reply
0 Kudos
Technogeezer
Immortal
Immortal

Another thought. I'm wondering if this could be a permissions issue. I don't see in your logs Fusion configuring the virtual mouse to your VM. 

If the other changes don't make any differenct, try a full uninstall of VMware Fusion per KB article https://kb.vmware.com/s/article/1017838 (don't simply drag the application to the trash). Then reboot and reinstall Fusion - granting it all permissions that it requests.

If you still can't get it to work, please repost those updated log files, and the support bundle that can be generated through Help > Collect Support Information > Quick

 

 

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides
Reply
0 Kudos
borosga
Contributor
Contributor

I have no option like this: Fusion Settings > General and make sure that "Enable per-virtual machine keyboard shortcuts"

borosga_0-1708980889914.png

I uninstalled VmWare based on KB article and reinstall Windows VM but still can't see cursor. The odd thing is that it didn't ask for any permission after reinstalled so it can be a permission issue but I don't know how to add permissions manually.

I attach the logs.

Reply
0 Kudos
Technogeezer
Immortal
Immortal

I'm running Fusion Pro - perhaps that's the difference that keeps you from seeing the keyboard shortcuts menu in the Fusion settings.

I see from the support bundle that you have some Logitech software on your system. Do you have a Logitech keyboard or mouse?

You might want to disable that software and see if that changes anything.

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides
Reply
0 Kudos
borosga
Contributor
Contributor

I did the following actions but still no cursor:

  1. uninstall Logitech App
  2. restart Mac
  3. Remove and re-add permission from Mac Settings / Privacy & Security / Accessiblity / VMWare Fusion
  4. delete Win 11 VM in VMWare
  5. Create new Win 11 VM
Reply
0 Kudos
Technogeezer
Immortal
Immortal

This is very strange, indeed.

If you create a new user, can you log in and run Fusion? 

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides
Reply
0 Kudos
Technogeezer
Immortal
Immortal

Also, I see you are running a lot of third party background applications, including Docker. Can you boot to safe mode so that these do not run automatically, and then try to run Fusion?

 

- Paul (Technogeezer)
Editor of the Unofficial Fusion Companion Guides
Reply
0 Kudos
borosga
Contributor
Contributor

I've created a new user, safe booted into it and create a new Win11 VM but still can't see cursor.

Attached the logs.

Reply
0 Kudos
VadikKuz
Contributor
Contributor

I have the same issue. Same setup but I'm running Windows XP. 
Is there any resolution for that? 

Reply
0 Kudos