AlanTheBeast
Enthusiast
Enthusiast

(Mac/Fusion 11.5) How do I make "Full Screen" Fusion a regular window and not in a "Space"

Jump to solution

On my previous setup (Fusion 7) I had the "full screen" Fusion as a window.  As such, my "side" display was happily showing whatever Mac apps that were there.

Now, even though I have Fusion in a single window (main iMac display) my side display is black.  When working on Windows I _do_ need that side display with those essential apps - And I don't want Unity or Single Window view.

Essentially: I can't find any setting to put Fusion into the same display Space as all other apps under Mac.

I recall fixing this in Fusion 7 (years ago) but can't seem to find it now.

Mac OS 10.14

1 Solution

Accepted Solutions
dempson
Enthusiast
Enthusiast

That isn't a Fusion issue, but a change in behaviour between macOS versions (on the host).

There is a setting in System Preferences > Mission Control: "Displays have separate spaces". I'm running macOS 10.14 and have that option turned on, and with Fusion 11.5.1 showing a VM full screen on one display, my other display is showing my normal Mac user interface.

If "Displays have separate spaces" is turned off then a full screen window results in other displays going black.

See this MacWorld article for details.

View solution in original post

7 Replies
dempson
Enthusiast
Enthusiast

That isn't a Fusion issue, but a change in behaviour between macOS versions (on the host).

There is a setting in System Preferences > Mission Control: "Displays have separate spaces". I'm running macOS 10.14 and have that option turned on, and with Fusion 11.5.1 showing a VM full screen on one display, my other display is showing my normal Mac user interface.

If "Displays have separate spaces" is turned off then a full screen window results in other displays going black.

See this MacWorld article for details.

View solution in original post

GlennyG
Enthusiast
Enthusiast

VMWare broke this back in version 8, maybe 7.  Apple decided on that useless full screen mode -- probably down to hiring some midrosoft person 😉 -- and VMWare decided to do what apple said rather than something useful.   Harsh,  but it's really annoying.

The older versions would work as you'd expect:  full screen and you could drag a window in front of it.  After whatever update it was it then went into the apple mode.  (This proves that VMWare chose to implement it in this way)

The half-baked workaround is to set Spaces up as different spaces per screen.  This means that the other monitor's not blacked out with fusion full screen in the other.  However you can't drag other windows in front of fusion.

I've kind of got used to it despite it being exceedingly stupid behaviour.  But hey,  that's progress.  Not.

dlhotka
Champion
Champion

The closest workaround is to opt-click the green button, which will maximize the window without turning it into a space.

0 Kudos
AlanTheBeast
Enthusiast
Enthusiast

A workaround has been to open my Windows apps as unity windows.  They can be smaller or full screen if needed.

Combined this with the suggestion above) of putting each display in separate spaces (which I don't really like).  I need to this "non spaced" to see how it works out.  Tomorrow.

So this works "good enough".

0 Kudos
AlanTheBeast
Enthusiast
Enthusiast

I haven't tried this yet, but noted for tomorrow.

0 Kudos
GlennyG
Enthusiast
Enthusiast

> The closest workaround is to opt-click the green button, which will maximize the window without turning it into a space.

Didn't know that 'trick' which maximises the window to the screen.  Alas it leaves the wasted menu bar space.

But a very useful point.

0 Kudos
ykcgpu
Contributor
Contributor

Thanks, I will give this a try.

0 Kudos