wwalker
Contributor
Contributor

MBP, Fusion 16, Guest is being suspended and Fusion exits when host is inactive (still powered on)

Jump to solution

New MacBookPro 16", running latest Big Sur, running latest VMware Fusion 12.

Guest  (Fedora 32) is running.  I walk away, screen saver kicks in.  VM is still running  (logging in a terminal in the guest).

1 hour after the screen saver kicks in, the logging in the guest stops.  An hour lafter that, the mac is still running, showing the screen saver.  I unlock it, Fusion is not running.  I restart Fusion.  The guest is suspended; when I start it up, the logging continues.  Looking at the time stamps in the logging, I see that it ran for an hour after the host's screen saver kicked in.

I have no idea why Fusion is being closed (probably by the host OS??)

Thank you for taking the time to look at this !!

Wayne

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
wwalker
Contributor
Contributor

So, for anyone else who runs into this, here is where the demon is:

System Preferences
-> Security and Privacy
  -> unlock the pad lock
    -> Advanced
      -> Uncheck "Log out after 60 minutes of inactivity"

:headdesk:

I'm told on IRC #macosx that by default this is not enabled.  Yet, I've had my machine for maybe 3 weeks, and I spend 99.99% of my time in my Fedora VM.  I booted the machine, upgraded to Big Sur, installed Fusion, copied my VM from my previous machine, and never touched macOS again until today trying to figure out this problem.

I didn't enable it.  My machine isn't corporate managed, so that didn't enable it.
So, don't assume that isn't your problem because "I wouldn't turn on auto logout, I hate auto logout", because something (the NSA??) may have turned it on.

Best of luck!

View solution in original post

0 Kudos
6 Replies
dlhotka
Champion
Champion

That's apple putting the machine to sleep 1 hour after the screen blanks.  In system preferences/energy check the 'prevent sleep when screen blanks' checkbox.

wwalker
Contributor
Contributor

Thank you @dlhotka .  However I already have that one checked (annoying as hades that that isn't an option when on battery, but that's a different issue).

It is still shutting it down.  but Not when it turns off the screen (I have that set to 15 minutes right now) .  I can still communicate with the VM until 1 hour of inactivity (45 minutes after it blanks the display...)

Wayne

0 Kudos
dlhotka
Champion
Champion

Hmm, is the guest itself set to sleep by chance?

wwalker
Contributor
Contributor

@dlhotka,

No, it isn't set to shut down.

I use the VM as a server, I've had it for years.

It's etiher a problem with Big Sur or with Fusion 12 (had to upgrade from 11.5 when I upgraded to Big Sur).

Of course Apple people say it is VMware ....  I can't find anything talking about Big Sur shutting down apps due to inactivity.

Wayne

 

0 Kudos
wwalker
Contributor
Contributor

So, for anyone else who runs into this, here is where the demon is:

System Preferences
-> Security and Privacy
  -> unlock the pad lock
    -> Advanced
      -> Uncheck "Log out after 60 minutes of inactivity"

:headdesk:

I'm told on IRC #macosx that by default this is not enabled.  Yet, I've had my machine for maybe 3 weeks, and I spend 99.99% of my time in my Fedora VM.  I booted the machine, upgraded to Big Sur, installed Fusion, copied my VM from my previous machine, and never touched macOS again until today trying to figure out this problem.

I didn't enable it.  My machine isn't corporate managed, so that didn't enable it.
So, don't assume that isn't your problem because "I wouldn't turn on auto logout, I hate auto logout", because something (the NSA??) may have turned it on.

Best of luck!

View solution in original post

0 Kudos
dlhotka
Champion
Champion

Wow - that's really odd, but definitely the culprit.

 

It's not by chance, a non-admin account it is?  maybe apple changed the default for those.

0 Kudos