sickofupgrades
Contributor
Contributor

MAC OSX Monterey - USB Arbitrator not running

I recently upgraded my MAC to Monterey and VMWare Fusion to 12 and the USB only connected to the MAC.

I have read all the technical blogs and vmware support doco and done everything suggested including removing / reinstalling VMWare v12 fusion software. i even went as far as removing the software reinstalling version 10 and low and behold the usb-arbitrator came back but of course you could run any of the VMs due to compatibility issues. I downgraded VMs but they didnt work with version 10 as the physical memory works differently. So its go around in circles trying to fix a problem. Is anyone else sick of upgrades, MAC of VMware - i dont care who causes the problem Im just sick of having functionality one day then upgrade and its hours of messing around to get back to features you once had in the old version.

Access to USB in your virtual machines is critical and now i simply dont have it. Any ideas other than look in Security preferences for extensions not allowed or removing /reinstalling as im on every frustrated verging on angry where i want to dump the MAc and VMWare and replace it with Windows and Virtualbox.....

0 Kudos
4 Replies
scott28tt
VMware Employee
VMware Employee

I've reported your thread so that moderators are notified it needs moving to the correct area for Fusion.

 


-------------------------------------------------------------------------------------------------------------------------------------------------------------

Although I am a VMware employee I contribute to VMware Communities voluntarily (ie. not in any official capacity)
VMware Training & Certification blog
0 Kudos
Technogeezer
Champion
Champion

Can you help us help you with a few more pieces of information?

  • Mac model you’re running on
  • What was the macOS version you were running before upgrade to Monterey?
  • What version of Fusion was installed when you upgraded your Mac to Monterey?
  • In what order did you upgrade Monterey and Fusion?

Some immediate thoughts.

When you say you removed/uninstalled Fusion, did you just move Fusion to the trash or did you perform a complete uninstall of Fusion and it’s support files per https://kb.vmware.com/s/article/1017838

You need to get Fusion 10 off that Monterey system because it will not run. Use the complete uninstall process as you will want all traces of the product removed. Reboot to clear any kexts that may still be running. Then reinstall Fusion 12. 

0 Kudos
Longrower
Contributor
Contributor

I have exactly the same problem.  2020 iMac, Monterey, VMWare Fusion Prof, 12.2.3.

VMWare connects to the drive (and disconnects the drive from the Mac) but the Fusion client (Linux in this case) cannot access the USB drive to mount it as a drive.

Has this problem been resolved and I just need to dig for the solution?  Fusion 10 has never been installed on this particular system.

Thanks!

0 Kudos
Technogeezer
Champion
Champion

This doesn’t sound like the exact same problem. Given that Fusion is offering to connect the drive to the VM, it initially appears that the usb-arbitrator is running. I do have a few questions. 

You say that the USB drive doesn’t mount, but have you checked that the disk device nodes (/dev:/sdb or something similar) for the USB drive have been created in the VM?
And that the USB drive has a file system that Linux understands (yeah, stupid question but has to be asked).
What Linux distribution are you using?