Pelodark
Contributor
Contributor

Leopard, VMware and Ubuntu

I am having a display problem and load failure when I start Ubuntu 7.10 and using Leopard (for the first time tonight). Prior to the Leopard upgrade Ubuntu 7.10 started up just fine and no errors. Now I get the following error during boot up:

The display server has been shut down about 6 times in the last 90 seconds. It is likely that something bad is going on. Waiting for 2 minutes before trying again on display 0.

Any hints?

0 Kudos
5 Replies
admin
Immortal
Immortal

Can you try a fresh install of Ubuntu to see if it's a global problem or just specific to that virtual machine?

0 Kudos
Pelodark
Contributor
Contributor

Did that already. No go. Rebooted, reinstalled, changed memory parameters and still nada. I even tried a reinstall using Parallels. Still no go. However, using Parallels my previous virtual systems still play. Not so with VMware. BTW...during this period of trying variations TM was not enabled. It is now though.

0 Kudos
nospamboz
Enthusiast
Enthusiast

What do you know? I can get the same "display server has been shut down" message

to reliably happen when I set my iMac display to "Thousands" of colours rather than

"Millions". And I'm on 10.4.10, not Leopard.

0 Kudos
nospamboz
Enthusiast
Enthusiast

Another user had the same "display server has been shut down" message in

OpenSUSE 10.3. They reported that adding the line:

Option "LVDSBiosNativeMode" "false"

to the "Device" section of /etc/X11/xorg.conf, and then re-installing VMware

tools would fix that problem.

(Look at the end of this thread: http://communities.vmware.com/thread/109560)

I had my doubts, since re-installing VMware tools would overwrite xorg.conf and

remove the added line. I tried it anyway, and, as expected, it didn't work (the

line was removed), and "Thousands color" mode still gets the "display server"

message.

Accrding to the Gutsy release notes, the LVDSBiosNativeMode setting has

something to do with ATI driver problems. My iMac does have an ATI card, but

I thought the VMware SVGA display driver would "mask" that in the Gutsy VM.

Should it be an issue?

0 Kudos
nospamboz
Enthusiast
Enthusiast

OK, this seems to be a problem with gdm in Gnome under Ubuntu Gutsy 7.10.

Looking on ubuntuforums, it looks like a number of people get this problem

on a number of platforms. I think the bug is more likely in gdm than Fusion.

In my case (15-bit colours and Fusion), it definitely doesn't happen with Feisty,

or in Gutsy with KDE instead of Gnome. In fact, if you force the system to

use xdm or kdm rather than gdm, you can log in fine (although the rest

of the system won't work very well). Also, it doesn't happen in Gutsy if

VMware Tools is not installed. Switching to 24-bit colour also fixes it.

Downgrading to the version of gdm that comes with Feisty doesn't fix it.

It must be a library thing.

I reckon the easiest thing to suggest right now is to use Kubuntu (and KDE)

instead of regular Gnome-based Ubuntu, if you need 7.10 and run into this

problem.

For the more technically inclined, probably changing the login so that X isn't

automatically started and gdm isn't used, permitting a simple text login

and "startx", would also work, as it would avoid gdm.

0 Kudos