VMware Communities
jonl123
Contributor
Contributor
Jump to solution

Keyboard & Mouse not working in Yosemite Virtual Machine

I'm trying to restore a Time Machine backup of an old Macbook Pro that was running Yosemite to a virtual machine in the latest version of Fusion.

It's taken some time but I'm now at the point where I've restored the backup and it starts up ok.

However, the keyboard and mouse do not work once the OS has started. They work ok during startup, so I can go in to Disk Utility for example.

I've tried Bluetooth and USB keyboards but none work - they all also work ok on the Mac, just not within the VM once the OS has started.

I did make some changes to the VMX file to allow Yosemite to install, hardware version, board id and similar - not sure if this could cause an issue? Makes no difference if I remove them.


Anyone got any ideas?

Reply
0 Kudos
1 Solution

Accepted Solutions
dariusd
VMware Employee
VMware Employee
Jump to solution

Here is one idea: A few older versions of OS X (from around the era of Yosemite) do not like our emulated USB3 (xHCI) controller, which would cause the keyboard and mouse to stop working inside the virtual machine.

Try shutting down the virtual machine and going into its Settings and choosing USB & Bluetooth, then expand Advanced USB options and set the USB Compatibility option to USB 2.0 or lower.  Then see if the guest OS can use the keyboard and mouse.

Hope this helps!

--

Darius

View solution in original post

8 Replies
ColoradoMarmot
Champion
Champion
Jump to solution

Yosemite is pretty old, are you restoring to a yosemite host?

BTW, Time machine is really unreliable to backup virtual machines - would strongly suggest a different option in the future.

Reply
0 Kudos
dariusd
VMware Employee
VMware Employee
Jump to solution

Here is one idea: A few older versions of OS X (from around the era of Yosemite) do not like our emulated USB3 (xHCI) controller, which would cause the keyboard and mouse to stop working inside the virtual machine.

Try shutting down the virtual machine and going into its Settings and choosing USB & Bluetooth, then expand Advanced USB options and set the USB Compatibility option to USB 2.0 or lower.  Then see if the guest OS can use the keyboard and mouse.

Hope this helps!

--

Darius

jonl123
Contributor
Contributor
Jump to solution

Thanks - switching to USB 2.0 resolved the issue.

Reply
0 Kudos
Alan_G
Contributor
Contributor
Jump to solution

Thanks; works like a charm.

Reply
0 Kudos
StJosephEdm
Contributor
Contributor
Jump to solution

Worked great. Thank you!

Reply
0 Kudos
Foggy09
Contributor
Contributor
Jump to solution

Hi Tried the advanced setting but it will not let me change the USB lower than the default of 3.1 which is greyed out and if I select keyboard and mouse the default profiles Mac Profile says disabled, Mac Profile 2 says Disabled, Have selected Profile Default and it says Enabled but still does not work.

Any suggestions. 

I want to run El Capitan on my MacBook Pro 16" under Monterey, VMWare so I can then install my older Adobe Design Collection.

Reply
0 Kudos
gringley
Hot Shot
Hot Shot
Jump to solution

The advanced setting can only be changed if the guest VM is shutdown.

Reply
0 Kudos
your9mare
Contributor
Contributor
Jump to solution

I directly edited vmx config file which is under my virtual machine/OS X 10.11 folder: changed virtualHW.version parameter from 19 to 15. The 15 is my arbitrary guess that makes El Captain run in Fusion Player 12.2.3  on my 2015 MBA running upgraded to Monterey, while the default 19 stuck the same mouse installation error. Yosemite should work the same fashion, maybe lower virtualHW.version

diff OS X 10.11.vmx.original OS X 10.11.vmx

< virtualHW.version = "19"

---

> virtualHW.version = "15" 

Do let us know if 2018 or new Maci can run El Captain/Yosemite after all, because some forum says Mac can't run older OSX version than the original OSX version the hardware release with. I am in the same shoe to prolong the life of Adobe CS5 which can only run El Captain 10.11 not higher

Reply
0 Kudos