fulmar2
Contributor
Contributor

Issue with keyboard and mouse mapping in VMware Fusion 12.2.3

I have a Windows 10VM running on Mac Monterrey.  Normally, I use the middle mouse button to switch between "spaces" on the Mac.  Spaces are useful when using the VM full screen because I can quickly switch between Mac and PC.  I set up the middle mouse button to do this, but I can also use the "spaces" key (F3) on my apple keyboard.  The problem is that since VMware 12.2.? this no longer works for me.  I THINK that the middle mouse button / F3 key are being sent to the VM rather than to the host.  I have tried all sorts of variations in key mappings / mouse shortcuts / Mac Host Shortcuts / Fusion Shortcuts... but no luck so far to map either the middle mouse button or the F3 key to the host.  Does anyone have an idea how to resolve this? Thanks!

0 Kudos
3 Replies
Technogeezer
Champion
Champion

I'm assuming that you're using a third-party mouse, since none of the Apple mice/trackpads have a "middle mouse button". If a third-party mouse, is there any software that's managing it? 

0 Kudos
fulmar2
Contributor
Contributor

Thanks for your reply.  Yes, it is a 3rd party mouse.  We could blame the mouse, but I'm also using an Apple keyboard, and the "spaces" button (the same as the F3 button) on the keyboard does not trigger spaces either. I'm pretty sure that the F3 and middle mouse button input are being sent to the guest when they should be going to the host.  The question I have is how do I map the middle mouse button and/or the F3 key to the host instead of the guest? I've tried key mapping and mouse settings in the preferences and cannot seem to get these to work. Thanks again for your reply.

0 Kudos
JamesKing75
Contributor
Contributor

Same Problem. I'm supposed to be catching up on VM's for my Unix class and my mouse (trackpad) won't work when trying to set it up or after it's done I tried a few that I've already done. I haven't changed anything, have the latest update, only thing that's different is my screen got replaced cuz I broke the last one accidentally.

I really don't want to have to use the computers at school as I like using mine so I can get used to doing them. Please help. I tried the online fix of creating a new profile under preferences didn't help. Any ideas would be great! TIA.

0 Kudos