jdbvmware
Contributor
Contributor

Internal Error on new 2018 MacBook Pro and Fusion 11

This is a continuation of this discussion: https://communities.vmware.com/message/2803862#2803862

When I take a VM from a working High Sierra installation (on a 2013 Mac Pro) and copy it to my new 2018 13" MacBook Pro with the new macOS Mojave, I get an Internal Error when I try to start the VM. Not a very descriptive error. Any idea how to fix this?

I had the same error on Fusion 10.x on the same machine. I've tried the various troubleshooting tips such as moving the application out of the Applications folder and then back again. This does trigger an install dialog and asks for an Admin password but the Security control panel warning does not repeat. This looks like a Kext permission problem.

9 Replies
Mikero
Community Manager
Community Manager

Can you generate the error and then run Help > Collect Support Information and share the .tgz?

-
Michael Roy - PM/PMM: Fusion & Workstation
0 Kudos
nancyz
VMware Employee
VMware Employee

Hi jdbvmware ,

Could you check if there is a folder named vmName.lck in vm bundle? Could you find a vmx process when this problem occur?

0 Kudos
jdbvmware
Contributor
Contributor

There is a folder called: 564df29d-8306-ea25-f656-3cf09c96d22d.vmem.lck

I see no sign of any process called vmx.

0 Kudos
jdbvmware
Contributor
Contributor

Not easily if this forum doesn't support uploads. I can mail it to someone.

0 Kudos
Parveen1988
Enthusiast
Enthusiast

Hi, Try  below:

1. Make sure you delete all .lck files from your virtual machine bundle, .lck are the locks files.

2. Try this command in terminal, kextstat | awk '$6 !~ /^com.apple/ { print $6 " \t " $7 }' this will load the kext status.

3. If you see that kexts are not loading, then the issue is isolated at Mac OS level, Go to System Preferences-Security & Privacy-General- See if you get any message, which requires you to "allow" the VMware Fusion so that kext could get loaded.

If this doesn't help, re-install Fusion.

1) Manually remove Fusion completely (better by using App cleaner from FreeMacSoft) and then execute the below commands in Terminal window on Mac Host

     xattr -l ~/Downloads/VMware-Fusion-xxxx.dmg

     xattr -dr com.apple.quarantine ~/Downloads/VMware-Fusion.xxxx.dmg (Here it would list you the possible quarantine, mostly chrome or safari, close that application) and run the command.

2. Install Fusion normally, this time, it should prompt you for the warning in Security & Preferences.

P.S: Note down your license key before uninstalling.

0 Kudos
altanis
Contributor
Contributor

I was able to resolve the "Internal error" issue and to install version 11 properly.

1. Do not start the "VMware Fusion.app" from the mounted .dmg

2. Remove all previous VMWare fusion installations. You could use e.g. "AppCleaner" (which, by the way, was used at the last upgrade hassle by an VMWare employee on my Mac 😉 )

3. Copy "VMWareFusion.app" to your Applications directory

4. Start "VMWareFusion.app" from the Applications directory

jdbvmware
Contributor
Contributor

I solved the problem for me. But I don't think it is a general solution. I suspect that you have to try many of the options presented in these pages and eventually something will work.

I'm fairly certain that the problem is with permissions for the kext's that are part of the application. These are essentially system files and drivers that run at nearly the highest privilege in macOS. As such, Apple has spent effort on recent updates to make the security around kexts more robust. If you install VMWare Fusion and go to your /Library/ folder (not your ~/Library/ folder), you will see something called StageExtensions. In there you see a few directories. I found the VMWare kexts in the /Library/StagedExtensions/Application/VMware Fusion.app folder. When I uninstall VMWare Fusion and reboot, they disappear.

One of the suggestions here was to install with a new Administrator account. I tried that but when I switched back to my normal admin account, I saw the same Internal Error. At the time, it didn't occur to me try running VMWare from the new admin account. After uninstalling everything VMWare installs for the 10th time and creating another new admin account, the install worked and I could run a VM but only from the new admin account. My normal account still failed with the dreaded "Internal Error".

This makes me believe that macOS is holding on to some old permissions and not installing the new kexts for my user because the old ones are incompatible. So I uninstalled everything for the 11th time (or so) and created another new admin account (BTW, delete old admin accounts when you are done with them, they can be a security hole unless you are very careful with passwords etc.) This time, I downgraded my normal user account to turn off administrative rights and rebooted again. I then reinstalled VMWare Fusion from the newly created (and now only) admin account. I launched Fusion and ran one of my development VMs. It started up and worked perfectly. I then logged off the temporary admin account and logged in to my normal but now non-admin account. I got about 2 dozen errors asking for my admin password. I entered a few but then just started hitting cancel until they all went away. I launched Fusion with a copy of the VM that I used from the other account. And it started up normally and worked without any issues. I subsequently gave myself back admin permissions, rebooted and VMWare still works. My problem seems 100% solved.

I can't say that this will fix other people's "Internal Error" problems but it worked for me. I suspect you will have to try multiple things until VMWare figures out the exact problem and issues an update.

0 Kudos
woodjasonj
Contributor
Contributor

The fix below worked for me and was mentioned in another post. Credit to Gideon007.

Shut Fusion down and use Finder (not any other file manager) to move the VM Ware Fusion.app to another folder and then back into the /applications folder (you need admin rights). Then start Fusion again and it should mention a security problem with the kernel extensions that you need to allow in the security settings of OS X.  You'll receive a pop-up to enable the feature and from there it should work fine.

0 Kudos
manish121
Contributor
Contributor

try clearing out your recycle bin, it may be hv previous vmware related files which may be giving error. It worked for me

Tags (1)
0 Kudos